aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-21 17:50:29 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-21 18:12:11 +0000
commitdd4df09808b40cac73f9bed55c8c2489bdee5f2f (patch)
tree620426dc7c675cc85684426d9d8bf4294d97ba81 /ftp
parenta5d2fb306f8e8274889e6d317675009b69f6b831 (diff)
downloadports-dd4df09808b40cac73f9bed55c8c2489bdee5f2f.tar.gz
ports-dd4df09808b40cac73f9bed55c8c2489bdee5f2f.zip
ftp/curl: Enable LIBSSH2 option by default
- Bump PORTREVISION for dependency change PR: 253939 Requested by: Dennis Clarke <dclarke@blastwave.org>
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 0e979ef5a475..fecff1337762 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -2,6 +2,7 @@
PORTNAME= curl
PORTVERSION= 7.77.0
+PORTREVISION= 1
CATEGORIES= ftp net www
MASTER_SITES= https://curl.se/download/ \
https://github.com/curl/curl/releases/download/curl-${PORTVERSION:S|.|_|g}/
@@ -37,7 +38,7 @@ OPTIONS_GROUP_PROTOCOL= DICT FTP GOPHER HTTP HTTP2 IMAP LDAP LDAPS LIBSSH2 POP3
OPTIONS_RADIO_SSL= GNUTLS NSS OPENSSL WOLFSSL
OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
OPTIONS_SINGLE_RESOLV= CARES THREADED_RESOLVER
-OPTIONS_DEFAULT=ALTSVC CA_BUNDLE COOKIES GSSAPI_${${SSL_DEFAULT} == base :?BASE :NONE} DICT FTP GOPHER HTTP HTTP2 IMAP NTLM OPENSSL POP3 PROXY RTSP SMTP TELNET TFTP THREADED_RESOLVER TLS_SRP
+OPTIONS_DEFAULT=ALTSVC CA_BUNDLE COOKIES GSSAPI_${${SSL_DEFAULT} == base :?BASE :NONE} DICT FTP GOPHER HTTP HTTP2 IMAP LIBSSH2 NTLM OPENSSL POP3 PROXY RTSP SMTP TELNET TFTP THREADED_RESOLVER TLS_SRP
ALTSVC_DESC= HTTP Alternative Services support
CA_BUNDLE_DESC= Enable CA bundle for OpenSSL/GnuTLS/mbedTLS
COOKIES_DESC= Cookies support