aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-21 21:12:52 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-21 21:12:52 +0000
commitee05a0fbe5a5835ca262c01f28de2f050c0d0da1 (patch)
tree589b5682961657065b1c61b6b672836e8700a24f /ftp
parent001aaa228796ee490eeb1f783a1d1fc1fdcd44f1 (diff)
downloadports-ee05a0fbe5a5835ca262c01f28de2f050c0d0da1.tar.gz
ports-ee05a0fbe5a5835ca262c01f28de2f050c0d0da1.zip
ftp/curl: Update to 7.78.0
- Remove METALINK option: all support removed by upstream - Update NTLM option: it has own configure option now Changes: https://curl.se/changes.html
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile10
-rw-r--r--ftp/curl/distinfo6
-rw-r--r--ftp/curl/files/patch-configure43
-rw-r--r--ftp/curl/files/patch-lib-url.c4
-rw-r--r--ftp/curl/files/patch-scripts-Makefile.in6
-rw-r--r--ftp/curl/files/patch-src-tool_operate.c6
-rw-r--r--ftp/curl/pkg-descr1
-rw-r--r--ftp/curl/pkg-plist2
8 files changed, 25 insertions, 53 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 003989669a15..06eae7629d11 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -1,8 +1,7 @@
# Created by: Neil Blakey-Milner <nbm@rucus.ru.ac.za>
PORTNAME= curl
-PORTVERSION= 7.77.0
-PORTREVISION= 1
+PORTVERSION= 7.78.0
CATEGORIES= ftp net www
MASTER_SITES= https://curl.se/download/ \
https://github.com/curl/curl/releases/download/curl-${PORTVERSION:S|.|_|g}/
@@ -30,7 +29,7 @@ CPE_VENDOR= haxx
SHEBANG_FILES= */*.pl
-OPTIONS_DEFINE= ALTSVC BROTLI CA_BUNDLE COOKIES CURL_DEBUG DEBUG DOCS EXAMPLES IDN IPV6 METALINK NTLM PROXY PSL STATIC TLS_SRP ZSTD
+OPTIONS_DEFINE= ALTSVC BROTLI CA_BUNDLE COOKIES CURL_DEBUG DEBUG DOCS EXAMPLES IDN IPV6 NTLM PROXY PSL STATIC TLS_SRP ZSTD
OPTIONS_GROUP= PROTOCOL
OPTIONS_RADIO= SSL
OPTIONS_SINGLE= GSSAPI RESOLV
@@ -108,15 +107,12 @@ LDAP_USE= OPENLDAP=yes
LDAPS_CONFIGURE_ENABLE= ldaps
LIBSSH2_CONFIGURE_WITH= libssh2
LIBSSH2_LIB_DEPENDS= libssh2.so:security/libssh2
-METALINK_CONFIGURE_WITH=libmetalink
-METALINK_LIB_DEPENDS= libmetalink.so:misc/libmetalink
-METALINK_LIBS= -lcrypto
MQTT_CONFIGURE_ENABLE= mqtt
NSS_CONFIGURE_WITH= nss
NSS_LIB_DEPENDS= libnss3.so:security/nss \
libnspr4.so:devel/nspr
NSS_USES= pkgconfig
-NTLM_CPPFLAGS_OFF= -DCURL_DISABLE_NTLM
+NTLM_CONFIGURE_ENABLE= ntlm
OPENSSL_CONFIGURE_WITH= ssl=${OPENSSLBASE}
OPENSSL_CPPFLAGS= -I${OPENSSLINC}
OPENSSL_LDFLAGS= -L${OPENSSLLIB}
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index b6af43894b3f..d4224ae59c67 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1622213928
-SHA256 (curl-7.77.0.tar.xz) = 0f64582c54282f31c0de9f0a1a596b182776bd4df9a4c4a2a41bbeb54f62594b
-SIZE (curl-7.77.0.tar.xz) = 2439336
+TIMESTAMP = 1626891030
+SHA256 (curl-7.78.0.tar.xz) = be42766d5664a739c3974ee3dfbbcbe978a4ccb1fe628bb1d9b59ac79e445fb5
+SIZE (curl-7.78.0.tar.xz) = 2440640
diff --git a/ftp/curl/files/patch-configure b/ftp/curl/files/patch-configure
index 540198a050c2..13c8672eb654 100644
--- a/ftp/curl/files/patch-configure
+++ b/ftp/curl/files/patch-configure
@@ -1,14 +1,6 @@
-Description: Tweak the build for a FreeBSD environment.
- Respect user-supplied CFLAGS
- Use the FreeBSD location of pkg-config's library directory.
- Check for librtmp in sensible locations in all cases.
-Forwarded: not-needed
-Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-12-19
-
---- configure.orig 2019-02-05 14:11:44 UTC
+--- configure.orig 2021-07-19 12:47:17 UTC
+++ configure
-@@ -3637,9 +3637,10 @@ $as_echo "$as_me: LIBS note: LIBS should
+@@ -3738,9 +3738,10 @@ $as_echo "$as_me: LIBS note: LIBS should only be used
-I*)
xc_bad_var_ldflags=yes
;;
@@ -22,7 +14,7 @@ Last-Update: 2010-12-19
esac
done
if test $xc_bad_var_ldflags = yes; then
-@@ -3709,9 +3710,10 @@ $as_echo "$as_me: $xc_bad_var_msg librar
+@@ -3810,9 +3811,10 @@ $as_echo "$as_me: $xc_bad_var_msg libraries. Use LIBS
xc_bad_var_cflags=no
for xc_word in $CFLAGS; do
case "$xc_word" in
@@ -36,33 +28,16 @@ Last-Update: 2010-12-19
-U*)
xc_bad_var_cflags=yes
;;
-@@ -17193,6 +17195,8 @@ $as_echo "$as_me: WARNING: compiler opti
- tmp_CFLAGS="$CFLAGS"
- tmp_CPPFLAGS="$CPPFLAGS"
-
-+# Do not remove the user-supplied debug flags in CFLAGS (PR/150854)
-+if false; then
- ac_var_stripped=""
- for word1 in $tmp_CFLAGS; do
- ac_var_strip_word="no"
-@@ -17223,6 +17227,7 @@ $as_echo "$as_me: WARNING: compiler opti
- done
- tmp_CPPFLAGS="$ac_var_stripped"
- squeeze tmp_CPPFLAGS
-+fi
-
- #
- if test "$want_debug" = "yes"; then
-@@ -17445,6 +17450,8 @@ $as_echo "$honor_optimize_option" >&6; }
+@@ -17213,6 +17215,8 @@ $as_echo "$honor_optimize_option" >&6; }
#
if test "$honor_optimize_option" = "yes"; then
-+# Do not remove the user-supplied optimization flags in CFLAGS (PR/150854)
++# Do not remove the user-supplied optimization flags in CFLAGS/CPPFLAGS (PR/150854)
+if false; then
ac_var_stripped=""
for word1 in $tmp_CFLAGS; do
ac_var_strip_word="no"
-@@ -17475,6 +17482,7 @@ $as_echo "$honor_optimize_option" >&6; }
+@@ -17243,6 +17247,7 @@ $as_echo "$honor_optimize_option" >&6; }
done
tmp_CPPFLAGS="$ac_var_stripped"
squeeze tmp_CPPFLAGS
@@ -70,7 +45,7 @@ Last-Update: 2010-12-19
if test "$want_optimize" = "yes"; then
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler accepts optimizer enabling options" >&5
-@@ -26706,30 +26714,30 @@ $as_echo "found" >&6; }
+@@ -28147,30 +28152,30 @@ $as_echo "found" >&6; }
;;
off)
LIB_RTMP="-lrtmp"
@@ -110,7 +85,7 @@ Last-Update: 2010-12-19
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-@@ -41169,9 +41177,10 @@ $as_echo "$as_me: LIBS note: LIBS should
+@@ -43354,9 +43359,10 @@ $as_echo "$as_me: LIBS note: LIBS should only be used
-I*)
xc_bad_var_ldflags=yes
;;
@@ -124,7 +99,7 @@ Last-Update: 2010-12-19
esac
done
if test $xc_bad_var_ldflags = yes; then
-@@ -41241,9 +41250,10 @@ $as_echo "$as_me: $xc_bad_var_msg librar
+@@ -43426,9 +43432,10 @@ $as_echo "$as_me: $xc_bad_var_msg libraries. Use LIBS
xc_bad_var_cflags=no
for xc_word in $CFLAGS; do
case "$xc_word" in
diff --git a/ftp/curl/files/patch-lib-url.c b/ftp/curl/files/patch-lib-url.c
index 6224c72f510a..40e5742e2d8c 100644
--- a/ftp/curl/files/patch-lib-url.c
+++ b/ftp/curl/files/patch-lib-url.c
@@ -3,9 +3,9 @@ Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2010-12-18
---- lib/url.c.orig 2020-12-08 07:39:35 UTC
+--- lib/url.c.orig 2021-07-20 21:07:48 UTC
+++ lib/url.c
-@@ -607,6 +607,10 @@ CURLcode Curl_init_userdefined(struct Curl_easy *data)
+@@ -630,6 +630,10 @@ CURLcode Curl_init_userdefined(struct Curl_easy *data)
CURL_HTTP_VERSION_1_1
#endif
;
diff --git a/ftp/curl/files/patch-scripts-Makefile.in b/ftp/curl/files/patch-scripts-Makefile.in
index 0ced59737639..8c785aa1eeb1 100644
--- a/ftp/curl/files/patch-scripts-Makefile.in
+++ b/ftp/curl/files/patch-scripts-Makefile.in
@@ -1,6 +1,6 @@
---- scripts/Makefile.in.orig 2019-03-25 21:03:52 UTC
+--- scripts/Makefile.in.orig 2021-07-19 12:47:18 UTC
+++ scripts/Makefile.in
-@@ -558,7 +558,7 @@ uninstall-am:
+@@ -578,7 +578,7 @@ uninstall-am:
.PRECIOUS: Makefile
@@ -9,7 +9,7 @@
$(ZSH_COMPLETION_FUNCTION_FILENAME): completion.pl
@CROSSCOMPILING_TRUE@ @echo "NOTICE: we can't generate zsh completion when cross-compiling!"
-@@ -573,9 +573,7 @@ $(FISH_COMPLETION_FUNCTION_FILENAME): co
+@@ -593,9 +593,7 @@ $(FISH_COMPLETION_FUNCTION_FILENAME): completion.pl
install-data-local:
@CROSSCOMPILING_TRUE@ @echo "NOTICE: we can't install zsh completion when cross-compiling!"
@CROSSCOMPILING_FALSE@ $(MKDIR_P) $(DESTDIR)$(ZSH_FUNCTIONS_DIR)
diff --git a/ftp/curl/files/patch-src-tool_operate.c b/ftp/curl/files/patch-src-tool_operate.c
index 57818ceb8161..58fbe73f458f 100644
--- a/ftp/curl/files/patch-src-tool_operate.c
+++ b/ftp/curl/files/patch-src-tool_operate.c
@@ -1,6 +1,6 @@
---- src/tool_operate.c.orig 2019-11-04 08:43:26 UTC
+--- src/tool_operate.c.orig 2021-07-19 07:19:57 UTC
+++ src/tool_operate.c
-@@ -992,20 +992,7 @@ static CURLcode single_transfer(struct G
+@@ -995,20 +995,7 @@ static CURLcode single_transfer(struct GlobalConfig *g
DEBUGASSERT(!outs->filename);
}
@@ -22,7 +22,7 @@
#ifdef __VMS
/* open file for output, forcing VMS output format into stream
mode which is needed for stat() call above to always work. */
-@@ -1022,6 +1009,19 @@ static CURLcode single_transfer(struct G
+@@ -1025,6 +1012,19 @@ static CURLcode single_transfer(struct GlobalConfig *g
}
outs->fopened = TRUE;
outs->stream = file;
diff --git a/ftp/curl/pkg-descr b/ftp/curl/pkg-descr
index df7e49ed9dad..b31b940547b9 100644
--- a/ftp/curl/pkg-descr
+++ b/ftp/curl/pkg-descr
@@ -11,3 +11,4 @@ form based upload, proxies, HTTP/2, cookies, user+password authentication
resume, proxy tunneling and more.
WWW: https://curl.se/
+WWW: https://github.com/curl/curl
diff --git a/ftp/curl/pkg-plist b/ftp/curl/pkg-plist
index 6147cd1e6461..227a383cf5bb 100644
--- a/ftp/curl/pkg-plist
+++ b/ftp/curl/pkg-plist
@@ -596,7 +596,7 @@ share/aclocal/libcurl.m4
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-double.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-event.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-formadd.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-poll.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-legacy.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-post.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-single.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-uv.c