aboutsummaryrefslogtreecommitdiff
path: root/games/3dc
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>1998-05-03 23:27:37 +0000
committerMatthew Hunt <mph@FreeBSD.org>1998-05-03 23:27:37 +0000
commit14b487fa47f592ac04c689b18581913c15020cbd (patch)
treed84fff509e41bb6ba2ee7a82eb3902b64df83c67 /games/3dc
parenta22982e021bde4f5f734aa038f4fe54f7a0507a3 (diff)
downloadports-14b487fa47f592ac04c689b18581913c15020cbd.tar.gz
ports-14b487fa47f592ac04c689b18581913c15020cbd.zip
Import of 3dc, a three-dimensional chess game for X11.
PR: 6491 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=10827
Diffstat (limited to 'games/3dc')
-rw-r--r--games/3dc/Makefile35
-rw-r--r--games/3dc/distinfo1
-rw-r--r--games/3dc/files/patch-aa35
-rw-r--r--games/3dc/pkg-comment1
-rw-r--r--games/3dc/pkg-descr2
-rw-r--r--games/3dc/pkg-plist7
6 files changed, 81 insertions, 0 deletions
diff --git a/games/3dc/Makefile b/games/3dc/Makefile
new file mode 100644
index 000000000000..381694e7427c
--- /dev/null
+++ b/games/3dc/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: 3Dc
+# Version required: 0.8.1
+# Date created: 2 May 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= 3Dc-0.8.1
+PKGNAME= 3dc-0.8.1
+CATEGORIES= games x11
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= games/strategy
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm \
+ Xaw3d\\.6\\.:${PORTSDIR}/x11/Xaw3d
+
+USE_X11= yes
+WRKSRC= ${WRKDIR}/3Dc
+
+do-build:
+ @ cd ${WRKSRC}/src; make
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/src/3Dc ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/3Dc
+.for file in 3Dc-rules.html ACKNOWLEDGEMENTS GPL README TODO
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/3Dc
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/3dc/distinfo b/games/3dc/distinfo
new file mode 100644
index 000000000000..a1d4ecf6d639
--- /dev/null
+++ b/games/3dc/distinfo
@@ -0,0 +1 @@
+MD5 (3Dc-0.8.1.tar.gz) = 9f577656749a4b67d8ff6b5283fdfe5f
diff --git a/games/3dc/files/patch-aa b/games/3dc/files/patch-aa
new file mode 100644
index 000000000000..518b8f27b67a
--- /dev/null
+++ b/games/3dc/files/patch-aa
@@ -0,0 +1,35 @@
+--- src/Makefile.orig Thu Apr 11 10:23:53 1996
++++ src/Makefile Sun May 3 19:20:18 1998
+@@ -13,7 +13,7 @@
+ # If your system doesn't have a unique define already, define one here.
+
+ # Linux
+-CONFIGS=-DHAVE_UNISTD_H -DHAVE_ULIMIT_H
++CONFIGS=-DHAVE_UNISTD_H
+ # OSF/Digital Unix/HPUX
+ #CONFIGS=-fPIC -DHAVE_UNISTD_H -DHAVE_ULIMIT_H
+ # Sun
+@@ -27,19 +27,19 @@
+ # can send me opinions at mailto:paulh@euristix.ie
+ PREFS=-DUNDO_ANY_MOVE
+
+-CC=gcc
++#CC=gcc
+ #DEBUG=-g -Wall -DDEBUG
+ DEBUG=
+-COPTIONS=-O2 -fstrength-reduce -fpcc-struct-return -DVERSION=\"${VERSION}\"
++COPTIONS=-DVERSION=\"${VERSION}\"
+
+-CFLAGS=${COPTIONS} ${DEBUG} ${CONFIGS} ${PREFS} -I../include
++CFLAGS+=${COPTIONS} ${DEBUG} ${CONFIGS} ${PREFS} -I../include -I${X11BASE}/include
+ LDOPTIONS=
+
+ # LDLIBS should include the name of your X library path if not /usr/lib;
+ # and I definitely recommend getting Xaw3d. The extra appearance doesn't
+ # appear much but it looks much better when it does.
+ # Linux
+-LDLIBS=-L/usr/X11R6/lib -lXpm -lXaw3d -lXmu -lXext -lXt -lX11
++LDLIBS=-L${X11BASE}/lib -lXpm -lXaw3d -lXmu -lXext -lXt -lX11
+ # Sun
+ #LDLIBS=-lXpm -lXaw -lXmu -lXext -lXt -lX11 -lm
+
diff --git a/games/3dc/pkg-comment b/games/3dc/pkg-comment
new file mode 100644
index 000000000000..edc08319d1cc
--- /dev/null
+++ b/games/3dc/pkg-comment
@@ -0,0 +1 @@
+3-Dimensional Chess for X Window System.
diff --git a/games/3dc/pkg-descr b/games/3dc/pkg-descr
new file mode 100644
index 000000000000..89d79d430705
--- /dev/null
+++ b/games/3dc/pkg-descr
@@ -0,0 +1,2 @@
+3-Dimensional Chess for X. Three boards, 96 pieces and 26 directions.
+3Dc is played with three chess boards arranged one above another.
diff --git a/games/3dc/pkg-plist b/games/3dc/pkg-plist
new file mode 100644
index 000000000000..4edc5063a7d8
--- /dev/null
+++ b/games/3dc/pkg-plist
@@ -0,0 +1,7 @@
+bin/3Dc
+share/doc/3Dc/3Dc-rules.html
+share/doc/3Dc/ACKNOWLEDGEMENTS
+share/doc/3Dc/GPL
+share/doc/3Dc/README
+share/doc/3Dc/TODO
+@dirrm share/doc/3Dc