aboutsummaryrefslogtreecommitdiff
path: root/games/3dc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/3dc
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'games/3dc')
-rw-r--r--games/3dc/Makefile2
-rw-r--r--games/3dc/files/patch-aa4
2 files changed, 3 insertions, 3 deletions
diff --git a/games/3dc/Makefile b/games/3dc/Makefile
index 0a06ec4a4e68..37b5de4073dc 100644
--- a/games/3dc/Makefile
+++ b/games/3dc/Makefile
@@ -16,7 +16,7 @@ DISTNAME= 3Dc-${PORTVERSION}
MAINTAINER= adam-ports@blacktabby.org
COMMENT= 3-Dimensional Chess for X Window System
-LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
USE_PERL5_BUILD=yes
USE_XORG= xpm
diff --git a/games/3dc/files/patch-aa b/games/3dc/files/patch-aa
index 5ab8f9a01388..791668f75d3e 100644
--- a/games/3dc/files/patch-aa
+++ b/games/3dc/files/patch-aa
@@ -21,7 +21,7 @@
+COPTIONS=-DVERSION=\"${VERSION}\"
-CFLAGS=${COPTIONS} ${DEBUG} ${CONFIGS} ${PREFS} -I../include
-+CFLAGS+=${COPTIONS} ${DEBUG} ${CONFIGS} ${PREFS} -I../include -I${X11BASE}/include
++CFLAGS+=${COPTIONS} ${DEBUG} ${CONFIGS} ${PREFS} -I../include -I${LOCALBASE}/include
LDOPTIONS=
# LDLIBS should include the name of your X library path if not /usr/lib;
@@ -29,7 +29,7 @@
# appear much but it looks much better when it does.
# Linux
-LDLIBS=-L/usr/X11R6/lib -lXpm -lXaw3d -lXmu -lXext -lXt -lX11
-+LDLIBS=-L${X11BASE}/lib -lXpm -lXaw3d -lXmu -lXext -lXt -lX11 -Wl,-rpath,${X11BASE}/lib
++LDLIBS=-L${LOCALBASE}/lib -lXpm -lXaw3d -lXmu -lXext -lXt -lX11 -Wl,-rpath,${LOCALBASE}/lib
# Sun
#LDLIBS=-lXpm -lXaw -lXmu -lXext -lXt -lX11 -lm