aboutsummaryrefslogtreecommitdiff
path: root/games/54321
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-08-22 12:15:01 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-08-22 12:15:01 +0000
commit8c82053608b44d7f8cd992bb70b9f66cb271957e (patch)
tree8d3b4841b5c2c79510e153ea3c59ed3fa3a61a3f /games/54321
parent624119f5e548790080a3c9bb1489bc31b413d04a (diff)
downloadports-8c82053608b44d7f8cd992bb70b9f66cb271957e.tar.gz
ports-8c82053608b44d7f8cd992bb70b9f66cb271957e.zip
Rename ARCH to OPSYS to fix build on amd64
Notes
Notes: svn path=/head/; revision=117017
Diffstat (limited to 'games/54321')
-rw-r--r--games/54321/Makefile4
-rw-r--r--games/54321/files/variables.GNU6
2 files changed, 7 insertions, 3 deletions
diff --git a/games/54321/Makefile b/games/54321/Makefile
index c65aeba9e4e4..5729355181fe 100644
--- a/games/54321/Makefile
+++ b/games/54321/Makefile
@@ -22,11 +22,15 @@ USE_SDL= image sdl
USE_GMAKE= yes
MAKEFILE= GNUmakefile
ALL_TARGET= all size
+USE_REINPLACE= yes
post-extract:
@${MKDIR} ${WRKSRC}/archs/FreeBSD
@${CP} ${FILESDIR}/variables.GNU ${WRKSRC}/archs/FreeBSD
+post-patch:
+ ${REINPLACE_CMD} -e "s,ARCH,OPSYS," ${WRKSRC}/GNUmakefile
+
post-build:
@${SED} -e "s;@PREFIX@;${PREFIX};g" \
${FILESDIR}/54321.sh > ${WRKSRC}/54321
diff --git a/games/54321/files/variables.GNU b/games/54321/files/variables.GNU
index e5867629c037..b833cd43716b 100644
--- a/games/54321/files/variables.GNU
+++ b/games/54321/files/variables.GNU
@@ -14,10 +14,10 @@ LDFLAGS += \
-L${SDL}/lib -Wl,-rpath -Wl,${SDL}/lib \
-lSDL_image -lSDL-1.1 -lSDLmain-1.1 -pthread -lpng
-prog: Release/54321-$(ARCH)
+prog: Release/54321-$(OPSYS)
-Release/54321-$(ARCH):
+Release/54321-$(OPSYS):
-@$(MKDIR_CMD)
echo '#!/bin/sh' > $@
- echo "cd ./bin/$(ARCH) && exec ./54321 \$$*" >> $@
+ echo "cd ./bin/$(OPSYS) && exec ./54321 \$$*" >> $@
chmod 755 $@