aboutsummaryrefslogtreecommitdiff
path: root/games/abe/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
commit3a283e24f296371e9b753c09e3e62a92ef3d8703 (patch)
tree88e0a2bbddafb5c9bdc18e8e02c5e59fb9f9d471 /games/abe/Makefile
parent7a0a8929bea1c510b4f30261d294a78b556b49d7 (diff)
downloadports-3a283e24f296371e9b753c09e3e62a92ef3d8703.tar.gz
ports-3a283e24f296371e9b753c09e3e62a92ef3d8703.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=299119
Diffstat (limited to 'games/abe/Makefile')
-rw-r--r--games/abe/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/games/abe/Makefile b/games/abe/Makefile
index 5b1715a95b31..5ebb76a609e7 100644
--- a/games/abe/Makefile
+++ b/games/abe/Makefile
@@ -25,8 +25,9 @@ CONFIGURE_ARGS= --with-data-dir=${DATADIR}
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
-OPTIONS= GOD_MODE "Enable God Mode (toggle with 'g')" off \
- OPTIMIZED_CFLAGS "Enable compilation optimizations" on
+OPTIONS_DEFINE= GOD_MODE OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
+GOD_MODE_DESC= Enable God Mode (toggle with 'g')
post-install:
@${MKDIR} ${DATADIR}
@@ -34,15 +35,15 @@ post-install:
@${CP} -R ${WRKSRC}/${d} ${DATADIR}
.endfor
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GOD_MODE) || defined(WITHOUT_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MGOD_MODE} || !empty{PORT_OPTIONS:MOPTIMIZED_CFLAGS}
post-patch:
-. if defined(WITH_GOD_MODE)
+. if ${PORT_OPTIONS:MGOD_MODE}
@${REINPLACE_CMD} -e 's|\(#define GOD_MODE\) 0|\1 1|' \
${WRKSRC}/src/Game.h
. endif
-. if defined(WITHOUT_OPTIMIZED_CFLAGS)
+. if empty(PORT_OPTIONS:MOPTIMIZED_CFLAGS}
@${REINPLACE_CMD} -e 's|-O2||g ; \
s|-fomit-frame-pointer||g ; \
s|-ffast-math||g ; \
@@ -51,4 +52,4 @@ post-patch:
. endif
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>