aboutsummaryrefslogtreecommitdiff
path: root/games/abuse_sdl
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-11-05 18:52:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-11-05 18:52:25 +0000
commit1c6d772e86e8ab93b132e790e8c8c4a34f44bb0f (patch)
treee82cbf8b845186836bdfbcabb06d228a406dbe20 /games/abuse_sdl
parent36f3f471e5ebe34392f14ccdbdb3cf6174af4c42 (diff)
downloadports-1c6d772e86e8ab93b132e790e8c8c4a34f44bb0f.tar.gz
ports-1c6d772e86e8ab93b132e790e8c8c4a34f44bb0f.zip
- Update to 0.7.1
PR: 140283 Submitted by: Chris Petrik <chris@officialunix.com> (maintainer)
Notes
Notes: svn path=/head/; revision=243849
Diffstat (limited to 'games/abuse_sdl')
-rw-r--r--games/abuse_sdl/Makefile17
-rw-r--r--games/abuse_sdl/distinfo6
-rw-r--r--games/abuse_sdl/files/patch-Makefile.in16
-rw-r--r--games/abuse_sdl/files/patch-configure15
-rw-r--r--games/abuse_sdl/files/patch-imlib-jmalloc.hpp10
-rw-r--r--games/abuse_sdl/pkg-plist5
6 files changed, 45 insertions, 24 deletions
diff --git a/games/abuse_sdl/Makefile b/games/abuse_sdl/Makefile
index 398a1361a18e..5a362a3b5eca 100644
--- a/games/abuse_sdl/Makefile
+++ b/games/abuse_sdl/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= abuse_sdl
-PORTVERSION= 0.7.0
-PORTREVISION= 5
+PORTVERSION= 0.7.1
CATEGORIES= games
-MASTER_SITES= http://abuse.zoy.org/raw-attachment/wiki/Downloads/ \
+MASTER_SITES= http://abuse.zoy.org/raw/Downloads/ \
http://epix.linux.tucows.com/files/ \
http://blueyonder.linux.tucows.com/files/ \
http://casemanl.linux.tucows.com/files/
-DISTNAME= abuse-sdl-${PORTVERSION}
+DISTNAME= abuse-${PORTVERSION}
MAINTAINER= chris@officialunix.com
COMMENT= An SDL port of the Abuse game engine
@@ -24,8 +23,16 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+WRKSRC= ${WRKDIR}/${DISTNAME}
-MAN6= abuse-sdl.6
+MAN6= abuse.6
+
+PLIST_FILES= bin/abuse.sdl \
+ share/abuse_sdl/abuse.bmp \
+ share/abuse_sdl/abuse.lsp \
+ share/abuse_sdl/abuse.png
+
+PLIST_DIRS= share/abuse_sdl
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
diff --git a/games/abuse_sdl/distinfo b/games/abuse_sdl/distinfo
index a441bcb6dd23..711b0d789b22 100644
--- a/games/abuse_sdl/distinfo
+++ b/games/abuse_sdl/distinfo
@@ -1,3 +1,3 @@
-MD5 (abuse-sdl-0.7.0.tar.gz) = 417f07dd34d92564f6a10260e4a41baa
-SHA256 (abuse-sdl-0.7.0.tar.gz) = 2efadf8a9f85ae4509a410d600172625c674f49c4e8eb56eed7bd697ea03e3bc
-SIZE (abuse-sdl-0.7.0.tar.gz) = 676076
+MD5 (abuse-0.7.1.tar.gz) = 439b607f291560a8f9698a2f09cffa63
+SHA256 (abuse-0.7.1.tar.gz) = 1516a19efc1b89715a8549109a0d87b71502d94fd8b782942e335b6782a1dd57
+SIZE (abuse-0.7.1.tar.gz) = 719285
diff --git a/games/abuse_sdl/files/patch-Makefile.in b/games/abuse_sdl/files/patch-Makefile.in
index 5948cd989362..fb83ac5303d6 100644
--- a/games/abuse_sdl/files/patch-Makefile.in
+++ b/games/abuse_sdl/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig Sat May 11 22:58:44 2002
-+++ Makefile.in Sat May 11 23:00:15 2002
-@@ -84,7 +84,7 @@
-
- man_MANS = abuse-sdl.6
-
+--- Makefile.in.old 2009-11-04 19:47:10.000000000 -0600
++++ Makefile.in 2009-11-04 19:48:20.000000000 -0600
+@@ -201,7 +201,7 @@
+ top_srcdir = @top_srcdir@
+ SUBDIRS = src
+ man_MANS = abuse.6
-datafiledir = $(datadir)/games/abuse
+datafiledir = $(datadir)/abuse_sdl
datafile_DATA = abuse.bmp abuse.lsp abuse.png
-
- EXTRA_DIST = abuse-sdl.6 abuse.bmp abuse.lsp abuse.png
+ EXTRA_DIST = bootstrap abuse.6 abuse.bmp abuse.lsp abuse.png
+ all: config.h
diff --git a/games/abuse_sdl/files/patch-configure b/games/abuse_sdl/files/patch-configure
index 2629b2c0ab4a..dfb33df019ff 100644
--- a/games/abuse_sdl/files/patch-configure
+++ b/games/abuse_sdl/files/patch-configure
@@ -1,11 +1,20 @@
--- configure.orig Sat May 11 23:00:27 2002
+++ configure Sat May 11 23:00:36 2002
-@@ -7568,7 +7568,7 @@
+@@ -3177,7 +3177,7 @@
+ echo "${ECHO_T}$ac_cv_exeext" >&6; }
+
+ rm -f conftest.$ac_ext
+-EXEEXT=$ac_cv_exeext
++EXEEXT=.sdl
+ ac_exeext=$EXEEXT
+ { echo "$as_me:$LINENO: checking for suffix of object files" >&5
+ echo $ECHO_N "checking for suffix of object files... $ECHO_C" >&6; }
+@@ -21887,7 +21887,7 @@
X_LIBS=-L$x_libraries
-EXPDATADIR="-DEXPDATADIR=\\\"$datadir/games/abuse\\\""
+EXPDATADIR="-DEXPDATADIR=\\\"$datadir/abuse_sdl\\\""
- echo "$as_me:7573: checking for XShmAttach in -lXext" >&5
- echo $ECHO_N "checking for XShmAttach in -lXext... $ECHO_C" >&6
+
+ { echo "$as_me:$LINENO: checking for XShmAttach in -lXext" >&5
diff --git a/games/abuse_sdl/files/patch-imlib-jmalloc.hpp b/games/abuse_sdl/files/patch-imlib-jmalloc.hpp
new file mode 100644
index 000000000000..635ef4a49752
--- /dev/null
+++ b/games/abuse_sdl/files/patch-imlib-jmalloc.hpp
@@ -0,0 +1,10 @@
+--- src/imlib/jmalloc.hpp.old 2009-11-04 20:07:54.000000000 -0600
++++ src/imlib/jmalloc.hpp 2009-11-04 20:08:16.000000000 -0600
+@@ -12,6 +12,7 @@
+
+
+ #include <stdlib.h>
++#include <stdint.h>
+
+ #ifdef MANAGE_MEM
+ enum {ALLOC_SPACE_STATIC,ALLOC_SPACE_CACHE};
diff --git a/games/abuse_sdl/pkg-plist b/games/abuse_sdl/pkg-plist
deleted file mode 100644
index e25abebd94c9..000000000000
--- a/games/abuse_sdl/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/abuse.sdl
-share/abuse_sdl/abuse.bmp
-share/abuse_sdl/abuse.lsp
-share/abuse_sdl/abuse.png
-@dirrm share/abuse_sdl