aboutsummaryrefslogtreecommitdiff
path: root/games/adgali/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-09-23 09:51:11 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-09-23 09:51:11 +0000
commit2451f0a4a9187da61fee937e908a68288bfe6cf3 (patch)
tree23adb2f380828eba6545a0bc9327368daa981c06 /games/adgali/Makefile
parent237889df706e224a1f9d5184ab901b907d3ecdaa (diff)
downloadports-2451f0a4a9187da61fee937e908a68288bfe6cf3.tar.gz
ports-2451f0a4a9187da61fee937e908a68288bfe6cf3.zip
Notes
Diffstat (limited to 'games/adgali/Makefile')
-rw-r--r--games/adgali/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/games/adgali/Makefile b/games/adgali/Makefile
new file mode 100644
index 000000000000..d1a629c77831
--- /dev/null
+++ b/games/adgali/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# New ports collection makefile for: adgali
+# Date created: Sep 23, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= adgali
+PORTVERSION= 0.1.0
+CATEGORIES= games devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12 \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ tiff:${PORTSDIR}/graphics/tiff \
+ png:${PORTSDIR}/graphics/png
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+USE_FREETYPE= yes
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= SDL_CONFIG=${SDL_CONFIG} \
+ CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L/usr/lib -lm"
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -r ${WRKSRC}/doc/html/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>