aboutsummaryrefslogtreecommitdiff
path: root/games/adgali
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-14 19:08:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-14 19:08:27 +0000
commit70e8b85a576f8fb5a85804226825a8ceec77ddf3 (patch)
tree543530ea74f61ae5f7ce7b65336770b449b5bfea /games/adgali
parent814956e97e5014b26248f44c09467bddf47075b6 (diff)
downloadports-70e8b85a576f8fb5a85804226825a8ceec77ddf3.tar.gz
ports-70e8b85a576f8fb5a85804226825a8ceec77ddf3.zip
Notes
Diffstat (limited to 'games/adgali')
-rw-r--r--games/adgali/Makefile13
-rw-r--r--games/adgali/files/patch-src-input-fontio_agl_bfontio.c11
-rw-r--r--games/adgali/files/patch-src-input-fontio_agl_ttfio.c11
-rw-r--r--games/adgali/files/patch-src_agl_main.c12
4 files changed, 39 insertions, 8 deletions
diff --git a/games/adgali/Makefile b/games/adgali/Makefile
index 5b699cb3f561..11eaa35d3c17 100644
--- a/games/adgali/Makefile
+++ b/games/adgali/Makefile
@@ -12,13 +12,14 @@ PORTREVISION= 3
CATEGORIES= games devel
MASTER_SITES= http://adgali.apiou.org/download/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@gahr.ch
COMMENT= An open source game library useful for 2D game development
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
- freetype.9:${PORTSDIR}/print/freetype2
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ execinfo.1:${PORTSDIR}/devel/libexecinfo
USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
@@ -28,18 +29,14 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib -lexecinfo"
CONFIGURE_ARGS= --enable-compile-optim=no
USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= "Does not build with gcc 4.2"
-.endif
-
.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
-BROKEN= "Configure fails"
+BROKEN= Configure fails
.endif
post-install:
diff --git a/games/adgali/files/patch-src-input-fontio_agl_bfontio.c b/games/adgali/files/patch-src-input-fontio_agl_bfontio.c
new file mode 100644
index 000000000000..4417ab121ca2
--- /dev/null
+++ b/games/adgali/files/patch-src-input-fontio_agl_bfontio.c
@@ -0,0 +1,11 @@
+--- src/input/fontio/agl_bfontio.c 2007-12-12 23:43:53.000000000 +0100
++++ src/input/fontio/agl_bfontio.c.orig 2007-12-12 23:43:41.000000000 +0100
+@@ -387,7 +387,7 @@
+ return 0;
+ }
+
+-static agl_fontio agl_bfnt_fontio = {
++agl_fontio agl_bfnt_fontio = {
+ agl_bfntis,
+ agl_bfntopen,
+ agl_bfntloadglyph,
diff --git a/games/adgali/files/patch-src-input-fontio_agl_ttfio.c b/games/adgali/files/patch-src-input-fontio_agl_ttfio.c
new file mode 100644
index 000000000000..a405eb78e8c8
--- /dev/null
+++ b/games/adgali/files/patch-src-input-fontio_agl_ttfio.c
@@ -0,0 +1,11 @@
+--- src/input/fontio/agl_ttfio.c.orig 2007-12-12 23:42:15.000000000 +0100
++++ src/input/fontio/agl_ttfio.c 2007-12-12 23:43:00.000000000 +0100
+@@ -481,7 +481,7 @@
+ return 1;
+ }
+
+-static agl_fontio agl_ttf_fontio = {
++agl_fontio agl_ttf_fontio = {
+ agl_ttfis,
+ agl_ttfopen,
+ agl_ttfloadglyph,
diff --git a/games/adgali/files/patch-src_agl_main.c b/games/adgali/files/patch-src_agl_main.c
new file mode 100644
index 000000000000..b53d84237906
--- /dev/null
+++ b/games/adgali/files/patch-src_agl_main.c
@@ -0,0 +1,12 @@
+--- src/agl_main.c.orig 2007-12-12 23:45:13.000000000 +0100
++++ src/agl_main.c 2007-12-12 23:47:00.000000000 +0100
+@@ -65,7 +65,8 @@
+ if (agl_initparachute() < 0)
+ return -1;
+
+- *phandle = (agl_handle) handle = (agl_container *) agl_malloc(sizeof(agl_container));
++ handle = agl_malloc(sizeof(agl_container));
++ *phandle = (agl_container *)handle;
+ if (*phandle == NULL)
+ {
+ agl_memerr();