aboutsummaryrefslogtreecommitdiff
path: root/games/alienwave
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-25 16:10:59 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-25 16:10:59 +0000
commitd1904a95140ae38397da87fcf6a2fdc1f5887911 (patch)
tree17b4c5f0279dba69816d8921054282c9ecf6a9fd /games/alienwave
parent042daf2242035db0624fc9424fa106b0fc587f5b (diff)
downloadports-d1904a95140ae38397da87fcf6a2fdc1f5887911.tar.gz
ports-d1904a95140ae38397da87fcf6a2fdc1f5887911.zip
Add alienwave.
A shoot'em up game written using ncurses where you control a spaceship and must kill as many alien spaceships as you can. WWW: http://www.cs.unibo.it/~pira/alienwave/aw.html PR: ports/83967 Submitted by: Travis Poppe <tlp@liquidx.org>
Notes
Notes: svn path=/head/; revision=140101
Diffstat (limited to 'games/alienwave')
-rw-r--r--games/alienwave/Makefile58
-rw-r--r--games/alienwave/distinfo2
-rw-r--r--games/alienwave/pkg-descr7
3 files changed, 67 insertions, 0 deletions
diff --git a/games/alienwave/Makefile b/games/alienwave/Makefile
new file mode 100644
index 000000000000..9f18bbb77644
--- /dev/null
+++ b/games/alienwave/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: alienwave
+# Date created: 23 July 2005
+# Whom: Travis Poppe <tlp@liquidx.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= alienwave
+PORTVERSION= 0.3.0
+CATEGORIES= games
+MASTER_SITES= http://www.cs.unibo.it/~pira/alienwave/
+
+MAINTAINER= tlp@liquidx.org
+COMMENT= Shoot'em up game written using ncurses
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+ALL_TARGET= ${PORTNAME}
+
+MAKE_ARGS= CC="${CC}" CFLAGS="-c ${CFLAGS}"
+
+PLIST_FILES= bin/alienwave
+PORTDOCS= README STORY TO_DO
+
+OPTIONS= RANDOM_LEVELS "Enable random waves" off \
+ LEVEL_EASY "Killing Xzarna: easy (default: medium)" off \
+ LEVEL_HARD "Killing Xzarna: hard (default: medium)" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_LEVEL_EASY)
+CFLAGS+= -DLEV_EASY
+.endif
+
+.if defined(WITH_LEVEL_HARD)
+CFLAGS+= -DLEV_HARD
+.endif
+
+.if defined(WITH_RANDOM_LEVELS)
+CFLAGS+= -DRANDOM_LEVELS
+.endif
+
+.if defined(WITH_LEVEL_EASY) && defined(WITH_LEVEL_HARD)
+pre-everything::
+ @${ECHO_CMD} "The LEVEL_EASY and LEVEL_HARD options are mutually exclusive."
+ @${ECHO_CMD} "Please run 'make config' again."
+ @${FALSE}
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/alienwave ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/alienwave/distinfo b/games/alienwave/distinfo
new file mode 100644
index 000000000000..407aeca61f79
--- /dev/null
+++ b/games/alienwave/distinfo
@@ -0,0 +1,2 @@
+MD5 (alienwave-0.3.0.tar.gz) = 7d30b2aabf18e588cb8f6998e555cdc9
+SIZE (alienwave-0.3.0.tar.gz) = 22046
diff --git a/games/alienwave/pkg-descr b/games/alienwave/pkg-descr
new file mode 100644
index 000000000000..5977223c245f
--- /dev/null
+++ b/games/alienwave/pkg-descr
@@ -0,0 +1,7 @@
+A shoot'em up game written using ncurses where you control a spaceship and
+must kill as many alien spaceships as you can.
+
+WWW: http://www.cs.unibo.it/~pira/alienwave/aw.html
+
+- Travis Poppe
+tlp@liquidx.org