aboutsummaryrefslogtreecommitdiff
path: root/games/allacrost
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-06-14 20:26:58 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-06-14 20:26:58 +0000
commit8d0b1d1c57a7836ca504297baa673b58bfa27be4 (patch)
treeda87de0bd6c0990f5ba0934fa696cf9ba74afbfe /games/allacrost
parentb7a3622d38d3f7883d3bcbef1b2bb095740dd28e (diff)
downloadports-8d0b1d1c57a7836ca504297baa673b58bfa27be4.tar.gz
ports-8d0b1d1c57a7836ca504297baa673b58bfa27be4.zip
Notes
Diffstat (limited to 'games/allacrost')
-rw-r--r--games/allacrost/Makefile29
-rw-r--r--games/allacrost/distinfo6
-rw-r--r--games/allacrost/files/patch-src-engine-video-video.cpp29
-rw-r--r--games/allacrost/files/patch-src-main.cpp18
-rw-r--r--games/allacrost/pkg-message24
-rw-r--r--games/allacrost/pkg-plist328
6 files changed, 137 insertions, 297 deletions
diff --git a/games/allacrost/Makefile b/games/allacrost/Makefile
index 45c5b3a6ba9e..b8e1db3e0b0f 100644
--- a/games/allacrost/Makefile
+++ b/games/allacrost/Makefile
@@ -6,44 +6,45 @@
#
PORTNAME= allacrost
-PORTVERSION= 0.1.0
-PORTREVISION= 1
+PORTVERSION= 0.2.0
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= allacrost_demo_source_${PORTVERSION}
MAINTAINER= amdmi3@amdmi3.ru
COMMENT= A single player 2D role-playing game
+BUILD_DEPENDS= ${LOCALBASE}/lib/libluabind.a:${PORTSDIR}/devel/luabind
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LUA= 5.0
-USE_SDL= sdl ttf mixer
+USE_SDL= sdl mixer ttf net
USE_GL= yes
+USE_GCC= 4.0+
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --datadir=${DATADIR}
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -L${LUA_LIBDIR}" \
- CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -I${LUA_INCDIR}"
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${LUA_LIBDIR}" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${LUA_INCDIR}"
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-USE_GCC= 4.0+
-.endif
+PORTDOCS= MANUAL
post-patch:
@${REINPLACE_CMD} -e 's|exit -1|exit 1|; /CXXFLAGS=/ d; \
s|-lSDL |`${SDL_CONFIG} --libs` |' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|DATADIR|"${DATADIR}"|' ${WRKSRC}/src/main.cpp
post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/allacrost/distinfo b/games/allacrost/distinfo
index 78f854082509..c0f7771116cd 100644
--- a/games/allacrost/distinfo
+++ b/games/allacrost/distinfo
@@ -1,3 +1,3 @@
-MD5 (allacrost_demo_source_0.1.0.tar.gz) = 1896eb2a6b369fc370b2043e49e9f7a7
-SHA256 (allacrost_demo_source_0.1.0.tar.gz) = 6528b7097db5ab254ad97b614fd73f479a43088877c845f9fa3054786515dc97
-SIZE (allacrost_demo_source_0.1.0.tar.gz) = 17367178
+MD5 (allacrost_demo_source_0.2.0.tar.gz) = 59025166c3de60e9492fa2510687cf3c
+SHA256 (allacrost_demo_source_0.2.0.tar.gz) = dcf07c5955cf2e397c97b55e5c35b506f7e67a4a42168c8d20dd2e958853366b
+SIZE (allacrost_demo_source_0.2.0.tar.gz) = 51020536
diff --git a/games/allacrost/files/patch-src-engine-video-video.cpp b/games/allacrost/files/patch-src-engine-video-video.cpp
deleted file mode 100644
index e3e05aec96ad..000000000000
--- a/games/allacrost/files/patch-src-engine-video-video.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/engine/video/video.cpp.orig Wed Oct 4 02:42:52 2006
-+++ src/engine/video/video.cpp Wed Oct 4 03:19:03 2006
-@@ -247,8 +247,6 @@
-
- // make a temp directory and make sure it doesn't contain any files
- // (in case the game crashed during a previous run, leaving stuff behind)
-- MakeDirectory("temp");
-- CleanDirectory("temp");
-
- // enable text shadows
- EnableTextShadow(true);
-@@ -438,8 +436,6 @@
- delete iImage->second;
- ++iImage;
- }
--
-- RemoveDirectory("temp");
- }
-
-
-@@ -1393,7 +1389,7 @@
- string GameVideo::_CreateTempFilename(const string &extension)
- {
- // figure out the temp filename to return
-- string filename = "temp/TEMP_";
-+ string filename = "/tmp/allacrost_TEMP_";
- filename += _nextTempFile;
- filename += extension;
-
diff --git a/games/allacrost/files/patch-src-main.cpp b/games/allacrost/files/patch-src-main.cpp
index 9b8704a1a47b..e4782fa21e9a 100644
--- a/games/allacrost/files/patch-src-main.cpp
+++ b/games/allacrost/files/patch-src-main.cpp
@@ -1,10 +1,10 @@
---- src/main.cpp.orig Mon Sep 11 00:31:22 2006
-+++ src/main.cpp Wed Oct 4 03:11:59 2006
-@@ -84,6 +84,7 @@
-
- // Every great game begins with a single function :)
- int32 main(int32 argc, char *argv[]) {
+--- src/main.cpp.orig Thu Jun 7 00:18:13 2007
++++ src/main.cpp Thu Jun 7 01:18:11 2007
+@@ -96,6 +96,7 @@
+ ***
+ **/
+ bool InitializeEngine() {
+ chdir(DATADIR);
- // When the program exits, first the QuitAllacrost() function, followed by SDL_Quit()
- atexit(SDL_Quit);
- atexit(QuitAllacrost);
+ // Initialize SDL. The video, audio, and joystick subsystems are initialized elsewhere.
+ if (SDL_Init(SDL_INIT_TIMER) != 0) {
+ cerr << "MAIN ERROR: Unable to initialize SDL: " << SDL_GetError() << endl;
diff --git a/games/allacrost/pkg-message b/games/allacrost/pkg-message
index fc6445c906ee..2411de6cc1de 100644
--- a/games/allacrost/pkg-message
+++ b/games/allacrost/pkg-message
@@ -1,16 +1,8 @@
-ATTENTION!
-
-This is a first demo release of Hero of Allacrost, so don't expect
-it to be much playable.
-
-From the website:
-"One thing we wish to mention right off the bat is: don't expect too
-much from this first release. This release demonstrates the basic
-components of map exploration, dialogue, battles, and character
-management, but not much more. We are still missing a lot of artwork
-and some important sections from the code that would have made this
-release much more interactive and fun to play. What you will
-experience is nothing but the foundation to which we will continue
-to build the game off of, so don't be mistaken into thinking to
-yourself "What, that's it?" when you play the demo for the first
-time."
+Remember that Allacrost is still a work in progress, and this release
+remains a fair distance from what we want this game to eventually
+become. Please share with us your comments, critiques, and thoughts
+on our forum (http://www.allacrost.org/forum) after you play so we
+can absorb your feedback for our next release. If you have any
+issues with playing our demo, you can leave us a note on the forum
+or stop by our IRC channel (#allacrost at irc.freenode.net) and
+we'll help you out. Have fun!
diff --git a/games/allacrost/pkg-plist b/games/allacrost/pkg-plist
index 6d54fa565bba..6b47ab440bb9 100644
--- a/games/allacrost/pkg-plist
+++ b/games/allacrost/pkg-plist
@@ -1,22 +1,54 @@
bin/allacrost
+%%DATADIR%%/dat/actors/characters.lua
+%%DATADIR%%/dat/actors/enemies_set_01.lua
+%%DATADIR%%/dat/actors/enemies_set_02.lua
%%DATADIR%%/dat/config/boot.lua
%%DATADIR%%/dat/config/settings.lua
-%%DATADIR%%/dat/enemies/skeleton.lua
-%%DATADIR%%/dat/enemies/slime.lua
-%%DATADIR%%/dat/enemies/snake.lua
-%%DATADIR%%/dat/enemies/spider.lua
-%%DATADIR%%/dat/maps/desert_cave.lua
-%%DATADIR%%/dat/skills/sword_swipe.lua
-%%DATADIR%%/dat/tilesets/tiles_database.lua
+%%DATADIR%%/dat/credits.lua
+%%DATADIR%%/dat/maps/demo_cave.lua
+%%DATADIR%%/dat/maps/demo_town.lua
+%%DATADIR%%/dat/objects/armor.lua
+%%DATADIR%%/dat/objects/items.lua
+%%DATADIR%%/dat/objects/weapons.lua
+%%DATADIR%%/dat/skills/attack.lua
+%%DATADIR%%/dat/skills/defense.lua
+%%DATADIR%%/dat/skills/support.lua
+%%DATADIR%%/dat/tilesets/desert_cave.lua
+%%DATADIR%%/dat/tilesets/desert_cave_ground.lua
+%%DATADIR%%/dat/tilesets/desert_cave_walls.lua
+%%DATADIR%%/dat/tilesets/desert_cave_walls2.lua
+%%DATADIR%%/dat/tilesets/desert_cave_water.lua
+%%DATADIR%%/dat/tilesets/mountain_house_exterior.lua
+%%DATADIR%%/dat/tilesets/mountain_house_exterior2.lua
+%%DATADIR%%/dat/tilesets/mountain_house_interior.lua
+%%DATADIR%%/dat/tilesets/mountain_landscape.lua
+%%DATADIR%%/dat/tilesets/test.lua
%%DATADIR%%/img/backdrops/battle/desert_cave.png
+%%DATADIR%%/img/backdrops/battle/desert_cave_anim.png
+%%DATADIR%%/img/backdrops/battle/mountain_village.png
%%DATADIR%%/img/backdrops/boot_screen00.jpg
%%DATADIR%%/img/fonts/COPYING
%%DATADIR%%/img/fonts/tarnhalo.ttf
%%DATADIR%%/img/fonts/vtc_switchblade_romance.ttf
+%%DATADIR%%/img/icons/actors/characters/claudius.png
+%%DATADIR%%/img/icons/actors/enemies/aerocephal.png
+%%DATADIR%%/img/icons/actors/enemies/arcana_drake.png
+%%DATADIR%%/img/icons/actors/enemies/aurum-drakueli.png
+%%DATADIR%%/img/icons/actors/enemies/daemarbora.png
+%%DATADIR%%/img/icons/actors/enemies/deceleon.png
+%%DATADIR%%/img/icons/actors/enemies/green_slime.png
+%%DATADIR%%/img/icons/actors/enemies/nagaruda.png
+%%DATADIR%%/img/icons/actors/enemies/scorpion.png
+%%DATADIR%%/img/icons/actors/enemies/skeleton.png
+%%DATADIR%%/img/icons/actors/enemies/snake.png
+%%DATADIR%%/img/icons/actors/enemies/spider.png
+%%DATADIR%%/img/icons/armor/cobalt_helm.png
%%DATADIR%%/img/icons/armor/karlate_breastplate.png
%%DATADIR%%/img/icons/armor/karlate_greaves.png
%%DATADIR%%/img/icons/armor/karlate_helmet.png
%%DATADIR%%/img/icons/armor/karlate_shield.png
+%%DATADIR%%/img/icons/armor/leather_chain_mail.png
+%%DATADIR%%/img/icons/armor/phoenix_shield.png
%%DATADIR%%/img/icons/battle/ap_indicator_fr0.png
%%DATADIR%%/img/icons/battle/ap_indicator_fr1.png
%%DATADIR%%/img/icons/battle/ap_indicator_fr2.png
@@ -30,13 +62,17 @@ bin/allacrost
%%DATADIR%%/img/icons/battle/swap_icon.png
%%DATADIR%%/img/icons/items/health_potion.png
%%DATADIR%%/img/icons/items/health_potion_large.png
+%%DATADIR%%/img/icons/weapons/iron_sword.png
%%DATADIR%%/img/icons/weapons/karlate_sword.png
+%%DATADIR%%/img/logos/mac_logo.icns
%%DATADIR%%/img/logos/main_logo_background.png
%%DATADIR%%/img/logos/main_logo_sword.png
%%DATADIR%%/img/logos/main_logo_text.png
%%DATADIR%%/img/logos/program_icon.bmp
%%DATADIR%%/img/logos/program_icon.ico
+%%DATADIR%%/img/menus/bar_cover.png
%%DATADIR%%/img/menus/battle_bottom_menu.png
+%%DATADIR%%/img/menus/battle_character_menu.png
%%DATADIR%%/img/menus/black_sleet_b.png
%%DATADIR%%/img/menus/black_sleet_bl.png
%%DATADIR%%/img/menus/black_sleet_br.png
@@ -44,6 +80,7 @@ bin/allacrost
%%DATADIR%%/img/menus/black_sleet_parch.png
%%DATADIR%%/img/menus/black_sleet_quad.png
%%DATADIR%%/img/menus/black_sleet_r.png
+%%DATADIR%%/img/menus/black_sleet_skin.png
%%DATADIR%%/img/menus/black_sleet_t.png
%%DATADIR%%/img/menus/black_sleet_texture.png
%%DATADIR%%/img/menus/black_sleet_tl.png
@@ -56,12 +93,15 @@ bin/allacrost
%%DATADIR%%/img/menus/dialogue_box.png
%%DATADIR%%/img/menus/dialogue_nameplate.png
%%DATADIR%%/img/menus/locations/desert_cave.png
+%%DATADIR%%/img/menus/locations/mountain_village.png
+%%DATADIR%%/img/menus/stamina_bar.png
+%%DATADIR%%/img/menus/stamina_icon.png
+%%DATADIR%%/img/menus/stamina_icon_selected.png
+%%DATADIR%%/img/menus/status_icons.png
+%%DATADIR%%/img/misc/category_icons.png
+%%DATADIR%%/img/misc/dialogue_icon.png
%%DATADIR%%/img/misc/torch_light_mask.png
-%%DATADIR%%/img/portraits/battle/claudius.png
-%%DATADIR%%/img/portraits/battle/claudius_hp00.png
-%%DATADIR%%/img/portraits/battle/claudius_hp25.png
-%%DATADIR%%/img/portraits/battle/claudius_hp50.png
-%%DATADIR%%/img/portraits/battle/claudius_hp75.png
+%%DATADIR%%/img/portraits/battle/claudius_damage.png
%%DATADIR%%/img/portraits/map/claudius.png
%%DATADIR%%/img/portraits/map/claudius_small.png
%%DATADIR%%/img/portraits/map/laila.png
@@ -72,234 +112,65 @@ bin/allacrost
%%DATADIR%%/img/portraits/map/vanica_small.png
%%DATADIR%%/img/portraits/menu/claudius.png
%%DATADIR%%/img/portraits/menu/claudius_large.png
-%%DATADIR%%/img/sprites/battle/characters/claudius_idle_fr0.png
-%%DATADIR%%/img/sprites/battle/characters/claudius_idle_fr1.png
-%%DATADIR%%/img/sprites/battle/characters/claudius_idle_fr2.png
-%%DATADIR%%/img/sprites/battle/characters/claudius_idle_fr3.png
-%%DATADIR%%/img/sprites/battle/characters/claudius_idle_fr4.png
-%%DATADIR%%/img/sprites/battle/characters/claudius_idle_fr5.png
+%%DATADIR%%/img/sprites/battle/characters/claudius_idle.png
+%%DATADIR%%/img/sprites/battle/enemies/aerocephal.png
+%%DATADIR%%/img/sprites/battle/enemies/arcana_drake.png
+%%DATADIR%%/img/sprites/battle/enemies/aurum-drakueli.png
+%%DATADIR%%/img/sprites/battle/enemies/daemarbora.png
+%%DATADIR%%/img/sprites/battle/enemies/deceleon.png
%%DATADIR%%/img/sprites/battle/enemies/green_slime.png
-%%DATADIR%%/img/sprites/battle/enemies/green_slime_hp00.png
-%%DATADIR%%/img/sprites/battle/enemies/green_slime_hp33.png
-%%DATADIR%%/img/sprites/battle/enemies/green_slime_hp66.png
+%%DATADIR%%/img/sprites/battle/enemies/nagaruda.png
+%%DATADIR%%/img/sprites/battle/enemies/scorpion.png
%%DATADIR%%/img/sprites/battle/enemies/skeleton.png
-%%DATADIR%%/img/sprites/battle/enemies/skeleton_hp00.png
-%%DATADIR%%/img/sprites/battle/enemies/skeleton_hp33.png
-%%DATADIR%%/img/sprites/battle/enemies/skeleton_hp66.png
%%DATADIR%%/img/sprites/battle/enemies/snake.png
-%%DATADIR%%/img/sprites/battle/enemies/snake_hp00.png
-%%DATADIR%%/img/sprites/battle/enemies/snake_hp33.png
-%%DATADIR%%/img/sprites/battle/enemies/snake_hp66.png
%%DATADIR%%/img/sprites/battle/enemies/spider.png
-%%DATADIR%%/img/sprites/battle/enemies/spider_hp00.png
-%%DATADIR%%/img/sprites/battle/enemies/spider_hp33.png
-%%DATADIR%%/img/sprites/battle/enemies/spider_hp66.png
-%%DATADIR%%/img/sprites/map/claudius_d0.png
-%%DATADIR%%/img/sprites/map/claudius_d1.png
-%%DATADIR%%/img/sprites/map/claudius_d2.png
-%%DATADIR%%/img/sprites/map/claudius_d3.png
-%%DATADIR%%/img/sprites/map/claudius_d4.png
-%%DATADIR%%/img/sprites/map/claudius_d5.png
-%%DATADIR%%/img/sprites/map/claudius_l0.png
-%%DATADIR%%/img/sprites/map/claudius_l1.png
-%%DATADIR%%/img/sprites/map/claudius_l2.png
-%%DATADIR%%/img/sprites/map/claudius_l3.png
-%%DATADIR%%/img/sprites/map/claudius_l4.png
-%%DATADIR%%/img/sprites/map/claudius_l5.png
-%%DATADIR%%/img/sprites/map/claudius_r0.png
-%%DATADIR%%/img/sprites/map/claudius_r1.png
-%%DATADIR%%/img/sprites/map/claudius_r2.png
-%%DATADIR%%/img/sprites/map/claudius_r3.png
-%%DATADIR%%/img/sprites/map/claudius_r4.png
-%%DATADIR%%/img/sprites/map/claudius_r5.png
-%%DATADIR%%/img/sprites/map/claudius_u0.png
-%%DATADIR%%/img/sprites/map/claudius_u1.png
-%%DATADIR%%/img/sprites/map/claudius_u2.png
-%%DATADIR%%/img/sprites/map/claudius_u3.png
-%%DATADIR%%/img/sprites/map/claudius_u4.png
-%%DATADIR%%/img/sprites/map/claudius_u5.png
-%%DATADIR%%/img/sprites/map/laila_d0.png
-%%DATADIR%%/img/sprites/map/laila_d1.png
-%%DATADIR%%/img/sprites/map/laila_d2.png
-%%DATADIR%%/img/sprites/map/laila_d3.png
-%%DATADIR%%/img/sprites/map/laila_d4.png
-%%DATADIR%%/img/sprites/map/laila_d5.png
-%%DATADIR%%/img/sprites/map/laila_l0.png
-%%DATADIR%%/img/sprites/map/laila_l1.png
-%%DATADIR%%/img/sprites/map/laila_l2.png
-%%DATADIR%%/img/sprites/map/laila_l3.png
-%%DATADIR%%/img/sprites/map/laila_l4.png
-%%DATADIR%%/img/sprites/map/laila_l5.png
-%%DATADIR%%/img/sprites/map/laila_r0.png
-%%DATADIR%%/img/sprites/map/laila_r1.png
-%%DATADIR%%/img/sprites/map/laila_r2.png
-%%DATADIR%%/img/sprites/map/laila_r3.png
-%%DATADIR%%/img/sprites/map/laila_r4.png
-%%DATADIR%%/img/sprites/map/laila_r5.png
-%%DATADIR%%/img/sprites/map/laila_u0.png
-%%DATADIR%%/img/sprites/map/laila_u1.png
-%%DATADIR%%/img/sprites/map/laila_u2.png
-%%DATADIR%%/img/sprites/map/laila_u3.png
-%%DATADIR%%/img/sprites/map/laila_u4.png
-%%DATADIR%%/img/sprites/map/laila_u5.png
-%%DATADIR%%/img/sprites/map/marcus_d0.png
-%%DATADIR%%/img/sprites/map/marcus_d1.png
-%%DATADIR%%/img/sprites/map/marcus_d2.png
-%%DATADIR%%/img/sprites/map/marcus_d3.png
-%%DATADIR%%/img/sprites/map/marcus_d4.png
-%%DATADIR%%/img/sprites/map/marcus_d5.png
-%%DATADIR%%/img/sprites/map/marcus_l0.png
-%%DATADIR%%/img/sprites/map/marcus_l1.png
-%%DATADIR%%/img/sprites/map/marcus_l2.png
-%%DATADIR%%/img/sprites/map/marcus_l3.png
-%%DATADIR%%/img/sprites/map/marcus_l4.png
-%%DATADIR%%/img/sprites/map/marcus_l5.png
-%%DATADIR%%/img/sprites/map/marcus_r0.png
-%%DATADIR%%/img/sprites/map/marcus_r1.png
-%%DATADIR%%/img/sprites/map/marcus_r2.png
-%%DATADIR%%/img/sprites/map/marcus_r3.png
-%%DATADIR%%/img/sprites/map/marcus_r4.png
-%%DATADIR%%/img/sprites/map/marcus_r5.png
-%%DATADIR%%/img/sprites/map/marcus_u0.png
-%%DATADIR%%/img/sprites/map/marcus_u1.png
-%%DATADIR%%/img/sprites/map/marcus_u2.png
-%%DATADIR%%/img/sprites/map/marcus_u3.png
-%%DATADIR%%/img/sprites/map/marcus_u4.png
-%%DATADIR%%/img/sprites/map/marcus_u5.png
-%%DATADIR%%/img/sprites/map/rags_woman_d0.png
-%%DATADIR%%/img/sprites/map/rags_woman_d1.png
-%%DATADIR%%/img/sprites/map/rags_woman_d2.png
-%%DATADIR%%/img/sprites/map/rags_woman_d3.png
-%%DATADIR%%/img/sprites/map/rags_woman_d4.png
-%%DATADIR%%/img/sprites/map/rags_woman_d5.png
-%%DATADIR%%/img/sprites/map/rags_woman_l0.png
-%%DATADIR%%/img/sprites/map/rags_woman_l1.png
-%%DATADIR%%/img/sprites/map/rags_woman_l2.png
-%%DATADIR%%/img/sprites/map/rags_woman_l3.png
-%%DATADIR%%/img/sprites/map/rags_woman_l4.png
-%%DATADIR%%/img/sprites/map/rags_woman_l5.png
-%%DATADIR%%/img/sprites/map/rags_woman_r0.png
-%%DATADIR%%/img/sprites/map/rags_woman_r1.png
-%%DATADIR%%/img/sprites/map/rags_woman_r2.png
-%%DATADIR%%/img/sprites/map/rags_woman_r3.png
-%%DATADIR%%/img/sprites/map/rags_woman_r4.png
-%%DATADIR%%/img/sprites/map/rags_woman_r5.png
-%%DATADIR%%/img/sprites/map/rags_woman_u0.png
-%%DATADIR%%/img/sprites/map/rags_woman_u1.png
-%%DATADIR%%/img/sprites/map/rags_woman_u2.png
-%%DATADIR%%/img/sprites/map/rags_woman_u3.png
-%%DATADIR%%/img/sprites/map/rags_woman_u4.png
-%%DATADIR%%/img/sprites/map/rags_woman_u5.png
-%%DATADIR%%/img/sprites/map/vanica_d0.png
-%%DATADIR%%/img/sprites/map/vanica_d1.png
-%%DATADIR%%/img/sprites/map/vanica_d2.png
-%%DATADIR%%/img/sprites/map/vanica_d3.png
-%%DATADIR%%/img/sprites/map/vanica_d4.png
-%%DATADIR%%/img/sprites/map/vanica_d5.png
-%%DATADIR%%/img/sprites/map/vanica_l0.png
-%%DATADIR%%/img/sprites/map/vanica_l1.png
-%%DATADIR%%/img/sprites/map/vanica_l2.png
-%%DATADIR%%/img/sprites/map/vanica_l3.png
-%%DATADIR%%/img/sprites/map/vanica_l4.png
-%%DATADIR%%/img/sprites/map/vanica_l5.png
-%%DATADIR%%/img/sprites/map/vanica_r0.png
-%%DATADIR%%/img/sprites/map/vanica_r1.png
-%%DATADIR%%/img/sprites/map/vanica_r2.png
-%%DATADIR%%/img/sprites/map/vanica_r3.png
-%%DATADIR%%/img/sprites/map/vanica_r4.png
-%%DATADIR%%/img/sprites/map/vanica_r5.png
-%%DATADIR%%/img/sprites/map/vanica_u0.png
-%%DATADIR%%/img/sprites/map/vanica_u1.png
-%%DATADIR%%/img/sprites/map/vanica_u2.png
-%%DATADIR%%/img/sprites/map/vanica_u3.png
-%%DATADIR%%/img/sprites/map/vanica_u4.png
-%%DATADIR%%/img/sprites/map/vanica_u5.png
-%%DATADIR%%/img/tiles/ll_diagonal_wall_left_floor.png
-%%DATADIR%%/img/tiles/ll_diagonal_wall_right_floor.png
-%%DATADIR%%/img/tiles/ll_floor1.png
-%%DATADIR%%/img/tiles/ll_floor2.png
-%%DATADIR%%/img/tiles/ll_floor3.png
-%%DATADIR%%/img/tiles/ll_floor_horizontal_sand_left.png
-%%DATADIR%%/img/tiles/ll_floor_horizontal_sand_right.png
-%%DATADIR%%/img/tiles/ll_floor_shadow_full.png
-%%DATADIR%%/img/tiles/ll_floor_shadow_left.png
-%%DATADIR%%/img/tiles/ll_floor_shadow_middle.png
-%%DATADIR%%/img/tiles/ll_floor_shadow_right.png
-%%DATADIR%%/img/tiles/ll_floor_vertical_sand_bottom.png
-%%DATADIR%%/img/tiles/ll_floor_vertical_sand_top.png
-%%DATADIR%%/img/tiles/ll_wall_torch.png
-%%DATADIR%%/img/tiles/ll_water.png
-%%DATADIR%%/img/tiles/ll_water_inner_corner_left.png
-%%DATADIR%%/img/tiles/ll_water_inner_corner_right.png
-%%DATADIR%%/img/tiles/ll_water_left_edge.png
-%%DATADIR%%/img/tiles/ll_water_lower_edge.png
-%%DATADIR%%/img/tiles/ll_water_lower_left_corner.png
-%%DATADIR%%/img/tiles/ll_water_lower_right_corner.png
-%%DATADIR%%/img/tiles/ll_water_right_edge.png
-%%DATADIR%%/img/tiles/ll_water_upper_edge.png
-%%DATADIR%%/img/tiles/ll_water_upper_left_corner.png
-%%DATADIR%%/img/tiles/ll_water_upper_right_corner.png
-%%DATADIR%%/img/tiles/ol_cavewall_bottom.png
-%%DATADIR%%/img/tiles/ol_cavewall_bottom_hole1.png
-%%DATADIR%%/img/tiles/ol_cavewall_bottom_hole2.png
-%%DATADIR%%/img/tiles/ol_cavewall_bottom_hole2_eyes.png
-%%DATADIR%%/img/tiles/ol_cavewall_top.png
-%%DATADIR%%/img/tiles/ol_cavewall_top_hole1.png
-%%DATADIR%%/img/tiles/ol_cavewall_top_hole2.png
-%%DATADIR%%/img/tiles/ol_diagonal_wall_left_bottom.png
-%%DATADIR%%/img/tiles/ol_diagonal_wall_left_bottom_hole.png
-%%DATADIR%%/img/tiles/ol_diagonal_wall_left_top.png
-%%DATADIR%%/img/tiles/ol_diagonal_wall_left_top_connector.png
-%%DATADIR%%/img/tiles/ol_diagonal_wall_left_top_hole.png
-%%DATADIR%%/img/tiles/ol_diagonal_wall_right_bottom.png
-%%DATADIR%%/img/tiles/ol_diagonal_wall_right_bottom_hole.png
-%%DATADIR%%/img/tiles/ol_diagonal_wall_right_top.png
-%%DATADIR%%/img/tiles/ol_diagonal_wall_right_top_connector.png
-%%DATADIR%%/img/tiles/ol_diagonal_wall_right_top_hole.png
-%%DATADIR%%/img/tiles/ol_rock_01.png
-%%DATADIR%%/img/tiles/ol_rock_02.png
-%%DATADIR%%/img/tiles/ol_rock_03.png
-%%DATADIR%%/img/tiles/ol_rock_04.png
-%%DATADIR%%/img/tiles/ol_rock_05.png
-%%DATADIR%%/img/tiles/ol_rock_06.png
-%%DATADIR%%/img/tiles/ol_stalagmite_bottom.png
-%%DATADIR%%/img/tiles/ol_stalagmite_top.png
-%%DATADIR%%/img/tiles/ol_wallborder2_left.png
-%%DATADIR%%/img/tiles/ol_wallborder2_right.png
-%%DATADIR%%/img/tiles/ol_wallborder_down.png
-%%DATADIR%%/img/tiles/ol_wallborder_inside_corner_lower_left.png
-%%DATADIR%%/img/tiles/ol_wallborder_inside_corner_lower_right.png
-%%DATADIR%%/img/tiles/ol_wallborder_inside_corner_upper_left.png
-%%DATADIR%%/img/tiles/ol_wallborder_inside_corner_upper_right.png
-%%DATADIR%%/img/tiles/ol_wallborder_left1.png
-%%DATADIR%%/img/tiles/ol_wallborder_left2.png
-%%DATADIR%%/img/tiles/ol_wallborder_lower_left.png
-%%DATADIR%%/img/tiles/ol_wallborder_lower_left_outside_corner.png
-%%DATADIR%%/img/tiles/ol_wallborder_lower_right.png
-%%DATADIR%%/img/tiles/ol_wallborder_lower_right_outside_corner.png
-%%DATADIR%%/img/tiles/ol_wallborder_right1.png
-%%DATADIR%%/img/tiles/ol_wallborder_right2.png
-%%DATADIR%%/img/tiles/ol_wallborder_upper_left.png
-%%DATADIR%%/img/tiles/ol_wallborder_upper_right.png
-%%DATADIR%%/img/tiles/ul_bridge_bottom_left.png
-%%DATADIR%%/img/tiles/ul_bridge_bottom_middle.png
-%%DATADIR%%/img/tiles/ul_bridge_bottom_right.png
-%%DATADIR%%/img/tiles/ul_bridge_top_left.png
-%%DATADIR%%/img/tiles/ul_bridge_top_middle.png
-%%DATADIR%%/img/tiles/ul_bridge_top_right.png
-%%DATADIR%%/img/tiles/ul_roof_darkness.png
+%%DATADIR%%/img/sprites/map/boy_npc01_walk.png
+%%DATADIR%%/img/sprites/map/claudius_frightened.png
+%%DATADIR%%/img/sprites/map/claudius_walk.png
+%%DATADIR%%/img/sprites/map/gigas_walk.png
+%%DATADIR%%/img/sprites/map/girl_npc02_walk.png
+%%DATADIR%%/img/sprites/map/laila_walk.png
+%%DATADIR%%/img/sprites/map/man_npc01_walk.png
+%%DATADIR%%/img/sprites/map/man_npc02_walk.png
+%%DATADIR%%/img/sprites/map/marcus_walk.png
+%%DATADIR%%/img/sprites/map/naga_walk.png
+%%DATADIR%%/img/sprites/map/scorpion_walk.png
+%%DATADIR%%/img/sprites/map/slime_walk.png
+%%DATADIR%%/img/sprites/map/snake_walk.png
+%%DATADIR%%/img/sprites/map/soldier_npc01_walk.png
+%%DATADIR%%/img/sprites/map/vanica_walk.png
+%%DATADIR%%/img/sprites/map/woman_npc01_walk.png
+%%DATADIR%%/img/sprites/map/woman_npc02_walk.png
+%%DATADIR%%/img/tilesets/desert_cave.png
+%%DATADIR%%/img/tilesets/desert_cave_ground.png
+%%DATADIR%%/img/tilesets/desert_cave_walls.png
+%%DATADIR%%/img/tilesets/desert_cave_walls2.png
+%%DATADIR%%/img/tilesets/desert_cave_water.png
+%%DATADIR%%/img/tilesets/mountain_house_exterior.png
+%%DATADIR%%/img/tilesets/mountain_house_exterior2.png
+%%DATADIR%%/img/tilesets/mountain_house_interior.png
+%%DATADIR%%/img/tilesets/mountain_landscape.png
+%%DATADIR%%/img/tilesets/test.png
+%%DATADIR%%/mus/Allacrost_Fanfare.ogg
+%%DATADIR%%/mus/Allacrost_Intermission.ogg
%%DATADIR%%/mus/Allacrost_Opening_Theme.ogg
%%DATADIR%%/mus/Confrontation.ogg
%%DATADIR%%/mus/Opening_Effect.ogg
%%DATADIR%%/mus/Seeking_New_Worlds.ogg
+%%DATADIR%%/mus/The_Creature_Awakens.ogg
+%%DATADIR%%/mus/Town_Folk.ogg
+%%DATADIR%%/mus/Venturing_Dragons_in_the_Dark.ogg
%%DATADIR%%/snd/battle_encounter_01.ogg
%%DATADIR%%/snd/battle_encounter_02.ogg
%%DATADIR%%/snd/battle_encounter_03.ogg
%%DATADIR%%/snd/bump.wav
%%DATADIR%%/snd/cancel.wav
+%%DATADIR%%/snd/coins.wav
%%DATADIR%%/snd/confirm.wav
+%%DATADIR%%/snd/level_up.wav
%%DATADIR%%/snd/obtain.wav
%%DATADIR%%/snd/potion_drink.wav
+%%DATADIR%%/snd/rumble.wav
%%DATADIR%%/snd/skeleton_attack.wav
%%DATADIR%%/snd/slime_attack.wav
%%DATADIR%%/snd/snake_attack.wav
@@ -308,7 +179,8 @@ bin/allacrost
%%DATADIR%%/snd/volume_test.wav
@dirrm %%DATADIR%%/snd
@dirrm %%DATADIR%%/mus
-@dirrm %%DATADIR%%/img/tiles
+@dirrm %%DATADIR%%/img/tilesets
+@dirrm %%DATADIR%%/img/temp
@dirrm %%DATADIR%%/img/sprites/map
@dirrm %%DATADIR%%/img/sprites/battle/enemies
@dirrm %%DATADIR%%/img/sprites/battle/characters
@@ -326,6 +198,9 @@ bin/allacrost
@dirrm %%DATADIR%%/img/icons/items
@dirrm %%DATADIR%%/img/icons/battle
@dirrm %%DATADIR%%/img/icons/armor
+@dirrm %%DATADIR%%/img/icons/actors/enemies
+@dirrm %%DATADIR%%/img/icons/actors/characters
+@dirrm %%DATADIR%%/img/icons/actors
@dirrm %%DATADIR%%/img/icons
@dirrm %%DATADIR%%/img/fonts
@dirrm %%DATADIR%%/img/backdrops/battle
@@ -333,8 +208,9 @@ bin/allacrost
@dirrm %%DATADIR%%/img
@dirrm %%DATADIR%%/dat/tilesets
@dirrm %%DATADIR%%/dat/skills
+@dirrm %%DATADIR%%/dat/objects
@dirrm %%DATADIR%%/dat/maps
-@dirrm %%DATADIR%%/dat/enemies
@dirrm %%DATADIR%%/dat/config
+@dirrm %%DATADIR%%/dat/actors
@dirrm %%DATADIR%%/dat
@dirrm %%DATADIR%%