aboutsummaryrefslogtreecommitdiff
path: root/games/allacrost
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 15:28:28 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 15:28:28 +0000
commite836ab008ac38916a93472f2840e03e2e8470ef5 (patch)
tree1485083919fd5b153bf056ea17ac895ea758a8a9 /games/allacrost
parent35d8b48dff5490ff5d7232109c287da637b58811 (diff)
downloadports-e836ab008ac38916a93472f2840e03e2e8470ef5.tar.gz
ports-e836ab008ac38916a93472f2840e03e2e8470ef5.zip
Replace lang/lua with the new lang/lua51
lang/lua51 is working the same way lang/lua52, chase ports using lua 5.1 Make the default lua lua52 Make all lua ports using USES=lua Approved by: portmgr (implicit)
Notes
Notes: svn path=/head/; revision=355360
Diffstat (limited to 'games/allacrost')
-rw-r--r--games/allacrost/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/allacrost/Makefile b/games/allacrost/Makefile
index 2cced4997f2e..2978e4dc189e 100644
--- a/games/allacrost/Makefile
+++ b/games/allacrost/Makefile
@@ -20,8 +20,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USES= gettext gmake openal:al
-USE_LUA= 5.1
+USES= gettext gmake openal:al lua:51
USE_SDL= sdl ttf net
USE_GL= yes
USE_GCC= any # problems in luabind
@@ -58,7 +57,8 @@ post-patch:
@${REINPLACE_CMD} -e '/^LIBS =/ s|$$| @INTLLIBS@|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/^bindir = / s|games|bin|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/qt4_incdirs/ s|".*"|"${QT_INCDIR}"|; \
- /qt4_libdirs/ s|".*"|"${QT_LIBDIR}"|; /test/ s|==|=|' \
+ /qt4_libdirs/ s|".*"|"${QT_LIBDIR}"|; /test/ s|==|=| ; \
+ s/-llua /-llua-${LUA_VER} /g;' \
${WRKSRC}/configure
.if ${PORT_OPTIONS:MEDITOR}
@${REINPLACE_CMD} -e '/^INCLUDES = / s|=|= -I${QT_INCDIR}/QtGui \