aboutsummaryrefslogtreecommitdiff
path: root/games/allacrost
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-03-01 15:29:09 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-03-01 15:29:09 +0000
commitee8deb11d082f98fe9b5fd3e59d9d8d83a4ee243 (patch)
tree8431c8051d1d13b9575963d537fd9270fe74cdbb /games/allacrost
parent4cb2ee99e377137eb3b5a1bb4a38fac20b84f201 (diff)
downloadports-ee8deb11d082f98fe9b5fd3e59d9d8d83a4ee243.tar.gz
ports-ee8deb11d082f98fe9b5fd3e59d9d8d83a4ee243.zip
- Fix runtime and build with newer compilers, get rid of gcc dependency
PR: 217002 Reported by: jbeich
Notes
Notes: svn path=/head/; revision=435166
Diffstat (limited to 'games/allacrost')
-rw-r--r--games/allacrost/Makefile5
-rw-r--r--games/allacrost/files/patch-src-luabind-luabind-detail-format__signature.hpp35
-rw-r--r--games/allacrost/files/patch-src_luabind_luabind_detail_object__rep.hpp11
-rw-r--r--games/allacrost/files/patch-src_main.cpp17
4 files changed, 65 insertions, 3 deletions
diff --git a/games/allacrost/Makefile b/games/allacrost/Makefile
index 97684c517068..6718bb7357d3 100644
--- a/games/allacrost/Makefile
+++ b/games/allacrost/Makefile
@@ -3,7 +3,7 @@
PORTNAME= allacrost
PORTVERSION= 1.0.2
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-demo/${PORTVERSION}
DISTNAME= ${PORTNAME}_demo_source_${PORTVERSION}
@@ -23,7 +23,6 @@ GNU_CONFIGURE= yes
USES= gettext gmake iconv jpeg lua:51 openal:al
USE_SDL= sdl ttf net
USE_GL= yes
-USE_GCC= any # problems in luabind
QT_NONSTANDARD= yes # used when EDITOR enabled
CONFIGURE_ARGS= --datadir=${DATADIR}
@@ -63,7 +62,7 @@ post-patch-EDITOR-on:
${WRKSRC}/Makefile.in
post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/MANUAL ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/games/allacrost/files/patch-src-luabind-luabind-detail-format__signature.hpp b/games/allacrost/files/patch-src-luabind-luabind-detail-format__signature.hpp
new file mode 100644
index 000000000000..d4bfdfad9b02
--- /dev/null
+++ b/games/allacrost/files/patch-src-luabind-luabind-detail-format__signature.hpp
@@ -0,0 +1,35 @@
+commit 3044a9053ac50977684a75c4af42b2bddb853fad
+Author: Daniel Wallin <daniel@boostpro.com>
+Date: Mon Oct 11 14:33:23 2010 +0200
+
+ Proper forward declarations for object wrappers. Now builds on clang!
+
+diff --git luabind/detail/format_signature.hpp luabind/detail/format_signature.hpp
+index 56e7963..b447bc9 100644
+--- src/luabind/luabind/detail/format_signature.hpp
++++ src/luabind/luabind/detail/format_signature.hpp
+@@ -13,12 +13,19 @@
+ # include <boost/mpl/next.hpp>
+ # include <boost/mpl/size.hpp>
+
+-namespace luabind {
++namespace luabind { namespace adl
++{
+
+-class object;
+-class argument;
+-template <class Base>
+-struct table;
++ class object;
++ class argument;
++ template <class Base>
++ struct table;
++
++} // namespace adl
++
++using adl::object;
++using adl::argument;
++using adl::table;
+
+ } // namespace luabind
+
diff --git a/games/allacrost/files/patch-src_luabind_luabind_detail_object__rep.hpp b/games/allacrost/files/patch-src_luabind_luabind_detail_object__rep.hpp
new file mode 100644
index 000000000000..a7e76daca794
--- /dev/null
+++ b/games/allacrost/files/patch-src_luabind_luabind_detail_object__rep.hpp
@@ -0,0 +1,11 @@
+--- src/luabind/luabind/detail/object_rep.hpp.orig 2010-01-03 23:08:15 UTC
++++ src/luabind/luabind/detail/object_rep.hpp
+@@ -29,6 +29,8 @@
+ #include <luabind/detail/instance_holder.hpp>
+ #include <luabind/detail/ref.hpp>
+
++#include <cstdlib>
++
+ namespace luabind { namespace detail
+ {
+ class class_rep;
diff --git a/games/allacrost/files/patch-src_main.cpp b/games/allacrost/files/patch-src_main.cpp
new file mode 100644
index 000000000000..0b1e93d822c1
--- /dev/null
+++ b/games/allacrost/files/patch-src_main.cpp
@@ -0,0 +1,17 @@
+--- src/main.cpp.orig 2010-05-17 22:52:57 UTC
++++ src/main.cpp
+@@ -364,11 +364,9 @@ int main(int argc, char *argv[]) {
+ // Now the program should be in app/Contents
+ path.append ("/Resources/");
+ chdir(path.c_str());
+- #elif (defined(__linux__) || defined(__FreeBSD__)) && !defined(RELEASE_BUILD)
+- // Look for data files in DATADIR only if they are not available in the
+- // current directory.
+- if (ifstream("dat/config/settings.lua") == NULL)
+- chdir(DATADIR);
++ #elif (defined(__linux__) || defined(__FreeBSD__) || defined(__DragonFly__)) && !defined(RELEASE_BUILD)
++ // Always look into datadir
++ chdir(DATADIR);
+ #endif
+
+ // Initialize the random number generator (note: 'unsigned int' is a required usage in this case)