aboutsummaryrefslogtreecommitdiff
path: root/games/an
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-18 08:47:05 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-18 08:47:05 +0000
commit191b7341ae175900437eafb3ea03815d89d5d705 (patch)
tree93b1f263fadb2f7e8f9520858a732f89fed85636 /games/an
parent1b3482df0c22a215dc6f8efa7cd9f934ab3a1ed3 (diff)
downloadports-191b7341ae175900437eafb3ea03815d89d5d705.tar.gz
ports-191b7341ae175900437eafb3ea03815d89d5d705.zip
- Update to 1.2
- Add LICENSE
Notes
Notes: svn path=/head/; revision=426313
Diffstat (limited to 'games/an')
-rw-r--r--games/an/Makefile20
-rw-r--r--games/an/distinfo5
-rw-r--r--games/an/files/patch-Makefile27
-rw-r--r--games/an/pkg-descr10
4 files changed, 44 insertions, 18 deletions
diff --git a/games/an/Makefile b/games/an/Makefile
index 06cb8fca8a7d..b1808e066d4c 100644
--- a/games/an/Makefile
+++ b/games/an/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= an
-PORTVERSION= 0.95
-PORTREVISION= 1
+PORTVERSION= 1.2
CATEGORIES= games
MASTER_SITES= DEBIAN_POOL
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
@@ -11,20 +10,15 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= ports@FreeBSD.org
COMMENT= Fast anagram generator
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libicuuc.so:devel/icu
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USES= gmake tar:xz
PLIST_FILES= bin/${PORTNAME} \
man/man6/${PORTNAME}.6.gz
-post-patch:
- @${REINPLACE_CMD} -e '/<stdint.h>/d' ${WRKSRC}/an.c
-
-do-build:
- cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} ${CPPFLAGS} an.c gan_qsort.c \
- -o ${PORTNAME} ${LDFLAGS}
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/an ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/an.6 ${STAGEDIR}${MANPREFIX}/man/man6
-
.include <bsd.port.mk>
diff --git a/games/an/distinfo b/games/an/distinfo
index a80a4227e327..744645385e3f 100644
--- a/games/an/distinfo
+++ b/games/an/distinfo
@@ -1,2 +1,3 @@
-SHA256 (an_0.95.orig.tar.gz) = 11266dd1e347594d98f8dfd1e141d8b4fbe067752542d0e93c422c4789f9295c
-SIZE (an_0.95.orig.tar.gz) = 47829
+TIMESTAMP = 1479213376
+SHA256 (an_1.2.orig.tar.xz) = b925d57d80bd0d83b755f5b8d78e6d5bf05eb059ec84a7d8fbb77b18c73b17a5
+SIZE (an_1.2.orig.tar.xz) = 13196
diff --git a/games/an/files/patch-Makefile b/games/an/files/patch-Makefile
new file mode 100644
index 000000000000..41631b347711
--- /dev/null
+++ b/games/an/files/patch-Makefile
@@ -0,0 +1,27 @@
+--- Makefile.orig 2012-05-25 09:50:02 UTC
++++ Makefile
+@@ -16,10 +16,10 @@
+ # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+
+-INSTALLDIR := $(DESTDIR)/usr/games
+-MANDIR := $(DESTDIR)/usr/share/man/man6
++INSTALLDIR := $(DESTDIR)$(PREFIX)/bin
++MANDIR := $(DESTDIR)$(PREFIX)/man/man6
+
+-CC:=gcc
++CC?=gcc
+ INSTALL:=install
+
+ CFLAGS += $(shell icu-config --cflags)
+@@ -43,8 +43,8 @@ $(BIN): $(OBJS)
+ $(MAN):
+
+ install: $(BIN)
+- $(INSTALL) -m 755 $(BIN) $(INSTALLDIR)/$(BIN)
+- $(INSTALL) -m 644 $(MAN) $(MANDIR)/$(MAN)
++ $(BSD_INSTALL_PROGRAM) $(BIN) $(INSTALLDIR)/$(BIN)
++ $(BSD_INSTALL_MAN) $(MAN) $(MANDIR)/$(MAN)
+
+ clean:
+ rm -f *.o $(BIN)
diff --git a/games/an/pkg-descr b/games/an/pkg-descr
index 6ece6d6bbbff..84e0bf435577 100644
--- a/games/an/pkg-descr
+++ b/games/an/pkg-descr
@@ -1,3 +1,7 @@
-Generates anagrams for a phrase supplied by the user, the words used
-in the anagram are taken from a specified dictionary which should
-contain one word per line (default:/usr/share/dict/words).
+Generates anagrams for a phrase supplied by the user, the words
+used in the anagram are taken from a specified dictionary which
+should contain one word per line (default:/usr/share/dict/words).
+It understands accented characters and should work with any alphabetic
+language.
+
+WWW: https://packages.debian.org/unstable/games/an