aboutsummaryrefslogtreecommitdiff
path: root/games/aquaria
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2019-06-16 14:57:51 +0000
committerRene Ladan <rene@FreeBSD.org>2019-06-16 14:57:51 +0000
commit046b39641dd97b0443934f3765026187bbc7a194 (patch)
tree72817e1d27ac5e3666d053ce4389e8e1e84c475e /games/aquaria
parent54690154169f2fcc2fdecb3b14f0d41717a4680e (diff)
downloadports-046b39641dd97b0443934f3765026187bbc7a194.tar.gz
ports-046b39641dd97b0443934f3765026187bbc7a194.zip
games/aquaria: include dirent.h instead of sys/dir.h which is scheduled for removal.
While here modernize USES PR: 238616 Approved by: maintainer (jbeich) Event: Berlin Hackathon 2019
Notes
Notes: svn path=/head/; revision=504349
Diffstat (limited to 'games/aquaria')
-rw-r--r--games/aquaria/Makefile2
-rw-r--r--games/aquaria/files/patch-ExternalLibs_ttvfs_VFSTools.cpp15
2 files changed, 16 insertions, 1 deletions
diff --git a/games/aquaria/Makefile b/games/aquaria/Makefile
index 5903eab0345e..1f3fb3479b1f 100644
--- a/games/aquaria/Makefile
+++ b/games/aquaria/Makefile
@@ -22,7 +22,7 @@ USE_GITHUB= yes
GH_ACCOUNT= AquariaOSE
GH_PROJECT= Aquaria
-USES= cmake:insource compiler:c++11-lang lua:51 openal pkgconfig
+USES= cmake:insource compiler:c++11-lang lua:51 openal pkgconfig sdl
EXCLUDE= AL FTGL GL SDL* freetype2 glm glpng/png glpng/zlib \
libogg-* libvorbis-* lua-* tinyxml2*
EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ExternalLibs/,}
diff --git a/games/aquaria/files/patch-ExternalLibs_ttvfs_VFSTools.cpp b/games/aquaria/files/patch-ExternalLibs_ttvfs_VFSTools.cpp
new file mode 100644
index 000000000000..c9e4acfc1b5e
--- /dev/null
+++ b/games/aquaria/files/patch-ExternalLibs_ttvfs_VFSTools.cpp
@@ -0,0 +1,15 @@
+--- ExternalLibs/ttvfs/VFSTools.cpp.orig 2016-06-19 23:56:27 UTC
++++ ExternalLibs/ttvfs/VFSTools.cpp
+@@ -12,11 +12,7 @@
+ # include <windows.h>
+ # include <io.h>
+ #else
+-# ifdef __HAIKU__
+-# include <dirent.h>
+-# else
+-# include <sys/dir.h>
+-# endif
++# include <dirent.h>
+ # include <unistd.h>
+ #endif
+