aboutsummaryrefslogtreecommitdiff
path: root/games/aquaria
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /games/aquaria
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'games/aquaria')
-rw-r--r--games/aquaria/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/aquaria/Makefile b/games/aquaria/Makefile
index d5f01ad4459b..8b94d9e24de7 100644
--- a/games/aquaria/Makefile
+++ b/games/aquaria/Makefile
@@ -22,7 +22,7 @@ USE_GITHUB= yes
GH_ACCOUNT= AquariaOSE
GH_PROJECT= Aquaria
-USES= cmake lua:51 openal pkgconfig
+USES= cmake:insource lua:51 openal pkgconfig
EXCLUDE= AL FTGL GL SDL* freetype2 glm glpng/png glpng/zlib \
libogg-* libvorbis-* lua-* tinyxml2*
EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ExternalLibs/,}