aboutsummaryrefslogtreecommitdiff
path: root/games/aquaria
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-12-27 19:45:18 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-12-27 19:45:18 +0000
commitd6e9e0f07869b63ddbe4c69ddab4f2ff1c60dfaa (patch)
tree0c5a9624bab20efd41149f0012c706ea1d65a115 /games/aquaria
parentfa272d9a7066109dc6d609938d73684050416296 (diff)
downloadports-d6e9e0f07869b63ddbe4c69ddab4f2ff1c60dfaa.tar.gz
ports-d6e9e0f07869b63ddbe4c69ddab4f2ff1c60dfaa.zip
games/aquaria: unbreak on GCC architectures after r455508
In file included from /usr/local/include/glm/detail/setup.hpp:30, from /usr/local/include/glm/detail/type_int.hpp:6, from /usr/local/include/glm/fwd.hpp:6, from /usr/local/include/glm/glm.hpp:61, from BBGE/RenderObject.cpp:29: /usr/local/include/glm/detail/../simd/platform.h:206:4: error: #error "GLM requires GCC 4.7 or higher" /usr/local/include/glm/detail/../simd/platform.h:230:3: error: #error "GLM_COMPILER undefined, your compiler may not be supported by GLM. Add #define GLM_COMPILER 0 to ignore this message." https://github.com/g-truc/glm/commit/dd48b56e44d6 PR: 234348 Submitted by: Piotr Kubaj
Notes
Notes: svn path=/head/; revision=488561
Diffstat (limited to 'games/aquaria')
-rw-r--r--games/aquaria/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/aquaria/Makefile b/games/aquaria/Makefile
index 8b94d9e24de7..5903eab0345e 100644
--- a/games/aquaria/Makefile
+++ b/games/aquaria/Makefile
@@ -22,7 +22,7 @@ USE_GITHUB= yes
GH_ACCOUNT= AquariaOSE
GH_PROJECT= Aquaria
-USES= cmake:insource lua:51 openal pkgconfig
+USES= cmake:insource compiler:c++11-lang lua:51 openal pkgconfig
EXCLUDE= AL FTGL GL SDL* freetype2 glm glpng/png glpng/zlib \
libogg-* libvorbis-* lua-* tinyxml2*
EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ExternalLibs/,}