aboutsummaryrefslogtreecommitdiff
path: root/games/armagetronad
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-07-23 00:53:33 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-07-23 00:53:33 +0000
commitdc9a4e46a7c08f9a0f9d0132fd47a1c7f9e0a155 (patch)
treedf75d4b667ae1d224cfa1f87807f416e46329d83 /games/armagetronad
parente9adc13a59707a96750604cd8bcb347b0a1c6760 (diff)
downloadports-dc9a4e46a7c08f9a0f9d0132fd47a1c7f9e0a155.tar.gz
ports-dc9a4e46a7c08f9a0f9d0132fd47a1c7f9e0a155.zip
Notes
Diffstat (limited to 'games/armagetronad')
-rw-r--r--games/armagetronad/Makefile34
-rw-r--r--games/armagetronad/distinfo3
-rw-r--r--games/armagetronad/files/patch-batch_sysinstall.in11
-rw-r--r--games/armagetronad/files/patch-src_tron_gCycle.cpp16
-rw-r--r--games/armagetronad/pkg-descr7
-rw-r--r--games/armagetronad/pkg-plist76
6 files changed, 147 insertions, 0 deletions
diff --git a/games/armagetronad/Makefile b/games/armagetronad/Makefile
new file mode 100644
index 000000000000..cd5195abaa67
--- /dev/null
+++ b/games/armagetronad/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= armagetronad
+DISTVERSION= 0.2.8.3.4
+DISTVERSIONSUFFIX= .src
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/stable/${DISTVERSION}/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Tron clone in 3D
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= bash:shells/bash
+LIB_DEPENDS= libpng16.so:graphics/png
+
+USES= autoreconf gl gmake gnome jpeg sdl
+GNU_CONFIGURE= yes
+USE_SDL= image mixer sdl
+USE_GL= gl glu
+USE_GNOME= libxml2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+
+CONFIGURE_ARGS= --disable-etc --disable-games --enable-music
+
+BINARY_ALIAS= sdl11-config=sdl-config
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= *
+
+.include <bsd.port.mk>
diff --git a/games/armagetronad/distinfo b/games/armagetronad/distinfo
new file mode 100644
index 000000000000..b31717242538
--- /dev/null
+++ b/games/armagetronad/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1563837617
+SHA256 (armagetronad-0.2.8.3.4.src.tar.gz) = 446af57c614ed28b4aa1d5a0d818c9d67a621bf7832b9276c3029c0f5006fedd
+SIZE (armagetronad-0.2.8.3.4.src.tar.gz) = 2217387
diff --git a/games/armagetronad/files/patch-batch_sysinstall.in b/games/armagetronad/files/patch-batch_sysinstall.in
new file mode 100644
index 000000000000..adbca77707a3
--- /dev/null
+++ b/games/armagetronad/files/patch-batch_sysinstall.in
@@ -0,0 +1,11 @@
+--- batch/sysinstall.in.orig 2011-09-11 10:41:39 UTC
++++ batch/sysinstall.in
+@@ -205,7 +205,7 @@ if test $MODE = install; then
+ for script in $DESTDIR$SCRIPTDIR/* $DESTDIR$CONFIGDIR/rc.config; do
+ if test $script != $DESTDIR$SCRIPTDIR/sysinstall; then
+ sed -e ${sedcommands} < $script > $script.trans || exit 1
+- mv $script.trans $script
++ mv -f $script.trans $script
+ chmod 755 $script
+ fi
+ done
diff --git a/games/armagetronad/files/patch-src_tron_gCycle.cpp b/games/armagetronad/files/patch-src_tron_gCycle.cpp
new file mode 100644
index 000000000000..58705446a300
--- /dev/null
+++ b/games/armagetronad/files/patch-src_tron_gCycle.cpp
@@ -0,0 +1,16 @@
+This is a fix for a bug in how std::autoptr is handled.
+clang complains:
+gCycle.cpp:*:*: warning: reference cannot be bound to dereferenced null pointer in well-defined C++ code; pointer may be assumed to always convert to true
+ [-Wundefined-bool-conversion]
+
+--- src/tron/gCycle.cpp.orig 2011-09-11 10:41:47 UTC
++++ src/tron/gCycle.cpp
+@@ -2712,7 +2712,7 @@ bool gCycle::Timestep(REAL currentTime){
+ gCycleChatBot & bot = gCycleChatBot::Get( this );
+ bot.Activate( currentTime );
+ }
+- else if ( &(*chatBot_) )
++ else if ( chatBot_.get() )
+ {
+ chatBot_->nextChatAI_ = 0;
+ }
diff --git a/games/armagetronad/pkg-descr b/games/armagetronad/pkg-descr
new file mode 100644
index 000000000000..7414f153cf8a
--- /dev/null
+++ b/games/armagetronad/pkg-descr
@@ -0,0 +1,7 @@
+Armagetron is a multiplayer game in 3d that attempts to emulate and expand on
+the lightcycle sequence from the movie Tron. It's an old school arcade game
+slung into the 21st century. Highlights include a customizable playing arena,
+HUD, unique graphics, and AI bots. For the more advanced player there are new
+game modes and a wide variety of physics settings to tweak as well.
+
+WWW: http://www.armagetronad.org/
diff --git a/games/armagetronad/pkg-plist b/games/armagetronad/pkg-plist
new file mode 100644
index 000000000000..7a77ec6519be
--- /dev/null
+++ b/games/armagetronad/pkg-plist
@@ -0,0 +1,76 @@
+bin/armagetronad
+%%ETCDIR%%/aiplayers.cfg
+%%ETCDIR%%/default.cfg
+%%ETCDIR%%/examples/breakfast_in_hell.cfg
+%%ETCDIR%%/examples/cvs_test/fortress_complete.cfg
+%%ETCDIR%%/examples/cvs_test/fortress_physics.cfg
+%%ETCDIR%%/examples/cvs_test/fortress_politics.cfg
+%%ETCDIR%%/examples/cvs_test/fortress_scoring.cfg
+%%ETCDIR%%/examples/cvs_test/sumo_complete.cfg
+%%ETCDIR%%/examples/death_zone.cfg
+%%ETCDIR%%/examples/fortress_soccer.cfg
+%%ETCDIR%%/examples/single_use_turbo.cfg
+%%ETCDIR%%/examples/teamsumo.cfg
+%%ETCDIR%%/master.srv
+%%ETCDIR%%/rc.config
+%%ETCDIR%%/settings.cfg
+%%ETCDIR%%/settings_authentication.cfg
+%%ETCDIR%%/settings_dedicated.cfg
+%%ETCDIR%%/settings_visual.cfg
+%%ETCDIR%%/subcultures.srv
+%%DATADIR%%/desktop/armagetronad.desktop
+%%DATADIR%%/desktop/icons/large/armagetronad.png
+%%DATADIR%%/desktop/icons/medium/armagetronad.png
+%%DATADIR%%/desktop/icons/small/armagetronad.png
+%%DATADIR%%/language/american.txt
+%%DATADIR%%/language/british.txt
+%%DATADIR%%/language/deutsch.txt
+%%DATADIR%%/language/english_base.txt
+%%DATADIR%%/language/english_base_notranslate.txt
+%%DATADIR%%/language/french.txt
+%%DATADIR%%/language/languages.txt
+%%DATADIR%%/language/languages.txt.in
+%%DATADIR%%/language/polish.txt
+%%DATADIR%%/language/polish_transliterated.txt
+%%DATADIR%%/language/spanish.txt
+%%DATADIR%%/language/update.py
+%%DATADIR%%/models/cycle_body.mod
+%%DATADIR%%/models/cycle_front.mod
+%%DATADIR%%/models/cycle_rear.mod
+%%DATADIR%%/resource/included/AATeam/map-0.2.8.0.dtd
+%%DATADIR%%/resource/included/AATeam/map-0.2.8.0_rc4.dtd
+%%DATADIR%%/resource/included/Anonymous/README
+%%DATADIR%%/resource/included/Anonymous/polygon/README
+%%DATADIR%%/resource/included/Anonymous/polygon/regular/40-gon-0.2.aamap.xml
+%%DATADIR%%/resource/included/Anonymous/polygon/regular/README
+%%DATADIR%%/resource/included/Anonymous/polygon/regular/diamond-1.0.2.aamap.xml
+%%DATADIR%%/resource/included/Anonymous/polygon/regular/square-1.0.1.aamap.xml
+%%DATADIR%%/resource/included/Your_mom/clever/inaktek-0.7.2.aamap.xml
+%%DATADIR%%/resource/included/Your_mom/clever/repeat-0.3.2.aamap.xml
+%%DATADIR%%/resource/included/Z-Man/fortress/for_old_clients-0.1.0.aamap.xml
+%%DATADIR%%/resource/included/Z-Man/fortress/fourfold_for_old_clients-0.1.0.aamap.xml
+%%DATADIR%%/resource/included/Z-Man/fortress/sumo_4x4-0.1.1.aamap.xml
+%%DATADIR%%/resource/included/Z-Man/fortress/sumo_8x2-0.1.0.aamap.xml
+%%DATADIR%%/resource/included/Z-Man/fortress/zonetest-0.1.0.aamap.xml
+%%DATADIR%%/resource/included/map-0.1-exp.dtd
+%%DATADIR%%/resource/included/map-0.1.dtd
+%%DATADIR%%/resource/included/map-0.2.8_beta3.dtd
+%%DATADIR%%/scripts/relocate
+%%DATADIR%%/scripts/sysinstall
+%%DATADIR%%/sound/cyclrun.wav
+%%DATADIR%%/sound/expl.wav
+%%DATADIR%%/textures/KGN_logo.png
+%%DATADIR%%/textures/cycle_body.png
+%%DATADIR%%/textures/cycle_wheel.png
+%%DATADIR%%/textures/dir_wall.png
+%%DATADIR%%/textures/floor.png
+%%DATADIR%%/textures/floor_a.png
+%%DATADIR%%/textures/floor_b.png
+%%DATADIR%%/textures/font.png
+%%DATADIR%%/textures/font_extra.png
+%%DATADIR%%/textures/font_s.png
+%%DATADIR%%/textures/icon.png
+%%DATADIR%%/textures/rim_wall.png
+%%DATADIR%%/textures/shadow.png
+%%DATADIR%%/textures/sky.png
+%%DATADIR%%/textures/title.jpg