aboutsummaryrefslogtreecommitdiff
path: root/games/assaultcube/files
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-02-27 02:46:33 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-02-27 02:46:33 +0000
commit2fd31e64b43504ba2fea20e5123b0846ef8641bc (patch)
tree1f4d6618960bca91818995059892736d2423612a /games/assaultcube/files
parent412793fcfc289279f2f6ae693901e5b07954da58 (diff)
downloadports-2fd31e64b43504ba2fea20e5123b0846ef8641bc.tar.gz
ports-2fd31e64b43504ba2fea20e5123b0846ef8641bc.zip
Notes
Diffstat (limited to 'games/assaultcube/files')
-rw-r--r--games/assaultcube/files/actioncube_client.in24
-rw-r--r--games/assaultcube/files/actioncube_server.in24
-rw-r--r--games/assaultcube/files/patch-source__src__Makefile16
3 files changed, 64 insertions, 0 deletions
diff --git a/games/assaultcube/files/actioncube_client.in b/games/assaultcube/files/actioncube_client.in
new file mode 100644
index 000000000000..a25b93af6d30
--- /dev/null
+++ b/games/assaultcube/files/actioncube_client.in
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+# The executable needs to be run from its data directory, and needs to store
+# configuration in it. We therefore mirror the data directory hierarchy in
+# ~/.XXX, and create symlinks to the data files, but the configuration files
+# are copied, and write permission for the user is added to them.
+
+APPNAME="actioncube"
+
+if [ -d ~/.$APPNAME ]
+then
+ echo "Using existing ~/.$APPNAME directory."
+else
+ echo "Creating ~/.$APPNAME directory."
+ cd %%DATADIR%% || exit 1
+ find * -type d -exec mkdir -p ~/.$APPNAME/{} \;
+ find * -type f -name "*.cfg" \
+ -exec cp %%DATADIR%%/{} ~/.$APPNAME/{} \; \
+ -exec chmod u+w ~/.$APPNAME/{} \; 2>/dev/null
+ find * -type f -exec ln -s %%DATADIR%%/{} ~/.$APPNAME/{} \; 2>/dev/null
+fi
+
+cd ~/.$APPNAME || exit 1
+exec %%PREFIX%%/libexec/${APPNAME}_client "$@"
diff --git a/games/assaultcube/files/actioncube_server.in b/games/assaultcube/files/actioncube_server.in
new file mode 100644
index 000000000000..6043d6db6161
--- /dev/null
+++ b/games/assaultcube/files/actioncube_server.in
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+# The executable needs to be run from its data directory, and needs to store
+# configuration in it. We therefore mirror the data directory hierarchy in
+# ~/.XXX, and create symlinks to the data files, but the configuration files
+# are copied, and write permission for the user is added to them.
+
+APPNAME="actioncube"
+
+if [ -d ~/.$APPNAME ]
+then
+ echo "Using existing ~/.$APPNAME directory."
+else
+ echo "Creating ~/.$APPNAME directory."
+ cd %%DATADIR%% || exit 1
+ find * -type d -exec mkdir -p ~/.$APPNAME/{} \;
+ find * -type f -name "*.cfg" \
+ -exec cp %%DATADIR%%/{} ~/.$APPNAME/{} \; \
+ -exec chmod u+w ~/.$APPNAME/{} \; 2>/dev/null
+ find * -type f -exec ln -s %%DATADIR%%/{} ~/.$APPNAME/{} \; 2>/dev/null
+fi
+
+cd ~/.$APPNAME || exit 1
+exec %%PREFIX%%/libexec/${APPNAME}_server "$@"
diff --git a/games/assaultcube/files/patch-source__src__Makefile b/games/assaultcube/files/patch-source__src__Makefile
new file mode 100644
index 000000000000..abd20c68d27c
--- /dev/null
+++ b/games/assaultcube/files/patch-source__src__Makefile
@@ -0,0 +1,16 @@
+--- ./source/src/Makefile.orig Tue Nov 14 13:17:07 2006
++++ ./source/src/Makefile Sun Feb 25 22:57:28 2007
+@@ -1,9 +1,9 @@
+-CXX=g++
+-CXXOPTFLAGS=-O3 -fomit-frame-pointer
+-CXXFLAGS=$(CXXOPTFLAGS) -I../enet/include `sdl-config --cflags` -fsigned-char -Wall -Wno-deprecated
++CXX?=g++
++CXXOPTFLAGS?=-O3 -fomit-frame-pointer
++CXXFLAGS+=$(CXXOPTFLAGS) -I../enet/include `$(SDL_CONFIG) --cflags` -I$(X11BASE)/include -fsigned-char -Wall -Wno-deprecated
+ PLATFORM_PREFIX=native
+
+-CLIENT_LIBS=-L../enet -lenet `sdl-config --libs` -lSDL_image -lSDL_mixer -lz -lGL -lGLU
++CLIENT_LIBS=-L../enet -lenet `$(SDL_CONFIG) --libs` -lSDL_image -lSDL_mixer -lz -L$(X11BASE)/lib -lGL -lGLU
+ CLIENT_OBJS= \
+ client.o \
+ clientextras.o \