aboutsummaryrefslogtreecommitdiff
path: root/games/asteroids3d
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-08 17:37:19 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-08 17:37:19 +0000
commit088921596163c059172fde587805900dfd4d0b19 (patch)
tree19e7bf338e32a5e8744619b42ffc296b259cd77c /games/asteroids3d
parent14bf979c829ab18b0554650a26a580b4e2643f0c (diff)
downloadports-088921596163c059172fde587805900dfd4d0b19.tar.gz
ports-088921596163c059172fde587805900dfd4d0b19.zip
- Switch to USES=autoreconf
- Simplify - Switch to options helpers
Notes
Notes: svn path=/head/; revision=401067
Diffstat (limited to 'games/asteroids3d')
-rw-r--r--games/asteroids3d/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/games/asteroids3d/Makefile b/games/asteroids3d/Makefile
index 85df5b5d2cd5..17910c7311de 100644
--- a/games/asteroids3d/Makefile
+++ b/games/asteroids3d/Makefile
@@ -3,7 +3,7 @@
PORTNAME= asteroids3d
PORTVERSION= 0.5.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= SF/a3d/${PORTVERSION}/ \
SF/nemysisfreebsdp/${CATEGORIES}/:icons
@@ -17,8 +17,7 @@ COMMENT= First-person shooter blowing up asteroids in 3D space
LICENSE= GPLv2 # or later
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-USES= tar:bzip2
-USE_AUTOTOOLS= aclocal autoheader
+USES= autoreconf tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ENV= with_gamesdir="${PREFIX}/bin" with_gamedatadir="${DATADIR}"
USE_GL= glut
@@ -26,8 +25,7 @@ USE_GL= glut
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PORTDOCS= README.html
-OPTIONS_DEFINE= DOCS
+PORTDOCS= *
INSTALLS_ICONS= yes
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
@@ -35,16 +33,15 @@ ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
DESKTOP_ENTRIES="Asteroids3D" "" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" ""
-pre-configure:
- @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|g' ${WRKSRC}/autogen.sh
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME:S/3d/3D/} \
+ ${INSTALL_PROGRAM} ${WRKSRC}/asteroids3D \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}
- @(cd ${WRKSRC}/src && ${COPYTREE_SHARE} "*.ub *.ppm" \
+ @(cd ${WRKSRC}/src && ${COPYTREE_SHARE} "*.ub *.ppm" \
${STAGEDIR}${DATADIR})
.for s in ${ICON_SIZES}
@@ -55,7 +52,8 @@ do-install:
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.html ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>