aboutsummaryrefslogtreecommitdiff
path: root/games/asteroids3d
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-20 18:06:58 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-20 18:06:58 +0000
commit6beff77a3b4bc3a465458136bd208f1b585bcc86 (patch)
tree32fbd01aabe421289a8a0ffd0310250c79fda8c4 /games/asteroids3d
parent92399528a7b2dd04c56e4856fe5679df8c05f380 (diff)
downloadports-6beff77a3b4bc3a465458136bd208f1b585bcc86.tar.gz
ports-6beff77a3b4bc3a465458136bd208f1b585bcc86.zip
- Update icons
- Drop indirect/needless dependencies PR: ports/173349 Submitted by: nemysis (maintainer)
Notes
Notes: svn path=/head/; revision=312643
Diffstat (limited to 'games/asteroids3d')
-rw-r--r--games/asteroids3d/Makefile30
-rw-r--r--games/asteroids3d/distinfo4
-rw-r--r--games/asteroids3d/pkg-descr1
-rw-r--r--games/asteroids3d/pkg-plist43
4 files changed, 58 insertions, 20 deletions
diff --git a/games/asteroids3d/Makefile b/games/asteroids3d/Makefile
index 38f7dbf05fd0..1283e8f7348c 100644
--- a/games/asteroids3d/Makefile
+++ b/games/asteroids3d/Makefile
@@ -3,45 +3,35 @@
PORTNAME= asteroids3d
PORTVERSION= 0.5.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/a3d/${PORTVERSION}/ \
SF/nemysisfreebsdp/:icons
DISTNAME= ${PORTNAME:S/3d/3D/}-${DISTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- asteroids3d_icons.tbz:icons
+ ${PORTNAME}_icons${EXTRACT_SUFX}:icons
MAINTAINER= nemysis@gmx.ch
COMMENT= First-person shooter blowing up asteroids in 3D space
LICENSE= GPLv2
-LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- drm:${PORTSDIR}/graphics/libdrm \
- xcb:${PORTSDIR}/x11/libxcb
-
USE_BZIP2= yes
USE_AUTOTOOLS= aclocal autoheader
GNU_CONFIGURE= yes
CONFIGURE_ENV= with_gamesdir="${PREFIX}/bin" with_gamedatadir="${DATADIR}"
-USE_XORG= x11 xau xdamage xdmcp xext xfixes xi xrandr xrender xxf86vm
USE_GL= glut glu
MAKE_JOBS_SAFE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-WRKSRC= ${WRKDIR}/${PORTNAME:S/3d/3D/}-${PORTVERSION}
-
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}_128.png \
- share/pixmaps/${PORTNAME}_48.png
-
-PORTDATA= *
PORTDOCS= README.html
-DESKTOP_ENTRIES="Asteroids3D" "${COMMENT}" \
- "${PREFIX}/share/pixmaps/${PORTNAME}_48.png" \
+INSTALLS_ICONS= yes
+ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
+
+DESKTOP_ENTRIES="Asteroids3D" "${COMMENT}" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" false
pre-configure:
@@ -58,7 +48,13 @@ do-install:
${MKDIR} ${DATADIR}
@(cd ${WRKSRC}/src && ${COPYTREE_SHARE} "*.ub *.ppm" ${DATADIR})
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}*.png ${PREFIX}/share/pixmaps
+post-install:
+.for s in ${ICON_SIZES}
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
+ ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps/
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
diff --git a/games/asteroids3d/distinfo b/games/asteroids3d/distinfo
index f1969e8e959f..b96050b19293 100644
--- a/games/asteroids3d/distinfo
+++ b/games/asteroids3d/distinfo
@@ -1,4 +1,4 @@
SHA256 (asteroids3D-0.5.1.tar.bz2) = 68a07541198591c7a010324d870d120932c2dc015981f9197fe2268964a45087
SIZE (asteroids3D-0.5.1.tar.bz2) = 584201
-SHA256 (asteroids3d_icons.tbz) = e8ed4bd8119e19b6cb423cd00c9b305490edd0e30600c227786f8cbd5bd442a9
-SIZE (asteroids3d_icons.tbz) = 4023
+SHA256 (asteroids3d_icons.tar.bz2) = 8c8b3aad1ea2287bbc1dada7eea027e00c6c0e324b4ba4e8748b8ed702c7f50e
+SIZE (asteroids3d_icons.tar.bz2) = 26442
diff --git a/games/asteroids3d/pkg-descr b/games/asteroids3d/pkg-descr
index 62c8c1b45817..071c058af731 100644
--- a/games/asteroids3d/pkg-descr
+++ b/games/asteroids3d/pkg-descr
@@ -2,4 +2,3 @@ A simple first person shooter of blowing up asteroids in 3D space.
The codebase also serves as an introduction to trigonometry and OpenGL.
WWW: http://sourceforge.net/projects/a3d/
- http://staff.psc.edu/smp/a3d/
diff --git a/games/asteroids3d/pkg-plist b/games/asteroids3d/pkg-plist
new file mode 100644
index 000000000000..577143961f87
--- /dev/null
+++ b/games/asteroids3d/pkg-plist
@@ -0,0 +1,43 @@
+bin/asteroids3d
+%%DATADIR%%/ast_snd0.ub
+%%DATADIR%%/ast_snd1.ub
+%%DATADIR%%/ast_snd2.ub
+%%DATADIR%%/ast_snd3.ub
+%%DATADIR%%/ast_snd4.ub
+%%DATADIR%%/ast_snd5.ub
+%%DATADIR%%/ast_tex0.ppm
+%%DATADIR%%/ast_tex1.ppm
+%%DATADIR%%/ast_tex2.ppm
+%%DATADIR%%/ast_tex3.ppm
+%%DATADIR%%/ast_tex4.ppm
+%%DATADIR%%/ast_tex5.ppm
+%%DATADIR%%/coll_snd.ub
+%%DATADIR%%/nebula_tex0.ppm
+%%DATADIR%%/nebula_tex1.ppm
+%%DATADIR%%/nebula_tex2.ppm
+%%DATADIR%%/nebula_tex3.ppm
+%%DATADIR%%/ta_snd.ub
+%%DATADIR%%/tf_snd.ub
+%%DATADIR%%/torp_tex0.ppm
+share/icons/hicolor/128x128/apps/asteroids3d.png
+share/icons/hicolor/32x32/apps/asteroids3d.png
+share/icons/hicolor/48x48/apps/asteroids3d.png
+share/icons/hicolor/64x64/apps/asteroids3d.png
+share/icons/hicolor/72x72/apps/asteroids3d.png
+share/icons/hicolor/96x96/apps/asteroids3d.png
+share/pixmaps/asteroids3d.png
+@dirrmtry share/icons/hicolor/96x96/apps
+@dirrmtry share/icons/hicolor/96x96
+@dirrmtry share/icons/hicolor/72x72/apps
+@dirrmtry share/icons/hicolor/72x72
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrm %%DATADIR%%