aboutsummaryrefslogtreecommitdiff
path: root/games/astromenace
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /games/astromenace
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'games/astromenace')
-rw-r--r--games/astromenace/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/astromenace/Makefile b/games/astromenace/Makefile
index 01b3a900e33b..c597eeee395f 100644
--- a/games/astromenace/Makefile
+++ b/games/astromenace/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= libogg.so:audio/libogg \
USE_GITHUB= yes
GH_ACCOUNT= viewizard
-USES= cmake compiler:c++11-lib dos2unix gl openal:al,alut
+USES= cmake:insource compiler:c++11-lib dos2unix gl openal:al,alut
DOS2UNIX_FILES= CMakeLists.txt src/config/config.cpp
USE_GL= gl glu
USE_SDL= sdl2