aboutsummaryrefslogtreecommitdiff
path: root/games/atomix
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-08-13 10:45:42 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-08-13 10:45:42 +0000
commit3492ee1585979442373e52c771f08626780d1205 (patch)
tree07e33f98867914eeedaefff1be7a4dc56cc4e7fa /games/atomix
parent848f8d247836dc2b890741ef9f3ab1d3c77f4b77 (diff)
downloadports-3492ee1585979442373e52c771f08626780d1205.tar.gz
ports-3492ee1585979442373e52c771f08626780d1205.zip
- Fix build with gcc 3.4 [1]
- Use intlhack. - Fix score file installation permissions. Reported by: kris [1]
Notes
Notes: svn path=/head/; revision=116096
Diffstat (limited to 'games/atomix')
-rw-r--r--games/atomix/Makefile6
-rw-r--r--games/atomix/files/patch-src::goal-view.c10
-rw-r--r--games/atomix/files/patch-src::level-convert.c10
3 files changed, 22 insertions, 4 deletions
diff --git a/games/atomix/Makefile b/games/atomix/Makefile
index d7e463a9bc63..56c5172cab93 100644
--- a/games/atomix/Makefile
+++ b/games/atomix/Makefile
@@ -16,15 +16,13 @@ COMMENT= A yet another little mind game
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack libgnome libgnomeui libgnomecanvas libxml2
+USE_GNOME= gnomeprefix gnomehack intlhack libgnome libgnomeui libgnomecanvas libxml2
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
USE_REINPLACE= yes
post-patch:
- @${FIND} ${WRKSRC} -name "intltool-merge.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|mkdir $$lang or|mkdir $$lang, 0777 or| ; \
- s|^push @INC, "/.*|push @INC, "${LOCALBASE}/share/intltool";|'
+ @${REINPLACE_CMD} -e 's/games\.games/games:games/' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/games/atomix/files/patch-src::goal-view.c b/games/atomix/files/patch-src::goal-view.c
new file mode 100644
index 000000000000..e0d887ac24b1
--- /dev/null
+++ b/games/atomix/files/patch-src::goal-view.c
@@ -0,0 +1,10 @@
+--- src/goal-view.c.orig Fri Aug 13 19:03:11 2004
++++ src/goal-view.c Fri Aug 13 19:03:42 2004
+@@ -96,6 +96,7 @@
+ case TILE_TYPE_WALL:
+ case TILE_TYPE_UNKNOWN:
+ default:
++ ;
+ }
+ g_object_unref (tile);
+ }
diff --git a/games/atomix/files/patch-src::level-convert.c b/games/atomix/files/patch-src::level-convert.c
new file mode 100644
index 000000000000..1ae7ad48f9b0
--- /dev/null
+++ b/games/atomix/files/patch-src::level-convert.c
@@ -0,0 +1,10 @@
+--- src/level-convert.c.orig Fri Aug 13 19:04:13 2004
++++ src/level-convert.c Fri Aug 13 19:04:40 2004
+@@ -579,6 +579,7 @@
+ case TILE_TYPE_FLOOR:
+ type_str = "TILE_TYPE_FLOOR"; break;
+ default:
++ ;
+ }
+
+ if (type_str == NULL) return;