aboutsummaryrefslogtreecommitdiff
path: root/games/atr3d
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-09 11:15:30 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-09 11:15:30 +0000
commit73848a8928551ead1a2978f9b19dc992c796d48c (patch)
tree5063a90157609ded0326d8596bd683d1eee3f72b /games/atr3d
parented5c05b87309da9e2dfc635c84076737fcc2bb89 (diff)
downloadports-73848a8928551ead1a2978f9b19dc992c796d48c.tar.gz
ports-73848a8928551ead1a2978f9b19dc992c796d48c.zip
games/atr3d: fix build on GCC architectures
OpenAL needs C++11 compiler: /usr/local/lib/libopenal.so: undefined reference to `vtable for std::__cxx11::basic_istringstream<char, std::char_traits<char>, std::allocator<char> >@GLIBCXX_3.4.21'
Notes
Notes: svn path=/head/; revision=519600
Diffstat (limited to 'games/atr3d')
-rw-r--r--games/atr3d/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index f86e0c506bb4..fa6f8482d2f2 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -29,7 +29,7 @@ LLD_UNSAFE= yes
OPTIONS_DEFINE= OPENAL
OPTIONS_DEFAULT=OPENAL
-OPENAL_USES= openal:alut
+OPENAL_USES= compiler:c++11-lang openal:alut
OPENAL_CONFIGURE_ENABLE= sound
pre-patch: