aboutsummaryrefslogtreecommitdiff
path: root/games/atr3d
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-03-10 16:01:51 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-03-10 16:01:51 +0000
commitb2bf4c83635aca20686b5f379ae42ed37ef7a19f (patch)
tree39bda9e5c1e8aa3a9813348b9c9ddd78b9d37619 /games/atr3d
parent274ccbf3a6bb1adedc51ed62f9bd30b67c5c841f (diff)
downloadports-b2bf4c83635aca20686b5f379ae42ed37ef7a19f.tar.gz
ports-b2bf4c83635aca20686b5f379ae42ed37ef7a19f.zip
- Remove USE_X_PREFIX in favor of USE_XORG
- Respect USE_GL - Add optional sound knob Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=208735
Diffstat (limited to 'games/atr3d')
-rw-r--r--games/atr3d/Makefile22
1 files changed, 15 insertions, 7 deletions
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index 303e4e2ce6e0..5ae38c61b736 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -7,7 +7,7 @@
PORTNAME= atr3d
PORTVERSION= 0.6
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= games
MASTER_SITES= ftp://ftp.avoidtheroid.com/pub/${PORTNAME}/
DISTNAME= ${PORTNAME}_source_${PORTVERSION}
@@ -16,17 +16,15 @@ EXTRACT_SUFX= .tgz
MAINTAINER= gahr@FreeBSD.org
COMMENT= 3D asteroids-like multiplayer game
-LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
- glut.4:${PORTSDIR}/graphics/libglut \
- alut.1:${PORTSDIR}/audio/freealut
+OPTIONS= SOUND "Enable sound" ON
SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GL= yes
+USE_GL= glut glu
+USE_XORG= xmu xi x11
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
@@ -38,6 +36,16 @@ USE_AUTOTOOLS= automake:19 autoconf:261
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_SOUND)
+LIB_DEPENDS+= alut.1:${PORTSDIR}/audio/freealut
+CONFIGURE_ARGS+= --enable-sound
+.else
+CONFIGURE_ARGS+= --disable-sound
+.endif
+
pre-patch:
@${PERL} -pi.orig -e 's|^aclocal|${ACLOCAL}|; \
s|^autoconf|${AUTOCONF}|; s|^automake|${AUTOMAKE}|' \
@@ -55,4 +63,4 @@ post-configure:
's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>