aboutsummaryrefslogtreecommitdiff
path: root/games/atr3d
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2006-04-23 10:14:30 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2006-04-23 10:14:30 +0000
commitc36bc8fc881f6eb4d76f3f8f7844854f3a828226 (patch)
treeaaf30a64e30860d610400f7306d965534b1f9570 /games/atr3d
parentf17a91a7d963df9d89cec69323edd437ef8eb1ea (diff)
downloadports-c36bc8fc881f6eb4d76f3f8f7844854f3a828226.tar.gz
ports-c36bc8fc881f6eb4d76f3f8f7844854f3a828226.zip
update to openal 20060211 [1]
fix dependant ports [2] PR: ports/96172 [1] ports/95192 [2] Submitted by: maintainer [1] oliver [2] Approved by: maintainer
Notes
Notes: svn path=/head/; revision=160213
Diffstat (limited to 'games/atr3d')
-rw-r--r--games/atr3d/Makefile4
-rw-r--r--games/atr3d/files/patch-sound.cpp21
2 files changed, 24 insertions, 1 deletions
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index 851837b46b5c..934f53c31063 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -17,7 +17,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= 3D asteroids-like multiplayer game
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
- glut.4:${PORTSDIR}/graphics/libglut
+ glut.4:${PORTSDIR}/graphics/libglut \
+ alut.0:${PORTSDIR}/audio/freealut
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
@@ -42,6 +43,7 @@ pre-patch:
@${PERL} -pi.orig -e 's|^aclocal|${ACLOCAL}|; \
s|^autoconf|${AUTOCONF}|; s|^automake|${AUTOMAKE}|' \
${WRKSRC}/autogen.sh
+ @${REINPLACE_CMD} -e 's|-lopenal|& -lalut|' ${WRKSRC}/Makefile.am
pre-configure:
cd ${WRKSRC}; ${SH} autogen.sh
diff --git a/games/atr3d/files/patch-sound.cpp b/games/atr3d/files/patch-sound.cpp
new file mode 100644
index 000000000000..22f8945687d3
--- /dev/null
+++ b/games/atr3d/files/patch-sound.cpp
@@ -0,0 +1,21 @@
+--- sound.cpp.orig Wed Mar 29 15:09:51 2006
++++ sound.cpp Wed Mar 29 15:11:11 2006
+@@ -288,6 +288,7 @@
+ {
+ int i;
+ char filename[1000];
++ ALboolean loop;
+
+ for (i=0; i<NUM_SOUNDS; i++) {
+ #ifdef WINDOWS
+@@ -296,8 +297,8 @@
+ sprintf(filename, "%s/atr3d/sounds/%d.wav", DATADIR, i);
+ #endif
+
+- alutLoadWAV(filename, &Wavs[i].wave, &Wavs[i].format,
+- &Wavs[i].size, &Wavs[i].bits, &Wavs[i].freq);
++ alutLoadWAVFile((ALbyte*)filename, &Wavs[i].format, &Wavs[i].wave,
++ &Wavs[i].size, &Wavs[i].freq, &loop);
+ }
+ }
+ #endif