aboutsummaryrefslogtreecommitdiff
path: root/games/atris
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-12-08 19:21:23 +0000
committerJohn Marino <marino@FreeBSD.org>2013-12-08 19:21:23 +0000
commit14c239f42a0e7650a715a2b78ba29d9b35bef99a (patch)
treeda311abc8d4dc06c3055717efcc1267f97689427 /games/atris
parent42058a78a326ae165665ef324ca8dca4e7eef769 (diff)
downloadports-14c239f42a0e7650a715a2b78ba29d9b35bef99a.tar.gz
ports-14c239f42a0e7650a715a2b78ba29d9b35bef99a.zip
games/atris: Use gmake as specified
This port specifies gmake, but "make" was hardcoded. This becomes apparent when bmake is used to build the port (it fails). The new post-patch command allows gmake to be used as intended. PR: ports/181731 Submitted by: Jan Beich
Notes
Notes: svn path=/head/; revision=335927
Diffstat (limited to 'games/atris')
-rw-r--r--games/atris/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/atris/Makefile b/games/atris/Makefile
index b62b5e1ca4ca..9b1576eeab91 100644
--- a/games/atris/Makefile
+++ b/games/atris/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www.sourcefiles.org/Games/Arcade/Block_Based/Tetris/
MAINTAINER= ports@FreeBSD.org
COMMENT= Atris: Alizarin Tetris
-USE_GMAKE= yes
+USES= gmake
USE_SDL= sdl ttf
GNU_CONFIGURE= yes
@@ -24,6 +24,9 @@ post-patch:
# Fix path to ${DATADIR}
${REINPLACE_CMD} -e 's|\(GAME_INSTALLDIR=\).*|\1"${DATADIR}"|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+# Fix install target to use gmake
+ ${REINPLACE_CMD} -e '/^install:/,/^$$/s/make/$$(MAKE)/' \
+ ${WRKSRC}/Makefile.in
# Fix SDL include statement
.for f in *.c *.h