aboutsummaryrefslogtreecommitdiff
path: root/games/auralquiz
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-06-06 17:15:36 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-06-06 17:15:36 +0000
commitc948f928e591da031e591362ec0aeb782a1b9b97 (patch)
tree00c8c5b37d5476feea57de69f35b1fdd8a11e1d0 /games/auralquiz
parent9de6aff58e9e34227f73dd6b173ff5c839a4060e (diff)
downloadports-c948f928e591da031e591362ec0aeb782a1b9b97.tar.gz
ports-c948f928e591da031e591362ec0aeb782a1b9b97.zip
- Add games/auralquiz
Auralquiz is a simple music quiz game for GNU/Linux, using your own music files. The game plays short pieces of music files from your folders (in Ogg Vorbis, FLAC, Opus or MP3 formats), and presents a question and several answers about the current song. The fastest the answer, the more points you receive. Up to 8 people can play in a turn-based mode. In the highest difficulty level there are no answer buttons, and instead, you have to type the answer yourself. WWW: https://jancoding.wordpress.com/auralquiz/
Notes
Notes: svn path=/head/; revision=442785
Diffstat (limited to 'games/auralquiz')
-rw-r--r--games/auralquiz/Makefile37
-rw-r--r--games/auralquiz/distinfo3
-rw-r--r--games/auralquiz/files/patch-Auralquiz.pro27
-rw-r--r--games/auralquiz/pkg-descr14
-rw-r--r--games/auralquiz/pkg-plist4
5 files changed, 85 insertions, 0 deletions
diff --git a/games/auralquiz/Makefile b/games/auralquiz/Makefile
new file mode 100644
index 000000000000..cb66419a2b50
--- /dev/null
+++ b/games/auralquiz/Makefile
@@ -0,0 +1,37 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= auralquiz
+PORTVERSION= 1.0.0
+DISTVERSIONPREFIX= v
+CATEGORIES= games
+MASTER_SITES= SAVANNAH
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Simple music quiz game using your own music files
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libtag.so:audio/taglib
+
+USES= qmake
+USE_GL= gl
+USE_QT5= core gui widgets phonon4 qmake_build buildtools_build
+
+PORTDOCS= CHANGELOG README TODO
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|; \
+ s|%%MAN6PREFIX%%|${MAN6PREFIX}|' \
+ ${WRKSRC}/Auralquiz.pro
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/auralquiz/distinfo b/games/auralquiz/distinfo
new file mode 100644
index 000000000000..a88b5d968124
--- /dev/null
+++ b/games/auralquiz/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1496674606
+SHA256 (auralquiz-v1.0.0.tar.gz) = fc1090de1db53eb39250d65788baab5a130509770e4267269fcbd2be91b68778
+SIZE (auralquiz-v1.0.0.tar.gz) = 913550
diff --git a/games/auralquiz/files/patch-Auralquiz.pro b/games/auralquiz/files/patch-Auralquiz.pro
new file mode 100644
index 000000000000..9795e7fbd1a5
--- /dev/null
+++ b/games/auralquiz/files/patch-Auralquiz.pro
@@ -0,0 +1,27 @@
+--- Auralquiz.pro.orig 2017-05-11 10:46:54 UTC
++++ Auralquiz.pro
+@@ -89,19 +89,19 @@ TRANSLATIONS += translations/auralquiz_e
+ LIBS += -ltag # to use TagLib
+
+ ## This is here so the makefile has a 'make install' target
+-target.path = /usr/games/
++target.path = %%PREFIX%%/bin/
+
+ desktop_file.files = auralquiz.desktop
+-desktop_file.path = /usr/share/applications/
++desktop_file.path = %%PREFIX%%/share/applications/
+
+ man_file.files = manual/auralquiz.6
+-man_file.path = /usr/share/man/man6/
++man_file.path = %%MAN6PREFIX%%/man/man6/
+
+ #icon32_png.files = icon/32x32/auralquiz.png
+-#icon32_png.path = /usr/share/icons/hicolor/32x32/apps/
++#icon32_png.path = %%PREFIX%%/share/icons/hicolor/32x32/apps/
+
+ icon64_png.files = icon/64x64/auralquiz.png
+-icon64_png.path = /usr/share/icons/hicolor/64x64/apps/
++icon64_png.path = %%PREFIX%%/share/icons/hicolor/64x64/apps/
+
+ INSTALLS += target \
+ desktop_file \
diff --git a/games/auralquiz/pkg-descr b/games/auralquiz/pkg-descr
new file mode 100644
index 000000000000..46217258a6d0
--- /dev/null
+++ b/games/auralquiz/pkg-descr
@@ -0,0 +1,14 @@
+Auralquiz is a simple music quiz game for GNU/Linux, using your own
+music files.
+
+The game plays short pieces of music files from your folders (in
+Ogg Vorbis, FLAC, Opus or MP3 formats), and presents a question and
+several answers about the current song. The fastest the answer, the
+more points you receive.
+
+Up to 8 people can play in a turn-based mode.
+
+In the highest difficulty level there are no answer buttons, and
+instead, you have to type the answer yourself.
+
+WWW: https://jancoding.wordpress.com/auralquiz/
diff --git a/games/auralquiz/pkg-plist b/games/auralquiz/pkg-plist
new file mode 100644
index 000000000000..6df46cc73377
--- /dev/null
+++ b/games/auralquiz/pkg-plist
@@ -0,0 +1,4 @@
+bin/auralquiz
+man/man6/auralquiz.6.gz
+share/icons/hicolor/64x64/apps/auralquiz.png
+share/applications/auralquiz.desktop