aboutsummaryrefslogtreecommitdiff
path: root/games/avanor
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-27 08:21:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-02-27 08:21:23 +0000
commit3c2b81abaf0dc525dd072546cbba7aa5acb59004 (patch)
treed626e9e2ab03bc3eae830b86e45da121a618a80d /games/avanor
parentc72cc2f779c767d150154111fde95da7f36e6089 (diff)
downloadports-3c2b81abaf0dc525dd072546cbba7aa5acb59004.tar.gz
ports-3c2b81abaf0dc525dd072546cbba7aa5acb59004.zip
Avanor is a roguelike game with a easy ADOM-like user interface, it
has countryside and subterranean areas to explore, a quest system, and some original features. WWW: http://www.avanor.com/ PR: ports/109588 Submitted by: Martin Tournoij <carpetsmoker at xs4all.nl>
Notes
Notes: svn path=/head/; revision=186094
Diffstat (limited to 'games/avanor')
-rw-r--r--games/avanor/Makefile35
-rw-r--r--games/avanor/distinfo3
-rw-r--r--games/avanor/pkg-descr5
-rw-r--r--games/avanor/pkg-plist17
4 files changed, 60 insertions, 0 deletions
diff --git a/games/avanor/Makefile b/games/avanor/Makefile
new file mode 100644
index 000000000000..5921ff706514
--- /dev/null
+++ b/games/avanor/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: avanor
+# Date created: 2007-02-27
+# Whom: Martin Tournoij <carpetsmoker@xs4all.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= avanor
+PORTVERSION= 0.5.8
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= avanor
+DISTFILES= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= carpetsmoker@xs4all.nl
+COMMENT= Rogue-like game with easy ADOM-like user interface
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+MAKE_ARGS+= VERSION=${PORTVERSION} DATA_DIR=${DATADIR}/
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|g++|${CXX}|; \
+ s|CFLAGS =|CFLAGS+=|;" \
+ ${WRKSRC}/Makefile
+
+ @${REINPLACE_CMD} -e "s|DATA_DIR|\"~/.avanor/\"|" \
+ ${WRKSRC}/helpers/hiscore.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/avanor ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}/manual
+ ${INSTALL_DATA} ${WRKSRC}/manual/* ${DATADIR}/manual/
+
+.include <bsd.port.mk>
diff --git a/games/avanor/distinfo b/games/avanor/distinfo
new file mode 100644
index 000000000000..7609c0c9053a
--- /dev/null
+++ b/games/avanor/distinfo
@@ -0,0 +1,3 @@
+MD5 (avanor-0.5.8-src) = 20067962b9635b1789933ddd7933d142
+SHA256 (avanor-0.5.8-src) = 8f55be83d985470b9a5220263fc87d0a0a6e2b60dbbc977c1c49347321379ef3
+SIZE (avanor-0.5.8-src) = 194587
diff --git a/games/avanor/pkg-descr b/games/avanor/pkg-descr
new file mode 100644
index 000000000000..d9d6e674bc57
--- /dev/null
+++ b/games/avanor/pkg-descr
@@ -0,0 +1,5 @@
+Avanor is a roguelike game with a easy ADOM-like user interface, it
+has countryside and subterranean areas to explore, a quest system, and
+some original features.
+
+WWW: http://www.avanor.com/
diff --git a/games/avanor/pkg-plist b/games/avanor/pkg-plist
new file mode 100644
index 000000000000..a654f695f389
--- /dev/null
+++ b/games/avanor/pkg-plist
@@ -0,0 +1,17 @@
+bin/avanor
+%%DATADIR%%/manual/basic.html
+%%DATADIR%%/manual/credits.html
+%%DATADIR%%/manual/equipment.html
+%%DATADIR%%/manual/index.html
+%%DATADIR%%/manual/intro.html
+%%DATADIR%%/manual/kblayout.html
+%%DATADIR%%/manual/magic.html
+%%DATADIR%%/manual/manual.css
+%%DATADIR%%/manual/misc.html
+%%DATADIR%%/manual/qstart.html
+%%DATADIR%%/manual/skills.html
+%%DATADIR%%/manual/tactics.html
+%%DATADIR%%/manual/testmode.html
+%%DATADIR%%/manual/wskills.html
+@dirrm %%DATADIR%%/manual
+@dirrm %%DATADIR%%