aboutsummaryrefslogtreecommitdiff
path: root/games/awele
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-05-05 08:00:27 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-05-05 08:00:27 +0000
commita3d85957d28a15ef1a5ecccb7c12707b6c2ac9aa (patch)
treee4ca2b6a92884161df4dfcff0b8b443c952de4d7 /games/awele
parent7f9110e8e872eb4bd5ad8e3718cb653b26bca365 (diff)
downloadports-a3d85957d28a15ef1a5ecccb7c12707b6c2ac9aa.tar.gz
ports-a3d85957d28a15ef1a5ecccb7c12707b6c2ac9aa.zip
New port awele. awele is an african board game.
Notes
Notes: svn path=/head/; revision=10857
Diffstat (limited to 'games/awele')
-rw-r--r--games/awele/Makefile27
-rw-r--r--games/awele/distinfo1
-rw-r--r--games/awele/files/patch-aa20
-rw-r--r--games/awele/files/patch-ab62
-rw-r--r--games/awele/files/patch-ac8
-rw-r--r--games/awele/pkg-comment1
-rw-r--r--games/awele/pkg-descr8
-rw-r--r--games/awele/pkg-plist3
8 files changed, 130 insertions, 0 deletions
diff --git a/games/awele/Makefile b/games/awele/Makefile
new file mode 100644
index 000000000000..1482f16f5090
--- /dev/null
+++ b/games/awele/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: awele
+# Version required: 1.0
+# Date created: 01 May 1998
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= awele
+PKGNAME= awele-1.0
+CATEGORIES= games tk80
+MASTER_SITES= http://www-rocq.inria.fr/air/ftp/Jean-Paul/
+EXTRACT_SUFX= 1.0.tgz
+
+MAINTAINER= tg@FreeBSD.ORG
+
+USE_IMAKE= yes
+NO_INSTALL_MANPAGES= yes
+MAN6= xawele.6
+
+post-patch:
+ @/usr/bin/perl -pi -e "s|@@LOCALBASE@@|${LOCALBASE}|g;" ${WRKSRC}/Imakefile
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/xawele.man ${PREFIX}/man/man6/xawele.6
+
+.include <bsd.port.mk>
diff --git a/games/awele/distinfo b/games/awele/distinfo
new file mode 100644
index 000000000000..616da6368b3c
--- /dev/null
+++ b/games/awele/distinfo
@@ -0,0 +1 @@
+MD5 (awele1.0.tgz) = bbf26f4336d41b15febf655bfc3c7704
diff --git a/games/awele/files/patch-aa b/games/awele/files/patch-aa
new file mode 100644
index 000000000000..3879b3204e68
--- /dev/null
+++ b/games/awele/files/patch-aa
@@ -0,0 +1,20 @@
+--- Imakefile.orig Fri Dec 8 16:35:38 1995
++++ Imakefile Fri May 1 09:44:16 1998
+@@ -2,14 +2,14 @@
+
+
+ XCOMM install directory
+- AWELE_DIR = /user/berroir/src/awele/install
++ AWELE_DIR = $(BINDIR)
+ XCOMM tcl/tk script
+ AWELE_SCRIPT = xawele
+ XCOMM libs, includes
+ XCOMM TK_LIB AND TK_INCLUDE stand for tk and tcl
+- TK_LIB = -L/usr/local/lib -ltk -ltcl
++ TK_LIB = -L@@LOCALBASE@@/lib -ltk80 -ltcl80
+ XCOMM TK_LIB = -L/usr/local/lib -ltk4.0 -ltcl7.4
+- TK_INCLUDE = -I/usr/local/include
++ TK_INCLUDE = -I@@LOCALBASE@@/include/tcl8.0 -I@@LOCALBASE@@/include/tk8.0
+ DEFINES = $(TK_INCLUDE)
+ LOCAL_LIBRARIES = $(TK_LIB) -lX11 -lm
+ XCOMM ANSI-C compiler
diff --git a/games/awele/files/patch-ab b/games/awele/files/patch-ab
new file mode 100644
index 000000000000..cfc786f006f9
--- /dev/null
+++ b/games/awele/files/patch-ab
@@ -0,0 +1,62 @@
+--- tkAppInit.c.orig Fri Dec 8 16:35:38 1995
++++ tkAppInit.c Fri May 1 09:36:18 1998
+@@ -9,12 +9,10 @@
+ *
+ * See the file "license.terms" for information on usage and redistribution
+ * of this file, and for a DISCLAIMER OF ALL WARRANTIES.
++ *
++ * SCCS: @(#) tkAppInit.c 1.22 96/05/29 09:47:08
+ */
+
+-#ifndef lint
+-static char sccsid[] = "@(#) tkAppInit.c 1.15 95/06/28 13:14:28";
+-#endif /* not lint */
+-
+ #include "tk.h"
+
+ extern void create_commands(Tcl_Interp *,Tk_Window);
+@@ -27,6 +25,7 @@
+
+ extern int matherr();
+ int *tclDummyMathPtr = (int *) matherr;
++
+
+ /*
+ *----------------------------------------------------------------------
+@@ -77,14 +76,13 @@
+ Tcl_AppInit(interp)
+ Tcl_Interp *interp; /* Interpreter for application. */
+ {
+- Tk_Window main;
+-
+ if (Tcl_Init(interp) == TCL_ERROR) {
+ return TCL_ERROR;
+ }
+ if (Tk_Init(interp) == TCL_ERROR) {
+ return TCL_ERROR;
+ }
++ Tcl_StaticPackage(interp, "Tk", Tk_Init, Tk_SafeInit);
+
+ /*
+ * Call the init procedures for included packages. Each call should
+@@ -103,17 +101,14 @@
+ */
+ create_commands(interp, main);
+ link_global_variables(interp, main);
+-
++
+ /*
+ * Specify a user-specific startup file to invoke if the application
+ * is run interactively. Typically the startup file is "~/.apprc"
+ * where "app" is the name of the application. If this line is deleted
+ * then no user-specific startup file will be run under any conditions.
+ */
+-#ifdef DEFAULT_TCL_SCRIPT
+- tcl_RcFileName = DEFAULT_TCL_SCRIPT ;
+-#else
+- tcl_RcFileName = "~/.wishrc";
+-#endif
++
++ Tcl_SetVar(interp, "tcl_rcFileName", "~/.wishrc", TCL_GLOBAL_ONLY);
+ return TCL_OK;
+ }
diff --git a/games/awele/files/patch-ac b/games/awele/files/patch-ac
new file mode 100644
index 000000000000..aff2a698de46
--- /dev/null
+++ b/games/awele/files/patch-ac
@@ -0,0 +1,8 @@
+--- xawele.orig Fri Dec 8 16:35:38 1995
++++ xawele Fri May 1 09:46:54 1998
+@@ -1,4 +1,4 @@
+-#!/a/air/alpha-bin/awelewish -f
++#!/usr/bin/env awelewish
+
+ # variables connues de C et de TCL
+ set levelname "REGULAR"
diff --git a/games/awele/pkg-comment b/games/awele/pkg-comment
new file mode 100644
index 000000000000..a4514d9e7047
--- /dev/null
+++ b/games/awele/pkg-comment
@@ -0,0 +1 @@
+An african board game.
diff --git a/games/awele/pkg-descr b/games/awele/pkg-descr
new file mode 100644
index 000000000000..93f2ce3e53df
--- /dev/null
+++ b/games/awele/pkg-descr
@@ -0,0 +1,8 @@
+The game of Awele is a popular african game, also known as "Sungo"
+or "Ubao". It is made of a wooden board with 12 holes containing
+some kind of stones. The aim is to capture as many stones as
+possible. There exist varieties of rules. I implemented the one
+I know, which is one of the most popular (in Ivory Coast at least).
+
+Send comments, suggestions, claims to:
+ jean-paul.berroir@inria.fr
diff --git a/games/awele/pkg-plist b/games/awele/pkg-plist
new file mode 100644
index 000000000000..69d0b82c59b4
--- /dev/null
+++ b/games/awele/pkg-plist
@@ -0,0 +1,3 @@
+bin/awelewish
+bin/xawele
+man/man6/xawele.6.gz