aboutsummaryrefslogtreecommitdiff
path: root/games/awele
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-12-13 12:03:22 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-12-13 12:03:22 +0000
commitefd701973ade981486eb3405d96e1e27ec44a6cb (patch)
tree30469958f0d28721f72c5b24c1e433ea5ac6b4cc /games/awele
parentb36ae732b437980a35e03b21412561a294f8ac24 (diff)
downloadports-efd701973ade981486eb3405d96e1e27ec44a6cb.tar.gz
ports-efd701973ade981486eb3405d96e1e27ec44a6cb.zip
Fix manpage installation with XFree86-4.
PR: 23424 Submitted by: FUJISHIMA Satsuki <k5@cheerful.com>
Notes
Notes: svn path=/head/; revision=35951
Diffstat (limited to 'games/awele')
-rw-r--r--games/awele/Makefile6
-rw-r--r--games/awele/files/patch-aa29
2 files changed, 27 insertions, 8 deletions
diff --git a/games/awele/Makefile b/games/awele/Makefile
index 0cbd0948db93..bbe2266a5c1b 100644
--- a/games/awele/Makefile
+++ b/games/awele/Makefile
@@ -17,13 +17,9 @@ LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
WRKSRC= ${WRKDIR}/awele
USE_IMAKE= yes
-NO_INSTALL_MANPAGES= yes
MAN6= xawele.6
post-patch:
- @/usr/bin/perl -pi -e "s|\@\@LOCALBASE\@\@|${LOCALBASE}|g;" ${WRKSRC}/Imakefile
-
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/xawele.man ${PREFIX}/man/man6/xawele.6
+ ${PERL} -pi -e "s|\@\@LOCALBASE\@\@|${LOCALBASE}|g;" ${WRKSRC}/Imakefile
.include <bsd.port.mk>
diff --git a/games/awele/files/patch-aa b/games/awele/files/patch-aa
index 49b3146ec235..873a72ece4bf 100644
--- a/games/awele/files/patch-aa
+++ b/games/awele/files/patch-aa
@@ -1,6 +1,6 @@
---- Imakefile.orig Fri Dec 8 16:35:38 1995
-+++ Imakefile Fri May 1 09:44:16 1998
-@@ -2,14 +2,14 @@
+--- Imakefile.orig Sat Dec 9 00:35:38 1995
++++ Imakefile Wed Nov 1 06:58:15 2000
+@@ -2,31 +2,31 @@
XCOMM install directory
@@ -18,3 +18,26 @@
DEFINES = $(TK_INCLUDE)
LOCAL_LIBRARIES = $(TK_LIB) -lX11 -lm
XCOMM ANSI-C compiler
+- CC = gcc
++XCOMM CC = gcc
+
+ XCOMM Please don't change anything below this point
+
+ DEPLIBS = $(DEPXLIB)
+
+- SRCS1 = tkAppInit.c awelewish.c alphabeta.c move.c util.c
+- OBJS1 = tkAppInit.o awelewish.o alphabeta.o move.o util.o
++ SRCS = tkAppInit.c awelewish.c alphabeta.c move.c util.c
++ OBJS = tkAppInit.o awelewish.o alphabeta.o move.o util.o
+
+ PROGRAMS = awelewish
++ MANSUFFIX = 6
+
+-all:: $(PROGRAMS)
+-
+-ComplexProgramTarget_1($(PROGRAMS), $(LOCAL_LIBRARIES), )
++ComplexProgramTargetNoMan($(PROGRAMS))
++InstallManPage(xawele,$(MANDIR))
+
+ install:: $(PROGRAMS) $(AWELE_SCRIPT)
+ @echo "AWELE directory is " $(AWELE_DIR)