aboutsummaryrefslogtreecommitdiff
path: root/games/ballerburg
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-07-07 07:51:52 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-07-07 07:51:52 +0000
commit601a3b8d274c8673b04905bdd4d9eca54e02caf9 (patch)
tree80ff2fc83096483172236a745a9581f4f06fa9f0 /games/ballerburg
parent6ba5d058c2bf92c8e70d81d742f17b011f10d749 (diff)
downloadports-601a3b8d274c8673b04905bdd4d9eca54e02caf9.tar.gz
ports-601a3b8d274c8673b04905bdd4d9eca54e02caf9.zip
Add ballerburg 1.2.0, two players, two castles, and a hill in between.
Notes
Notes: svn path=/head/; revision=445211
Diffstat (limited to 'games/ballerburg')
-rw-r--r--games/ballerburg/Makefile36
-rw-r--r--games/ballerburg/distinfo5
-rw-r--r--games/ballerburg/files/patch-CMakeLists.txt11
-rw-r--r--games/ballerburg/files/patch-po_CMakeLists.txt11
-rw-r--r--games/ballerburg/pkg-descr8
-rw-r--r--games/ballerburg/pkg-plist11
6 files changed, 82 insertions, 0 deletions
diff --git a/games/ballerburg/Makefile b/games/ballerburg/Makefile
new file mode 100644
index 000000000000..48e2ca8e6eba
--- /dev/null
+++ b/games/ballerburg/Makefile
@@ -0,0 +1,36 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ballerburg
+PORTVERSION= 1.2.0
+CATEGORIES= games
+MASTER_SITES= http://download.tuxfamily.org/baller/ \
+ LOCAL/ehaupt:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}-icons-1${EXTRACT_SUFX}:icons
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Two players, two castles, and a hill in between
+
+LICENSE= GPLv3+
+
+GNU_CONFIGURE= yes
+NLS_USES= gettext
+USES= cmake
+USE_SDL= sdl
+
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+DESKTOP_ENTRIES="Ballerburg" \
+ "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/ballerburg.png" \
+ "${PORTNAME}" \
+ "" \
+ false
+
+post-install:
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-icons-1/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+.include <bsd.port.mk>
diff --git a/games/ballerburg/distinfo b/games/ballerburg/distinfo
new file mode 100644
index 000000000000..898a2d4453e2
--- /dev/null
+++ b/games/ballerburg/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1499413186
+SHA256 (ballerburg-1.2.0.tar.gz) = 0625f4b213c1180f2cb2179ef2bc6ce35c7e99db2b27306a8690c389ceac6300
+SIZE (ballerburg-1.2.0.tar.gz) = 99910
+SHA256 (ballerburg-icons-1.tar.gz) = 14188ceb30c8d850b280fb402230199dd9f6a05cb7a0c84255c3e2ad227513b0
+SIZE (ballerburg-icons-1.tar.gz) = 786
diff --git a/games/ballerburg/files/patch-CMakeLists.txt b/games/ballerburg/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..c36427d00c96
--- /dev/null
+++ b/games/ballerburg/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2015-03-29 15:04:01 UTC
++++ CMakeLists.txt
+@@ -50,7 +50,7 @@ if(NOT BIN2LOCALEDIR)
+ endif()
+
+ if(NOT MANDIR)
+- set(MANDIR share/man/man6)
++ set(MANDIR man/man6)
+ endif()
+
+ if(NOT DOCDIR)
diff --git a/games/ballerburg/files/patch-po_CMakeLists.txt b/games/ballerburg/files/patch-po_CMakeLists.txt
new file mode 100644
index 000000000000..862189760d62
--- /dev/null
+++ b/games/ballerburg/files/patch-po_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- po/CMakeLists.txt.orig 2015-03-29 15:04:01 UTC
++++ po/CMakeLists.txt
+@@ -13,7 +13,7 @@ if (GETTEXT_FOUND)
+ --package-name=${CMAKE_PROJECT_NAME}
+ -o ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_PROJECT_NAME}.pot
+ ${CMAKE_CURRENT_SOURCE_DIR}/../src/*.c
+- COMMAND sed -i -e s/charset=CHARSET/charset=ISO-8859-1/
++ COMMAND sed -i".bak" -e s/charset=CHARSET/charset=ISO-8859-1/
+ -e s%"${CMAKE_CURRENT_SOURCE_DIR}/../"%%g
+ ${CMAKE_PROJECT_NAME}.pot
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../src/*.c
diff --git a/games/ballerburg/pkg-descr b/games/ballerburg/pkg-descr
new file mode 100644
index 000000000000..dd3ed95ca519
--- /dev/null
+++ b/games/ballerburg/pkg-descr
@@ -0,0 +1,8 @@
+Ballerburg SDL is a classical castle combat game. Two castles, separated by a
+mountain, try to defeat each other with their cannonballs, either by killing the
+opponent's king or by weakening the opponent enough so that the king
+capitulates.
+
+Ballerburg was originally written 1987, for the Atari ST machines.
+
+WWW: http://baller.tuxfamily.org/
diff --git a/games/ballerburg/pkg-plist b/games/ballerburg/pkg-plist
new file mode 100644
index 000000000000..46356ee3613f
--- /dev/null
+++ b/games/ballerburg/pkg-plist
@@ -0,0 +1,11 @@
+bin/ballerburg
+man/man6/ballerburg.6.gz
+share/pixmaps/ballerburg.png
+%%DATADIR%%/baller.dat
+%%DATADIR%%/baller.mus
+%%PORTDOCS%%%%DOCSDIR%%/anleitung.html
+%%PORTDOCS%%%%DOCSDIR%%/manual.html
+%%NLS%%share/locale/de/LC_MESSAGES/ballerburg.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/ballerburg.mo
+%%NLS%%share/locale/it/LC_MESSAGES/ballerburg.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/ballerburg.mo