aboutsummaryrefslogtreecommitdiff
path: root/games/barbie_seahorse_adventures/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2013-03-12 22:15:14 +0000
committerBeech Rintoul <beech@FreeBSD.org>2013-03-12 22:15:14 +0000
commit0c180ca84175f11e81551ec5c8bac9b86cfaa611 (patch)
treeb3c1fbdefbe1b733f9d05ba230932c4baff8cad1 /games/barbie_seahorse_adventures/Makefile
parent47568860f0426a6e8c16a1cdc912455e7d688604 (diff)
downloadports-0c180ca84175f11e81551ec5c8bac9b86cfaa611.tar.gz
ports-0c180ca84175f11e81551ec5c8bac9b86cfaa611.zip
Notes
Diffstat (limited to 'games/barbie_seahorse_adventures/Makefile')
-rw-r--r--games/barbie_seahorse_adventures/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/games/barbie_seahorse_adventures/Makefile b/games/barbie_seahorse_adventures/Makefile
index 55c24e1c8129..737cfae71967 100644
--- a/games/barbie_seahorse_adventures/Makefile
+++ b/games/barbie_seahorse_adventures/Makefile
@@ -1,7 +1,5 @@
# Created by: nemysis@gmx.ch
-#
# $FreeBSD$
-#
PORTNAME= barbie_seahorse_adventures
PORTVERSION= 1.0
@@ -10,9 +8,8 @@ CATEGORIES= games python
MASTER_SITES= http://www.imitationpickles.org/barbie/files/ \
SF/nemysisfreebsdp/:icons
DISTFILES= barbie-${DISTVERSION}${EXTRACT_SUFX} \
- ${PORTNAME}.png:icons
+ ${PORTNAME}_icons.tar.gz:icons
DIST_SUBDIR= python
-EXTRACT_ONLY= barbie-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= nemysis@gmx.ch
COMMENT= You are a seahorse and you want to go to the moon!
@@ -26,12 +23,11 @@ WRKSRC= ${WRKDIR}/barbie-${DISTVERSION}
USE_PYTHON= yes
NO_BUILD= yes
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.png
-
-PORTDATA= *
PORTDOCS= CHANGES.txt LEVELS.txt NOTES.txt README.txt TODO.txt
+INSTALLS_ICONS= yes
+ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
+
SUB_FILES= ${PORTNAME}
DESKTOP_ENTRIES="Barbie Seahorse Adventures" "${COMMENT}" "${PORTNAME}" \
@@ -42,14 +38,21 @@ DESKTOP_ENTRIES="Barbie Seahorse Adventures" "${COMMENT}" "${PORTNAME}" \
post-patch:
@${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' \
${WRKSRC}/leveledit.py ${WRKSRC}/tileedit.py
- @(cd ${WRKSRC} && ${RM} *.py.bak)
+ @${FIND} ${WRKSRC} -name "*.bak" -delete
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/*.py ${DATADIR}
@(cd ${WRKSRC} && ${COPYTREE_SHARE} "data lib" ${DATADIR})
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
+
+post-install:
+.for s in ${ICON_SIZES}
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
+ ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}