aboutsummaryrefslogtreecommitdiff
path: root/games/barrage/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-04-27 16:34:24 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-04-27 16:34:24 +0000
commit18b67ce51d18e36347dca289b01c7bec7f051f43 (patch)
tree3b29c3249a4686cfff01c941f908b82a251cd713 /games/barrage/Makefile
parent8b1d68ae92d8aa1c1a6f53c211c880645e6a1657 (diff)
downloadports-18b67ce51d18e36347dca289b01c7bec7f051f43.tar.gz
ports-18b67ce51d18e36347dca289b01c7bec7f051f43.zip
Notes
Diffstat (limited to 'games/barrage/Makefile')
-rw-r--r--games/barrage/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/games/barrage/Makefile b/games/barrage/Makefile
new file mode 100644
index 000000000000..0fa9bbfc9490
--- /dev/null
+++ b/games/barrage/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: barrage
+# Date created: 23 April 2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= barrage
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= lgames
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Destroy as many targets as possible
+
+LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
+ SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
+
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-profile-path=/var/games
+
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
+ CPPFLAGS="-I${X11BASE}/include"
+
+post-install:
+ ${CHMOD} 0755 ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>