aboutsummaryrefslogtreecommitdiff
path: root/games/battletanks
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-01-20 17:46:54 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-01-20 17:46:54 +0000
commitbb3ae2b610c690eee671237bf5beeb56c4662bd3 (patch)
tree77ddcb5ef11f8632862d895ef366fbb963db5bd0 /games/battletanks
parent0c784348472a67d23712404179a09ea273fbe8f8 (diff)
downloadports-bb3ae2b610c690eee671237bf5beeb56c4662bd3.tar.gz
ports-bb3ae2b610c690eee671237bf5beeb56c4662bd3.zip
games/battletanks: unbreak build with Clang 6 (C++14 by default)
In file included from engine/net/scanner.cpp:1: In file included from engine/src/config.h:33: In file included from ./mrt/xml.h:23: /usr/include/c++/v1/map:629:15: error: object of type 'std::__1::pair<const mrt::Socket::addr, Scanner::Host>' cannot be assigned because its copy assignment operator is implicitly deleted {__nc = __v.__cc; return *this;} ^ /usr/include/c++/v1/__tree:1645:35: note: in instantiation of member function 'std::__1::__value_type<const mrt::Socket::addr, Scanner::Host>::operator=' requested here __cache->__value_ = *__first; ^ /usr/include/c++/v1/__tree:1575:9: note: in instantiation of function template specialization 'std::__1::__tree<std::__1::__value_type<const mrt::Socket::addr, Scanner::Host>, std::__1::__map_value_compare<const mrt::Socket::addr, std::__1::__value_type<const mrt::Socket::addr, Scanner::Host>, std::__1::less<const mrt::Socket::addr>, true>, std::__1::allocator<std::__1::__value_type<const mrt::Socket::addr, Scanner::Host> > >::__assign_multi<std::__1::__tree_const_iterator<std::__1::__value_type<const mrt::Socket::addr, Scanner::Host>, std::__1::__tree_node<std::__1::__value_type<const mrt::Socket::addr, Scanner::Host>, void *> *, long> >' requested here __assign_multi(__t.begin(), __t.end()); ^ /usr/include/c++/v1/map:912:21: note: in instantiation of member function 'std::__1::__tree<std::__1::__value_type<const mrt::Socket::addr, Scanner::Host>, std::__1::__map_value_compare<const mrt::Socket::addr, std::__1::__value_type<const mrt::Socket::addr, Scanner::Host>, std::__1::less<const mrt::Socket::addr>, true>, std::__1::allocator<std::__1::__value_type<const mrt::Socket::addr, Scanner::Host> > >::operator=' requested here __tree_ = __m.__tree_; ^ engine/net/scanner.cpp:256:8: note: in instantiation of member function 'std::__1::map<const mrt::Socket::addr, Scanner::Host, std::__1::less<const mrt::Socket::addr>, std::__1::allocator<std::__1::pair<const mrt::Socket::addr, Scanner::Host> > >::operator=' requested here hosts = _hosts; ^ /usr/include/c++/v1/utility:325:5: note: copy assignment operator is implicitly deleted because 'pair<const mrt::Socket::addr, Scanner::Host>' has a user-declared move constructor pair(pair&&) = default; ^ Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=459537
Diffstat (limited to 'games/battletanks')
-rw-r--r--games/battletanks/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/games/battletanks/Makefile b/games/battletanks/Makefile
index 16e4fe85cf49..a06516280915 100644
--- a/games/battletanks/Makefile
+++ b/games/battletanks/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= libsigc-2.0.so:devel/libsigc++20 \
libsmpeg.so:multimedia/smpeg
USES= openal:al pkgconfig lua:51 python:2.7,build scons tar:bzip2
+USE_CXXSTD= gnu++98
USE_LDCONFIG= yes
USE_SDL= image sdl
MAKE_ARGS= prefix=${PREFIX} resources_dir=${DATADIR} \