aboutsummaryrefslogtreecommitdiff
path: root/games/blobby
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2013-03-29 10:22:43 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2013-03-29 10:22:43 +0000
commit77af481c8954cdd7d15f09c786fbf7fe3fdb3f5e (patch)
treefe6cd7d39c4f21580e793d7a74277daf5f4fb413 /games/blobby
parent1f05ffe74cb6cc0a2ee922ab3c781ca0a0120a87 (diff)
downloadports-77af481c8954cdd7d15f09c786fbf7fe3fdb3f5e.tar.gz
ports-77af481c8954cdd7d15f09c786fbf7fe3fdb3f5e.zip
- Update to 1.0r3
- Use new header format in Makefile
Notes
Notes: svn path=/head/; revision=315536
Diffstat (limited to 'games/blobby')
-rw-r--r--games/blobby/Makefile14
-rw-r--r--games/blobby/distinfo4
-rw-r--r--games/blobby/files/patch-src-raknet-BinarySearchTree.h66
-rw-r--r--games/blobby/files/patch-src-raknet-RakPeer.cpp10
4 files changed, 17 insertions, 77 deletions
diff --git a/games/blobby/Makefile b/games/blobby/Makefile
index dcecc29e170f..947e4c4089f7 100644
--- a/games/blobby/Makefile
+++ b/games/blobby/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: blobby
-# Date created: 01 Apr 2008
-# Whom: Ganael Laplanche <ganael.laplanche@martymac.org>
-#
+# Created by: Ganael Laplanche <ganael.laplanche@martymac.org>
# $FreeBSD$
-#
PORTNAME= blobby
-PORTVERSION= 1.0r1
+PORTVERSION= 1.0r3
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/Blobby%20Volley%202%20%28Linux%29/1.0RC1/
-DISTNAME= blobby2-linux-1.0rc1
+MASTER_SITES= SF/${PORTNAME}/Blobby%20Volley%202%20%28Linux%29/1.0RC3/
+DISTNAME= blobby2-linux-1.0rc3
MAINTAINER= martymac@FreeBSD.org
COMMENT= Official continuation of the famous Blobby Volley 1.x game
@@ -26,7 +22,7 @@ USE_SDL= sdl
USE_GL= glu
USES= cmake
CMAKE_ARGS+= -DDATADIR:PATH="${DATADIR}"
-WRKSRC= ${WRKDIR}/blobby-1.0rc1
+WRKSRC= ${WRKDIR}/blobby-1.0rc3
USE_DOS2UNIX= yes
DOS2UNIX_REGEX= .*\.(c|h|cpp)
diff --git a/games/blobby/distinfo b/games/blobby/distinfo
index 49a454e3eb9f..f245db6c2da8 100644
--- a/games/blobby/distinfo
+++ b/games/blobby/distinfo
@@ -1,2 +1,2 @@
-SHA256 (blobby2-linux-1.0rc1.tar.gz) = de113d71fb195c59528c55601d0b282945a5041ee4feca446013ef30da3265b1
-SIZE (blobby2-linux-1.0rc1.tar.gz) = 2215914
+SHA256 (blobby2-linux-1.0rc3.tar.gz) = 45bdb2530b7eb1b508693d304e31088c9a9b366f978f716b5a0cf1e7c502c581
+SIZE (blobby2-linux-1.0rc3.tar.gz) = 2323776
diff --git a/games/blobby/files/patch-src-raknet-BinarySearchTree.h b/games/blobby/files/patch-src-raknet-BinarySearchTree.h
deleted file mode 100644
index 13cbb9fdb6cd..000000000000
--- a/games/blobby/files/patch-src-raknet-BinarySearchTree.h
+++ /dev/null
@@ -1,66 +0,0 @@
---- src/raknet/BinarySearchTree.h.orig 2011-11-10 19:09:02.760002087 +0100
-+++ src/raknet/BinarySearchTree.h 2011-11-10 19:16:43.285213671 +0100
-@@ -338,12 +338,12 @@
- if ( current->left == 0 )
- left_height = 0;
- else
-- left_height = height( current->left );
-+ left_height = this->height( current->left );
-
- if ( current->right == 0 )
- right_height = 0;
- else
-- right_height = height( current->right );
-+ right_height = this->height( current->right );
-
- if ( right_height - left_height == 2 )
- {
-@@ -371,7 +371,7 @@
- if ( current == this->root )
- break;
-
-- current = find_parent( *( current->item ) );
-+ current = this->find_parent( *( current->item ) );
-
- }
- }
-@@ -400,7 +400,7 @@
- if ( A == 0 )
- return false;
-
-- return height( A->right ) > height( A->left );
-+ return this->height( A->right ) > this->height( A->left );
- }
-
- template <class BinarySearchTreeType>
-@@ -409,7 +409,7 @@
- if ( A == 0 )
- return false;
-
-- return height( A->left ) > height( A->right );
-+ return this->height( A->left ) > this->height( A->right );
- }
-
- template <class BinarySearchTreeType>
-@@ -446,8 +446,8 @@
-
- */
-
-- B = find_parent( *( C->item ) );
-- A = find_parent( *( B->item ) );
-+ B = this->find_parent( *( C->item ) );
-+ A = this->find_parent( *( B->item ) );
- D = C->right;
-
- if ( A )
-@@ -510,8 +510,8 @@
-
- */
-
-- B = find_parent( *( C->item ) );
-- A = find_parent( *( B->item ) );
-+ B = this->find_parent( *( C->item ) );
-+ A = this->find_parent( *( B->item ) );
- D = C->left;
-
- if ( A )
diff --git a/games/blobby/files/patch-src-raknet-RakPeer.cpp b/games/blobby/files/patch-src-raknet-RakPeer.cpp
new file mode 100644
index 000000000000..c51acb4009e1
--- /dev/null
+++ b/games/blobby/files/patch-src-raknet-RakPeer.cpp
@@ -0,0 +1,10 @@
+--- src/raknet/RakPeer.cpp.orig 2013-03-28 17:46:00.000000000 +0100
++++ src/raknet/RakPeer.cpp 2013-03-28 17:55:11.000000000 +0100
+@@ -1060,7 +1060,6 @@
+
+ for ( ; index < banList.size(); index++ )
+ {
+- delete [] banList[ index ]->IP;
+ delete [] banList[ index ];
+ }
+