aboutsummaryrefslogtreecommitdiff
path: root/games/blobwars
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-31 13:27:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-31 13:27:18 +0000
commite45db0c53504eea5291594ac9dd5825cc13d35d5 (patch)
tree0474bdbab0aab3b1c21ed6aa19ed023033c3fcbf /games/blobwars
parent2ba7749b7e0d55ef38679252c8a8dc3ccf4b4227 (diff)
downloadports-e45db0c53504eea5291594ac9dd5825cc13d35d5.tar.gz
ports-e45db0c53504eea5291594ac9dd5825cc13d35d5.zip
- Fix build with gcc 4.2
PR: 117699 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=202460
Diffstat (limited to 'games/blobwars')
-rw-r--r--games/blobwars/Makefile8
-rw-r--r--games/blobwars/files/patch-src-CFileData.h9
-rw-r--r--games/blobwars/files/patch-src-CKeyboard.h10
3 files changed, 20 insertions, 7 deletions
diff --git a/games/blobwars/Makefile b/games/blobwars/Makefile
index 5b55864a6091..ce8429f2932c 100644
--- a/games/blobwars/Makefile
+++ b/games/blobwars/Makefile
@@ -36,10 +36,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/blobwars/files/patch-src-CFileData.h b/games/blobwars/files/patch-src-CFileData.h
new file mode 100644
index 000000000000..1694343b105d
--- /dev/null
+++ b/games/blobwars/files/patch-src-CFileData.h
@@ -0,0 +1,9 @@
+--- src/CFileData.h.orig 2005-04-25 18:25:38.000000000 +0000
++++ src/CFileData.h 2007-10-31 02:26:03.000000000 +0000
+@@ -30,5 +30,5 @@
+ FileData();
+
+ void swapEndians();
+- void FileData::set(char *filename, Uint32 fSize, Uint32 cSize, Uint32 location);
++ void set(char *filename, Uint32 fSize, Uint32 cSize, Uint32 location);
+ };
diff --git a/games/blobwars/files/patch-src-CKeyboard.h b/games/blobwars/files/patch-src-CKeyboard.h
new file mode 100644
index 000000000000..7d8da3a6efbe
--- /dev/null
+++ b/games/blobwars/files/patch-src-CKeyboard.h
@@ -0,0 +1,10 @@
+--- src/CKeyboard.h.orig 2005-04-25 18:25:38.000000000 +0000
++++ src/CKeyboard.h 2007-10-31 02:29:26.000000000 +0000
+@@ -8,6 +8,6 @@
+
+ Keyboard();
+ void setDefaultKeys();
+- static char *Keyboard::translateKey(int value);
++ static char *translateKey(int value);
+
+ };