aboutsummaryrefslogtreecommitdiff
path: root/games/blockout
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-05-30 16:38:56 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-05-30 16:38:56 +0000
commitde9bba1607cd276b2e9b6daf14ad9e5d83b3582a (patch)
tree0d05e8248b451bf65b6e37cfb6f7eb19a39c0b67 /games/blockout
parent5f7c3559a94bfe6537fe2a308943f5c093cb97d2 (diff)
downloadports-de9bba1607cd276b2e9b6daf14ad9e5d83b3582a.tar.gz
ports-de9bba1607cd276b2e9b6daf14ad9e5d83b3582a.zip
Remove ALSA dependency. It's not required.
Approved by: lme (mentor) Differential Revision: https://reviews.freebsd.org/D10730
Notes
Notes: svn path=/head/; revision=442102
Diffstat (limited to 'games/blockout')
-rw-r--r--games/blockout/Makefile4
-rw-r--r--games/blockout/files/patch-Makefile12
2 files changed, 8 insertions, 8 deletions
diff --git a/games/blockout/Makefile b/games/blockout/Makefile
index e8dc2df1584d..0490110f8a09 100644
--- a/games/blockout/Makefile
+++ b/games/blockout/Makefile
@@ -3,7 +3,7 @@
PORTNAME= blockout
PORTVERSION= 2.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/BlockOut%20${PORTVERSION}/ \
http://www.stasyan.com/devel/distfiles/
@@ -14,8 +14,6 @@ COMMENT= BlockOut II is an adaptation of the original Blockout DOS game
LICENSE= GPLv2+
-LIB_DEPENDS= libasound.so:audio/alsa-lib
-
ONLY_FOR_ARCHS= i386 amd64
USE_SDL= mixer sdl
diff --git a/games/blockout/files/patch-Makefile b/games/blockout/files/patch-Makefile
index 04fcbbc9ba09..6b8ac18621a2 100644
--- a/games/blockout/files/patch-Makefile
+++ b/games/blockout/files/patch-Makefile
@@ -1,6 +1,6 @@
---- BlockOut/Makefile.orig 2014-05-06 13:47:56.000000000 +0400
-+++ BlockOut/Makefile 2016-05-23 20:37:54.725070000 +0300
-@@ -47,27 +47,27 @@
+--- BlockOut/Makefile.orig 2014-05-06 09:47:56 UTC
++++ BlockOut/Makefile
+@@ -47,27 +47,27 @@ else
SDL_LIBS = /usr/lib/i386-linux-gnu
endif
@@ -16,8 +16,9 @@
LFLAGS = -Wl,--strip-all \
$(ADD_LIBS) \
- -lSDL_mixer -lSDL -lasound \
+- -lSDL_mixer -lSDL -lasound \
- -lGL -lGLU -lpthread -lm -ldl
++ -lSDL_mixer -lSDL \
+ -lGL -lGLU -lpthread -lm
else
@@ -30,8 +31,9 @@
-LFLAGS = -L $(SDL_LIBS) \
+LFLAGS = -L $(LOCALBASE)/lib \
$(ADD_LIBS) \
- -lSDL_mixer -lSDL -lasound \
+- -lSDL_mixer -lSDL -lasound \
- -lGL -lGLU -lpthread -lm -ldl
++ -lSDL_mixer -lSDL \
+ -lGL -lGLU -lpthread -lm
endif