aboutsummaryrefslogtreecommitdiff
path: root/games/bloodfrontier
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-22 23:43:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-22 23:43:54 +0000
commit9828ded97fb370c2c4d10bcd326dc86c226680d9 (patch)
tree36203fda7e63ce95252d8ada564df0afb633c23d /games/bloodfrontier
parent917a5811d15c2ad922b723f3fe2ce2329d940b9b (diff)
downloadports-9828ded97fb370c2c4d10bcd326dc86c226680d9.tar.gz
ports-9828ded97fb370c2c4d10bcd326dc86c226680d9.zip
- Switch to options helpers
Notes
Notes: svn path=/head/; revision=397597
Diffstat (limited to 'games/bloodfrontier')
-rw-r--r--games/bloodfrontier/Makefile61
1 files changed, 29 insertions, 32 deletions
diff --git a/games/bloodfrontier/Makefile b/games/bloodfrontier/Makefile
index 306f3336c62f..50eb40d5d899 100644
--- a/games/bloodfrontier/Makefile
+++ b/games/bloodfrontier/Makefile
@@ -13,6 +13,10 @@ COMMENT= Single- and multi-player first-person shooter based on Cube 2
LICENSE= ZLIB
+BROKEN_ia64= does not compile
+BROKEN_powerpc= does not compile
+BROKEN_sparc64= does not compile
+
USES= tar:bzip2 gmake
GNU_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/src/enet
@@ -30,43 +34,36 @@ OPTIONS_MULTI= COMPONENTS
OPTIONS_MULTI_COMPONENTS=CLIENT DEDICATED
OPTIONS_DEFAULT= CLIENT DEDICATED OPTIMIZED_CFLAGS
-CLIENT_DESC= Build client
-CLIENT_USE= GL=gl SDL=image,mixer,sdl XORG=x11
-CLIENT_ALL_TARGET= client
-CLIENT_PLIST_FILES= bin/bfclient libexec/bfclient \
- share/pixmaps/${PORTNAME}.ico
-DEDICATED_DESC= Build dedicated server
-DEDICATED_PLIST_FILES= bin/bfserver libexec/bfserver
-DEDICATED_ALL_TARGET= server
-OPTIMIZED_CFLAGS_CFLAGS= -O3 -fomit-frame-pointer
-OPTIMIZED_CFLAGS_CXXFLAGS= -O3 -fomit-frame-pointer
+CLIENT_DESC= Build client
+CLIENT_USE= GL=gl SDL=image,mixer,sdl XORG=x11
+CLIENT_ALL_TARGET= client
+CLIENT_PLIST_FILES= bin/bfclient libexec/bfclient \
+ share/pixmaps/${PORTNAME}.ico
-.include <bsd.port.options.mk>
+CLIENT_DESKTOP_ENTRIES= "Blood Frontier" \
+ "" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
+ "bfclient" \
+ "Game;Shooter;" \
+ ""
+DEDICATED_DESC= Build dedicated server
+DEDICATED_PLIST_FILES= bin/bfserver libexec/bfserver
+DEDICATED_ALL_TARGET= server
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
-
-.if ${PORT_OPTIONS:MCLIENT}
-DESKTOP_ENTRIES="Blood Frontier" \
- "${COMMENT}" \
- "${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
- "bfclient" \
- "Game;Shooter;" \
- ""
-.endif
+OPTIMIZED_CFLAGS_CFLAGS= -O3 -fomit-frame-pointer
+OPTIMIZED_CFLAGS_CXXFLAGS= -O3 -fomit-frame-pointer
do-install:
-.for f in ${PLIST_FILES:Mbin/*}
- ${INSTALL_SCRIPT} ${WRKDIR}/${f:T} ${STAGEDIR}${PREFIX}/${f}
-.endfor
-.for f in ${PLIST_FILES:Mlibexec/*}
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${f:T} ${STAGEDIR}${PREFIX}/${f:H}
-.endfor
-.if ${PORT_OPTIONS:MCLIENT}
+ (cd ${WRKSRC}/data && ${COPYTREE_SHARE} "." ${STAGEDIR}${DATADIR})
+
+do-install-CLIENT-on:
+ ${INSTALL_SCRIPT} ${WRKDIR}/bfclient ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/bfclient ${STAGEDIR}${PREFIX}/libexec/
${INSTALL_DATA} ${WRKSRC}/src/${PORTNAME}.ico \
${STAGEDIR}${PREFIX}/share/pixmaps
-.endif
- (cd ${WRKSRC}/data && ${COPYTREE_SHARE} "." ${STAGEDIR}${DATADIR})
+
+do-install-DEDICATED-on:
+ ${INSTALL_SCRIPT} ${WRKDIR}/bfserver ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/bfserver ${STAGEDIR}${PREFIX}/libexec/
.include <bsd.port.mk>