aboutsummaryrefslogtreecommitdiff
path: root/games/bombherman
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-20 18:05:17 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-20 18:05:17 +0000
commit92399528a7b2dd04c56e4856fe5679df8c05f380 (patch)
tree566afdb320026f8c71a5d5b2efba04060a0f86b2 /games/bombherman
parent43bb1b5c2dd77c2a12a9b44cc488f620db6b7948 (diff)
downloadports-92399528a7b2dd04c56e4856fe5679df8c05f380.tar.gz
ports-92399528a7b2dd04c56e4856fe5679df8c05f380.zip
Notes
Diffstat (limited to 'games/bombherman')
-rw-r--r--games/bombherman/Makefile29
-rw-r--r--games/bombherman/distinfo4
-rw-r--r--games/bombherman/pkg-plist22
3 files changed, 38 insertions, 17 deletions
diff --git a/games/bombherman/Makefile b/games/bombherman/Makefile
index 6a5f37ded060..968909c98a78 100644
--- a/games/bombherman/Makefile
+++ b/games/bombherman/Makefile
@@ -1,23 +1,21 @@
-# Created by: nemysis@gmx.ch
-#
+# Created by: nemysis@gmx.ch
# $FreeBSD$
PORTNAME= bomb-her-man
PORTVERSION= 0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= GH \
SF/nemysisfreebsdp/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
- ${PORTNAME}_icons.tar.gz:icons
+ ${PORTNAME}_icons${EXTRACT_SUFX}:icons
MAINTAINER= nemysis@gmx.ch
COMMENT= Bomberman clone written in C++
LICENSE= GPLv3
-BUILD_DEPENDS= automake:${PORTSDIR}/devel/automake \
- p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
USE_GITHUB= yes
@@ -29,7 +27,7 @@ GH_COMMIT= 8f5aa22
USE_SDL= sdl image mixer ttf
USE_GNOME= intltool librsvg2
GNU_CONFIGURE= yes
-AUTOMAKE_ARGS= --add-missing
+USE_AUTOTOOLS= automake:env
USE_GMAKE= yes
ALL_TARGET= # empty
MAKE_JOBS_SAFE= yes
@@ -39,12 +37,16 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= AUTHORS ChangeLog NEWS README
-DESKTOP_ENTRIES="Bomb-her-man" "Bomberman clone" \
- "${PREFIX}/share/pixmaps/${PORTNAME}_48.png" \
+INSTALLS_ICONS= yes
+ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
+
+DESKTOP_ENTRIES="Bomb-her-man" "Bomberman clone" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" false
OPTIONS_DEFINE= NLS
-OPTIONS_DEFAULT= NLS
+
+# Wrong versioning upstream
+PORTSCOUT= ignore:1
.include <bsd.port.options.mk>
@@ -65,7 +67,12 @@ pre-configure:
.endif
post-install:
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}*.png ${PREFIX}/share/pixmaps
+.for s in ${ICON_SIZES}
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
+ ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
diff --git a/games/bombherman/distinfo b/games/bombherman/distinfo
index 20c698c8af1a..caebd61de8ae 100644
--- a/games/bombherman/distinfo
+++ b/games/bombherman/distinfo
@@ -1,4 +1,4 @@
SHA256 (bomb-her-man-0.3.tar.gz) = 6ccf847f7452afaec664ee6f0dae50895ed7138bfc27479254e539d56b8cca9c
SIZE (bomb-her-man-0.3.tar.gz) = 2019211
-SHA256 (bomb-her-man_icons.tar.gz) = b2a402bd226ccb324c0b9dbe24540da99880409ca2d2e862725eb08120c02978
-SIZE (bomb-her-man_icons.tar.gz) = 29696
+SHA256 (bomb-her-man_icons.tar.gz) = 40be2e1ab029822d6acdbe35914a9169c4401e9a53e04bd500f44fe0253a3ac1
+SIZE (bomb-her-man_icons.tar.gz) = 32256
diff --git a/games/bombherman/pkg-plist b/games/bombherman/pkg-plist
index cefb2c7593ca..775ad8653375 100644
--- a/games/bombherman/pkg-plist
+++ b/games/bombherman/pkg-plist
@@ -54,11 +54,25 @@ bin/bomb-her-man
%%DATADIR%%/graphics/scores/background-vertical.svg
%%DATADIR%%/graphics/tomb1.svg
%%DATADIR%%/graphics/tomb2.svg
+share/icons/hicolor/32x32/apps/bomb-her-man.png
+share/icons/hicolor/48x48/apps/bomb-her-man.png
+share/icons/hicolor/64x64/apps/bomb-her-man.png
+share/icons/hicolor/72x72/apps/bomb-her-man.png
+share/icons/hicolor/96x96/apps/bomb-her-man.png
%%NLS%%share/locale/fr/LC_MESSAGES/bomb-her-man.mo
-share/pixmaps/bomb-her-man_48.png
-share/pixmaps/bomb-her-man_64.png
-share/pixmaps/bomb-her-man_72.png
-share/pixmaps/bomb-her-man_96.png
+share/pixmaps/bomb-her-man.png
+@dirrmtry share/icons/hicolor/96x96/apps
+@dirrmtry share/icons/hicolor/96x96
+@dirrmtry share/icons/hicolor/72x72/apps
+@dirrmtry share/icons/hicolor/72x72
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
@dirrm %%DATADIR%%/graphics/scores/2
@dirrm %%DATADIR%%/graphics/scores/1
@dirrm %%DATADIR%%/graphics/scores