aboutsummaryrefslogtreecommitdiff
path: root/games/bomns
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
commit3a283e24f296371e9b753c09e3e62a92ef3d8703 (patch)
tree88e0a2bbddafb5c9bdc18e8e02c5e59fb9f9d471 /games/bomns
parent7a0a8929bea1c510b4f30261d294a78b556b49d7 (diff)
downloadports-3a283e24f296371e9b753c09e3e62a92ef3d8703.tar.gz
ports-3a283e24f296371e9b753c09e3e62a92ef3d8703.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=299119
Diffstat (limited to 'games/bomns')
-rw-r--r--games/bomns/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/games/bomns/Makefile b/games/bomns/Makefile
index 789718158e08..3b3950887d18 100644
--- a/games/bomns/Makefile
+++ b/games/bomns/Makefile
@@ -24,20 +24,21 @@ CPPFLAGS+= `${SDL_CONFIG} --cflags`
LDFLAGS+= `${SDL_CONFIG} --libs`
CONFIGURE_ARGS= --program-transform-name=
-OPTIONS= EDITOR "Enable building of the map editor" on \
- LAUNCHER "Enable building of the GTK2 launcher" on \
- OPTIMIZED_CFLAGS "Enable compilation optimizations" on
+OPTIONS_DEFINE= EDITOR LAUNCHER OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT= EDITOR LAUNCHER OPTIMIZED_CFLAGS
+EDITOR_DESC= Enable building of the map editor
+LAUNCHER_DESC= Enable building of the GTK2 launcher
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_EDITOR)
+.if ${PORT_OPTIONS:MEDITOR}
PLIST_SUB+= EDITOR=""
.else
CONFIGURE_ARGS+=--disable-editor
PLIST_SUB+= EDITOR="@comment "
.endif
-.if !defined(WITHOUT_LAUNCHER)
+.if ${PORT_OPTIONS:MLAUNCHER}
USE_GNOME= gtk20
PLIST_SUB+= LAUNCHER=""
.else
@@ -61,8 +62,8 @@ post-patch:
.endfor
# Enable/disable compilation optimizations.
-.if defined(WITHOUT_OPTIMIZED_CFLAGS)
+.if empty(PORT_OPTIONS:MOPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e 's|-O2||' ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>