aboutsummaryrefslogtreecommitdiff
path: root/games/briquolo
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-19 17:56:28 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-19 17:56:28 +0000
commitf9e54c645d51708ef01839c7cb8aeee482fa8001 (patch)
tree8a831c57656776b3c689d17a2f5cae2456ae1502 /games/briquolo
parentd4420cd94876577cc7a61a44c994a9d3f8b78868 (diff)
downloadports-f9e54c645d51708ef01839c7cb8aeee482fa8001.tar.gz
ports-f9e54c645d51708ef01839c7cb8aeee482fa8001.zip
Notes
Diffstat (limited to 'games/briquolo')
-rw-r--r--games/briquolo/Makefile34
-rw-r--r--games/briquolo/distinfo1
-rw-r--r--games/briquolo/files/patch-src-MOGL-MOGL_GenerateurParticule.h10
-rw-r--r--games/briquolo/pkg-descr3
-rw-r--r--games/briquolo/pkg-plist90
5 files changed, 138 insertions, 0 deletions
diff --git a/games/briquolo/Makefile b/games/briquolo/Makefile
new file mode 100644
index 000000000000..20fcc2922339
--- /dev/null
+++ b/games/briquolo/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: briquolo
+# Date created: 18 Nov 2003
+# Whom: Kirill Ponomarew <krion@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= briquolo
+PORTVERSION= 0.4.1
+CATEGORIES= games
+MASTER_SITES= http://briquolo.free.fr/download/
+
+MAINTAINER= krion@FreeBSD.org
+COMMENT= Breakout clone with an OpenGL 3D representation
+
+LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
+ GUI.0:${PORTSDIR}/graphics/guilib
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+USE_SDL= yes
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.cpp" | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|SDL/|SDL11/|g'
+ @${FIND} ${WRKSRC} -name "*.h" | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|SDL/|SDL11/|g'
+
+.include <bsd.port.mk>
diff --git a/games/briquolo/distinfo b/games/briquolo/distinfo
new file mode 100644
index 000000000000..4ea6aeffc344
--- /dev/null
+++ b/games/briquolo/distinfo
@@ -0,0 +1 @@
+MD5 (briquolo-0.4.1.tar.bz2) = 765517b572f56dba96e1670bd18acd51
diff --git a/games/briquolo/files/patch-src-MOGL-MOGL_GenerateurParticule.h b/games/briquolo/files/patch-src-MOGL-MOGL_GenerateurParticule.h
new file mode 100644
index 000000000000..4ed6115dab3a
--- /dev/null
+++ b/games/briquolo/files/patch-src-MOGL-MOGL_GenerateurParticule.h
@@ -0,0 +1,10 @@
+--- src/MOGL/MOGL_GenerateurParticule.h.orig Sun Oct 19 19:40:24 2003
++++ src/MOGL/MOGL_GenerateurParticule.h Sun Oct 19 19:40:54 2003
+@@ -22,6 +22,7 @@
+ #ifndef MOGL_GENERATEURPARTICULE
+ #define MOGL_GENERATEURPARTICULE
+
++#include <sys/types.h>
+ #include <list>
+ #include <sys/timeb.h>
+
diff --git a/games/briquolo/pkg-descr b/games/briquolo/pkg-descr
new file mode 100644
index 000000000000..1611f8cb200e
--- /dev/null
+++ b/games/briquolo/pkg-descr
@@ -0,0 +1,3 @@
+Briquolo is a breakout with 3D representation based on OpenGL.
+
+WWW: http://briquolo.free.fr/en/
diff --git a/games/briquolo/pkg-plist b/games/briquolo/pkg-plist
new file mode 100644
index 000000000000..0e56e52cc5d6
--- /dev/null
+++ b/games/briquolo/pkg-plist
@@ -0,0 +1,90 @@
+bin/briquolo
+share/briquolo/0.4.1
+share/briquolo/data/Environment.1.png
+share/briquolo/data/Environment.2.png
+share/briquolo/data/Environment.3.png
+share/briquolo/data/Environment.4.png
+share/briquolo/data/Environment.5.png
+share/briquolo/data/Environment.6.png
+share/briquolo/data/Flare1.bmp
+share/briquolo/data/Flare1.png
+share/briquolo/data/Flare2.bmp
+share/briquolo/data/Flare3.bmp
+share/briquolo/data/Flare4.bmp
+share/briquolo/data/Shine1.bmp
+share/briquolo/data/Shine1.png
+share/briquolo/data/Shine2.bmp
+share/briquolo/data/balle.png
+share/briquolo/data/balle.tri
+share/briquolo/data/bois.png
+share/briquolo/data/bonus.wav
+share/briquolo/data/bonus_doubleballe.tri
+share/briquolo/data/bonus_fast.tri
+share/briquolo/data/bonus_gros.tri
+share/briquolo/data/bonus_grosplateau.png
+share/briquolo/data/bonus_grosplateau.tri
+share/briquolo/data/bonus_petit.tri
+share/briquolo/data/bonus_petitplateau.png
+share/briquolo/data/bonus_petitplateau.tri
+share/briquolo/data/bonus_slow.tri
+share/briquolo/data/bonus_superpuissance.tri
+share/briquolo/data/bonus_vuesubjective.tri
+share/briquolo/data/breche.png
+share/briquolo/data/breche.wav
+share/briquolo/data/brique.png
+share/briquolo/data/brique.tri
+share/briquolo/data/brique_breche.tri
+share/briquolo/data/brique_deuxcoups.png
+share/briquolo/data/brique_deuxcoups.tri
+share/briquolo/data/brique_incassable.png
+share/briquolo/data/brique_incassable.tri
+share/briquolo/data/brique_rebond.wav
+share/briquolo/data/double.png
+share/briquolo/data/eau2.png
+share/briquolo/data/env.tri
+share/briquolo/data/explosion2.wav
+share/briquolo/data/fast.png
+share/briquolo/data/flare.bmp
+share/briquolo/data/grille.png
+share/briquolo/data/gros.png
+share/briquolo/data/herbe.png
+share/briquolo/data/imageplateau.png
+share/briquolo/data/mur1.png
+share/briquolo/data/petit.png
+share/briquolo/data/petite_brique.png
+share/briquolo/data/petite_brique.tri
+share/briquolo/data/petite_police.ftx
+share/briquolo/data/pierre.png
+share/briquolo/data/plateau.png
+share/briquolo/data/plateau_droite.tri
+share/briquolo/data/plateau_gauche.tri
+share/briquolo/data/plateau_milieu.tri
+share/briquolo/data/police.ftx
+share/briquolo/data/rebond.wav
+share/briquolo/data/slow.png
+share/briquolo/data/superpuissance.png
+share/briquolo/data/superpuissance.wav
+share/briquolo/data/tableau.tri
+share/briquolo/data/vie.ftx
+share/briquolo/data/vuesubjective.png
+share/briquolo/tableau/001.tab
+share/briquolo/tableau/002.tab
+share/briquolo/tableau/003.tab
+share/briquolo/tableau/004.tab
+share/briquolo/tableau/005.tab
+share/briquolo/tableau/006.tab
+share/briquolo/tableau/007.tab
+share/briquolo/tableau/008.tab
+share/briquolo/tableau/009.tab
+share/briquolo/tableau/010.tab
+share/briquolo/tableau/011.tab
+share/briquolo/tableau/012.tab
+share/briquolo/tableau/013.tab
+share/briquolo/tableau/014.tab
+share/briquolo/tableau/015.tab
+share/briquolo/tableau/016.tab
+share/locale/fr/LC_MESSAGES/briquolo.mo
+share/locale/nl/LC_MESSAGES/briquolo.mo
+@dirrm share/briquolo/data
+@dirrm share/briquolo/tableau
+@dirrm share/briquolo