aboutsummaryrefslogtreecommitdiff
path: root/games/brutalchess/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-08 22:36:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-02-08 22:36:23 +0000
commitb80110d7a12995212c1c2832670f3f1283d65228 (patch)
tree27a74ef41261492638ceb902f9971c1e8746f989 /games/brutalchess/Makefile
parentb376475a2956fef45d9a54c6771315c78fc162ff (diff)
downloadports-b80110d7a12995212c1c2832670f3f1283d65228.tar.gz
ports-b80110d7a12995212c1c2832670f3f1283d65228.zip
Notes
Diffstat (limited to 'games/brutalchess/Makefile')
-rw-r--r--games/brutalchess/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/games/brutalchess/Makefile b/games/brutalchess/Makefile
new file mode 100644
index 000000000000..4b81da89f442
--- /dev/null
+++ b/games/brutalchess/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Brutalchess
+# Date created: 2005-02-07
+# Whom: Gustavo Perez Querol <gustau.perez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= brutalchess
+PORTVERSION= 0.5.1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-alpha-${PORTVERSION}-src
+
+MAINTAINER= gustau.perez@gmail.com
+COMMENT= Nice looking OpenGL chess game
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+CONFIGURE_TARGET= --target=${ARCH}-unknown-freebsd${OSREL}
+
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+
+USE_GL= yes
+USE_SDL= sdl image
+
+pre-build:
+ ${CHMOD} 0755 ${WRKSRC}/install-sh
+
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>