aboutsummaryrefslogtreecommitdiff
path: root/games/bsdgames
diff options
context:
space:
mode:
authorUlrich Spörlein <uqs@FreeBSD.org>2012-05-25 10:50:07 +0000
committerUlrich Spörlein <uqs@FreeBSD.org>2012-05-25 10:50:07 +0000
commit037d27a3158ce21cf941743853362f41b087b4bb (patch)
tree59947dedfe730862f2599c3c545220b27c372ff3 /games/bsdgames
parent9109fc66395ff2e41bb0529aff0e131481859337 (diff)
downloadports-037d27a3158ce21cf941743853362f41b087b4bb.tar.gz
ports-037d27a3158ce21cf941743853362f41b087b4bb.zip
Fix battlestar(6), there was treachery afoot, see the newsflash.
*BATTLESTAR NEWSFLASH*BATTLESTAR NEWSFLASH*BATTLESTAR NEWSFLASH* Battlestar Daily uncovers heinous sabotage scheme! Leaked mission radio protocols show losing grip on reality. In what flabbergasted experts describe as a 'highly efficient, covert thingie'-scheme, members of our forces involved in highly classified operations suffered a dramatic loss of vital sensorical capabilities, leading to desastrous results. From leaked radio recordings and its own sources involved in mission preparation and conduct, BD learned shocking details of failed missions. While sources insist, that missions parameters were in normal range at all times, the recordings reveal disoriented operatives, sobbingly crawling floors looking for gear like laser pistols, or panicking over loss of visuals after battles in space. 'Odd.', one expert is quoted saying after reviewing detailed mission protocols, clearly admitting to this being a deliberate act of sabotage. 'They need to adapt to this new threat.', says Vidad Gleirg, Battlestar senior consultant with Anagram & Partners, 'Quickly.'. BD has notified officials of the situation, and is awaiting responses. PR: ports/166319 Submitted by: Marco Steinbach <coco@executive-computing.de> Approved by: beat (mentor)
Notes
Notes: svn path=/head/; revision=297396
Diffstat (limited to 'games/bsdgames')
-rw-r--r--games/bsdgames/Makefile2
-rw-r--r--games/bsdgames/files/patch-battlestar34
2 files changed, 35 insertions, 1 deletions
diff --git a/games/bsdgames/Makefile b/games/bsdgames/Makefile
index ad88e50fddee..0333a36df354 100644
--- a/games/bsdgames/Makefile
+++ b/games/bsdgames/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bsdgames
PORTVERSION= 2.4
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= games
# Fetched from http://gitweb.dragonflybsd.org/dragonfly.git/tree/v2.4.0:/games
diff --git a/games/bsdgames/files/patch-battlestar b/games/bsdgames/files/patch-battlestar
new file mode 100644
index 000000000000..f2f85218cae0
--- /dev/null
+++ b/games/bsdgames/files/patch-battlestar
@@ -0,0 +1,34 @@
+diff -Naur battlestar.orig/fly.c battlestar/fly.c
+--- battlestar.orig/fly.c 2012-03-22 13:59:00.000000000 +0100
++++ battlestar/fly.c 2012-03-22 13:59:09.000000000 +0100
+@@ -294,6 +294,7 @@
+ signal(SIGALRM, SIG_DFL);
+ mvcur(0,COLS-1,LINES-1,0);
+ endwin();
++ setlinebuf(stdout);
+ signal(SIGTSTP, SIG_DFL);
+ signal(SIGINT, oldsig);
+ }
+--- battlestar/externs.h.orig 2012-05-25 11:57:52.000000000 +0200
++++ battlestar/externs.h 2012-05-25 11:57:55.000000000 +0200
+@@ -44,15 +44,18 @@
+ #include <string.h>
+ #include <unistd.h>
+
++/* We use our own */
++#undef setbit
++#undef testbit
++#undef clearbit
++
+ #define BITS (8)
+
+ #define OUTSIDE (position > 68 && position < 246 && position != 218)
+ #define rnd(x) (random() % (x))
+ #define max(a,b) ((a) < (b) ? (b) : (a))
+ #define testbit(array, index) (array[index/BITS] & (1 << (index % BITS)))
+-#ifndef setbit
+ #define setbit(array, index) (array[index/BITS] |= (1 << (index % BITS)))
+-#endif
+ #define clearbit(array, index) (array[index/BITS] &= ~(1 << (index % BITS)))
+
+ /* well known rooms */