aboutsummaryrefslogtreecommitdiff
path: root/games/bsp
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-04 09:25:44 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-03-04 09:25:44 +0000
commit0dc9612057db7f73e7ed279950113eb71770831e (patch)
tree68daccded21c3be770d0a3e11e21dc888668381c /games/bsp
parentc8bf9ce551eac056127719013c6e31b202b0f08c (diff)
downloadports-0dc9612057db7f73e7ed279950113eb71770831e.tar.gz
ports-0dc9612057db7f73e7ed279950113eb71770831e.zip
BROKEN on sparc64: Does not compile
Notes
Notes: svn path=/head/; revision=102905
Diffstat (limited to 'games/bsp')
-rw-r--r--games/bsp/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/bsp/Makefile b/games/bsp/Makefile
index fc0b6f676726..505000db656b 100644
--- a/games/bsp/Makefile
+++ b/games/bsp/Makefile
@@ -17,6 +17,12 @@ COMMENT= Node builder for Doom
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s,-O2 -fomit-frame-pointer -ffast-math,${CFLAGS}," \
${WRKSRC}/configure
@@ -28,4 +34,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>