aboutsummaryrefslogtreecommitdiff
path: root/games/burgerspace/Makefile
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2019-11-15 11:00:18 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2019-11-15 11:00:18 +0000
commitca02b2baaa9cb94d357ab9274fb5384208a253ae (patch)
tree40a24384b870f311d7b3212af59943ab1d68761a /games/burgerspace/Makefile
parenta4a82891ae6d2890e88eede019b108eb789c8d60 (diff)
downloadports-ca02b2baaa9cb94d357ab9274fb5384208a253ae.tar.gz
ports-ca02b2baaa9cb94d357ab9274fb5384208a253ae.zip
Notes
Diffstat (limited to 'games/burgerspace/Makefile')
-rw-r--r--games/burgerspace/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/games/burgerspace/Makefile b/games/burgerspace/Makefile
index 6bb2ee96186e..edeb991f850c 100644
--- a/games/burgerspace/Makefile
+++ b/games/burgerspace/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= burgerspace
-PORTVERSION= 1.9.2
-PORTREVISION= 2
+PORTVERSION= 1.9.3
CATEGORIES= games
MASTER_SITES= http://perso.b2b2c.ca/~sarrazip/dev/ \
LOCAL/martymac
@@ -17,20 +16,18 @@ LIB_DEPENDS= libflatzebra-0.1.so:devel/flatzebra
USES= pkgconfig sdl
USE_CXXSTD= gnu++98
-USE_SDL= mixer sdl
+USE_SDL= image mixer sdl
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-PORTDOCS= AUTHORS COPYING INSTALL NEWS README THANKS TODO
+PORTDOCS= AUTHORS COPYING NEWS README THANKS
OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e 's|^pkgsounddir =.*|pkgsounddir = ${DATADIR}/sounds|' \
+ @${REINPLACE_CMD} 's|^pkgsounddir =.*|pkgsounddir = ${DATADIR}/sounds|' \
${WRKSRC}/src/Makefile.in
- @${REINPLACE_CMD} -e 's|docdir = .*|docdir = ${DOCSDIR}|' \
+ @${REINPLACE_CMD} 's|^docdir = .*|docdir = ${DOCSDIR}|' \
${WRKSRC}/Makefile.in
.include <bsd.port.mk>