aboutsummaryrefslogtreecommitdiff
path: root/games/bygfoot
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-17 12:15:00 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-17 12:15:00 +0000
commit84007e8715ca906283b4c38eadc23710c1e47894 (patch)
tree2b573a8883c186f8de8f6038c503531bbed04bd3 /games/bygfoot
parentcf3baa4f818f491d749f55ccab267a3b0ee164ff (diff)
- Update to 1.4.2
Notes
Notes: svn path=/head/; revision=113811
Diffstat (limited to 'games/bygfoot')
-rw-r--r--games/bygfoot/Makefile2
-rw-r--r--games/bygfoot/distinfo4
-rw-r--r--games/bygfoot/files/patch-src-games.c42
3 files changed, 45 insertions, 3 deletions
diff --git a/games/bygfoot/Makefile b/games/bygfoot/Makefile
index 61298574626a..69d8da20747c 100644
--- a/games/bygfoot/Makefile
+++ b/games/bygfoot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bygfoot
-PORTVERSION= 1.4.1
+PORTVERSION= 1.4.2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/games/bygfoot/distinfo b/games/bygfoot/distinfo
index 849d0f01e36a..9e47dff23418 100644
--- a/games/bygfoot/distinfo
+++ b/games/bygfoot/distinfo
@@ -1,2 +1,2 @@
-MD5 (bygfoot-1.4.1.tar.bz2) = 0cfed4affc9ad3865b4a449c591582d8
-SIZE (bygfoot-1.4.1.tar.bz2) = 248727
+MD5 (bygfoot-1.4.2.tar.bz2) = 7eb56353a62500d7d08c207682e4e27c
+SIZE (bygfoot-1.4.2.tar.bz2) = 248654
diff --git a/games/bygfoot/files/patch-src-games.c b/games/bygfoot/files/patch-src-games.c
new file mode 100644
index 000000000000..25773c0931cf
--- /dev/null
+++ b/games/bygfoot/files/patch-src-games.c
@@ -0,0 +1,42 @@
+--- src/games.c.orig Mon Jul 12 10:33:02 2004
++++ src/games.c Sat Jul 17 14:05:39 2004
+@@ -436,9 +436,6 @@
+ gint i;
+ gfloat random = rnd(0,1);
+
+- if(debug && fix.team_id[team] == my_team)
+- return;
+-
+ player *pl =
+ &(teams[fix.team_id[team]].players[player_number]);
+
+@@ -454,6 +451,9 @@
+ in weeks: 1,2,3,4 or 5 */
+ gfloat duration[6]={0,0.7,0.85,0.95,0.975,1};
+
++ if(debug && fix.team_id[team] == my_team)
++ return;
++
+ /* injured or banned players don't really participate
+ in the game */
+ if(!pl->cskill ||
+@@ -496,9 +496,6 @@
+ gint i;
+ gfloat random = rnd(0,1);
+
+- if(debug && fix.team_id[team] == my_team)
+- return;
+-
+ /* for convenience, so as not to write
+ teams[fix.team_id[team]].players[player_number]
+ each time */
+@@ -538,6 +535,9 @@
+ {4,12},{5,12},{6,16},{3,8},
+ {5,14},{12,30}};
+
++ if(debug && fix.team_id[team] == my_team)
++ return;
++
+ for(i=1;i<12;i++)
+ if(injury_probs[i - 1] * prob < random &&
+ random <= injury_probs[i] * prob &&