aboutsummaryrefslogtreecommitdiff
path: root/games/cake
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-03-06 08:51:07 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-03-06 08:51:07 +0000
commitdcee42192bb1e592ecc68f9eb006c958611894ce (patch)
tree3ced7a55a210205c75546daf80c5d658973e0880 /games/cake
parent7575ccd280220a09ec5717b375ff82460e25d365 (diff)
downloadports-dcee42192bb1e592ecc68f9eb006c958611894ce.tar.gz
ports-dcee42192bb1e592ecc68f9eb006c958611894ce.zip
Unbreak the build against Clang 4.0.
PR: 216629
Notes
Notes: svn path=/head/; revision=435522
Diffstat (limited to 'games/cake')
-rw-r--r--games/cake/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/cake/Makefile b/games/cake/Makefile
index e839ce660574..a0cb7749cd5e 100644
--- a/games/cake/Makefile
+++ b/games/cake/Makefile
@@ -39,8 +39,9 @@ post-patch: .SILENT
${WRKSRC}/cake/sound.h
# Use traditional mapping for console key (tilde)
${REINPLACE_CMD} -e 's/167/96/' ${WRKSRC}/main.cpp
-# Fix for GCC 4.x
+# Fixes for GCC 4.x and Clang 4.0
${REINPLACE_CMD} -e 's/Mat3x2:://' ${WRKSRC}/cake/math.h
+ ${REINPLACE_CMD} -e '2852s/numverts/&[0]/' ${WRKSRC}/cake/q3bsp.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/main ${STAGEDIR}${PREFIX}/bin/cake