aboutsummaryrefslogtreecommitdiff
path: root/games/cataclysm-dda
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-27 16:00:49 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-05-27 16:00:49 +0000
commit8416961f94f98665fb22db283d6aa5241eb76f65 (patch)
tree7e54c3496ccc0bea5358ac0b74147c147f7b1881 /games/cataclysm-dda
parentb9bf240d32b62b5fbbb8a4156b95ff94c408c3c7 (diff)
downloadports-8416961f94f98665fb22db283d6aa5241eb76f65.tar.gz
ports-8416961f94f98665fb22db283d6aa5241eb76f65.zip
Mark some ports failing on armv6, for errors classified as "clang_werror".
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=441850
Diffstat (limited to 'games/cataclysm-dda')
-rw-r--r--games/cataclysm-dda/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/games/cataclysm-dda/Makefile b/games/cataclysm-dda/Makefile
index 26aec076a888..c5d452eeb92d 100644
--- a/games/cataclysm-dda/Makefile
+++ b/games/cataclysm-dda/Makefile
@@ -13,6 +13,10 @@ COMMENT= Fork/variant of Cataclysm Roguelike by Whales
LICENSE= CC-BY-SA-3.0
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BROKEN_aarch64= fails to compile: comparison of integers of different signs: wchar_t and const int
+BROKEN_armv6= fails to compile: comparison of integers of different signs: wchar_t and const int
+BROKEN_powerpc64= fails to compile: overmap.cpp: 'pow' is not a member of 'std'
+
USES= alias compiler:c++11-lib execinfo gmake shebangfix
SHEBANG_FILES= lang/*.sh
bash_CMD= /bin/sh
@@ -60,10 +64,6 @@ SOUND_IMPLIES= SDL
SOUND_FILES= cataclysmthemeREV6.ogg Dark_Days_Ahead_demo_2.ogg
-BROKEN_aarch64= fails to compile: comparison of integers of different signs: wchar_t and const int
-BROKEN_armv6= fails to compile: comparison of integers of different signs: wchar_t and const int
-BROKEN_powerpc64= fails to compile: overmap.cpp: 'pow' is not a member of 'std'
-
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 36