aboutsummaryrefslogtreecommitdiff
path: root/games/cheech/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-07-28 21:16:06 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-07-28 21:16:06 +0000
commit44eab91c9f4fc7af6439c803786975f57b9cbfa1 (patch)
tree992a8855feced3d73d6de780b893c71f6d6619c1 /games/cheech/Makefile
parent8e49fb740d4abc1bbd5da04011ef8f14764870a1 (diff)
downloadports-44eab91c9f4fc7af6439c803786975f57b9cbfa1.tar.gz
ports-44eab91c9f4fc7af6439c803786975f57b9cbfa1.zip
Notes
Diffstat (limited to 'games/cheech/Makefile')
-rw-r--r--games/cheech/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/games/cheech/Makefile b/games/cheech/Makefile
new file mode 100644
index 000000000000..85edcf8d55ad
--- /dev/null
+++ b/games/cheech/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: cheech
+# Date created: 18 Jul 2007
+# Whom: Yinghong.Liu <relaxbsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cheech
+PORTVERSION= 0.8
+CATEGORIES= games
+MASTER_SITES= SF
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= relaxbsd@gmail.com
+COMMENT= A multi-platform, networked Chinese Checkers game
+
+LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ gnet-2.0.0:${PORTSDIR}/net/gnet2
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= automake:19:env
+
+DESKTOP_ENTRIES= "cheech" \
+ "A networked Chinese Checkers Game" \
+ "cheech" \
+ "cheech" \
+ "Application;Game;" \
+ "false"
+
+.if !defined(NOPORTDOCS)
+INSTALL_TARGET= install install-cheechdocDATA
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|doc/cheech|share/doc/cheech|g" \
+ -e "s|: install-cheechdocDATA|:|g" \
+ ${WRKSRC}/Makefile.in
+
+pre-configure:
+ @${LN} -sf ${AUTOMAKE_DIR}/install-sh ${WRKSRC}
+
+.include <bsd.port.mk>